summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2015-03-22 09:09:50 +0000
committerJohann Schmitz <ercpe@gentoo.org>2015-03-22 09:09:50 +0000
commit06bb544629a0d73fa10aea68e4d080e7155490fa (patch)
tree00258b182adfb2299dbd282c98007d184d01f729 /net-misc
parentNew ebuild for tablelayout (diff)
downloadgentoo-2-06bb544629a0d73fa10aea68e4d080e7155490fa.tar.gz
gentoo-2-06bb544629a0d73fa10aea68e4d080e7155490fa.tar.bz2
gentoo-2-06bb544629a0d73fa10aea68e4d080e7155490fa.zip
Version bump of yajhfc; build from source
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yajhfc/ChangeLog7
-rw-r--r--net-misc/yajhfc/yajhfc-0.5.7.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-misc/yajhfc/ChangeLog b/net-misc/yajhfc/ChangeLog
index 8c98b828ce53..acb84b216f9b 100644
--- a/net-misc/yajhfc/ChangeLog
+++ b/net-misc/yajhfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/yajhfc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/yajhfc/ChangeLog,v 1.3 2015/03/21 19:44:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yajhfc/ChangeLog,v 1.4 2015/03/22 09:09:50 ercpe Exp $
+
+*yajhfc-0.5.7 (22 Mar 2015)
+
+ 22 Mar 2015; Johann Schmitz <ercpe@gentoo.org> +yajhfc-0.5.7.ebuild:
+ Version bump of yajhfc; build from source
21 Mar 2015; Justin Lecher <jlec@gentoo.org> metadata.xml,
yajhfc-0.5.2.ebuild:
diff --git a/net-misc/yajhfc/yajhfc-0.5.7.ebuild b/net-misc/yajhfc/yajhfc-0.5.7.ebuild
new file mode 100644
index 000000000000..168342b354db
--- /dev/null
+++ b/net-misc/yajhfc/yajhfc-0.5.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yajhfc/yajhfc-0.5.7.ebuild,v 1.1 2015/03/22 09:09:50 ercpe Exp $
+
+EAPI=5
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-${PV}"
+MY_P="${MY_P/_/}"
+MY_P="${MY_P/./_}"
+MY_P="${MY_P/./_}"
+
+DESCRIPTION="Yet another Java HylaFAX Plus Client"
+HOMEPAGE="http://www.yajhfc.de/"
+SRC_URI="http://download.yajhfc.de/releases/${MY_P}-src.zip"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/gnu-hylafax:0
+ dev-java/tablelayout:0"
+RDEPEND="${COMMON_DEPEND} >=virtual/jre-1.6"
+DEPEND="${COMMON_DEPEND} >=virtual/jdk-1.6 virtual/pkgconfig app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+JAVA_GENTOO_CLASSPATH="gnu-hylafax,tablelayout"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ rm build.xml || die
+ rm -rv "${S}"/jna-src "${S}"/mac-src || die # contains win32/mac only code
+
+ cp -r java1-src/* src || die
+ cp -r java6-src/* src || die
+
+ # this method is missing in the gnu-hylafax api despite they use the same upstream version
+ sed -i -e 's/client.setCharacterEncoding.*//g' src/yajhfc/HylaClientManager.java || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ pushd src || die
+ find -type f -not -name "*.java" -not -name "*.class" | xargs jar uf "${S}"/${PN}.jar || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar --main yajhfc.Launcher
+}