summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-07 19:33:20 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-07 19:33:20 +0000
commitc86652a13b1b1aef0a8bdbcdbe89d6c328eefe2a (patch)
treec5560b61ba918925fc77ef2881b5f8e3f60d9f03 /net-misc/youtube-viewer
parentMarked ~hppa (bug #450672). (diff)
downloadgentoo-2-c86652a13b1b1aef0a8bdbcdbe89d6c328eefe2a.tar.gz
gentoo-2-c86652a13b1b1aef0a8bdbcdbe89d6c328eefe2a.tar.bz2
gentoo-2-c86652a13b1b1aef0a8bdbcdbe89d6c328eefe2a.zip
update live ebuild
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'net-misc/youtube-viewer')
-rw-r--r--net-misc/youtube-viewer/ChangeLog5
-rw-r--r--net-misc/youtube-viewer/youtube-viewer-9999.ebuild25
2 files changed, 25 insertions, 5 deletions
diff --git a/net-misc/youtube-viewer/ChangeLog b/net-misc/youtube-viewer/ChangeLog
index 4f6021e7be77..54c56a91e0ab 100644
--- a/net-misc/youtube-viewer/ChangeLog
+++ b/net-misc/youtube-viewer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/youtube-viewer
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-viewer/ChangeLog,v 1.18 2013/01/07 19:28:28 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-viewer/ChangeLog,v 1.19 2013/01/07 19:33:20 hasufell Exp $
+
+ 07 Jan 2013; Julian Ospald <hasufell@gentoo.org> youtube-viewer-9999.ebuild:
+ update live ebuild
07 Jan 2013; Julian Ospald <hasufell@gentoo.org>
-files/youtube-viewer-3.0.1_p20120924-desktopfile.patch,
diff --git a/net-misc/youtube-viewer/youtube-viewer-9999.ebuild b/net-misc/youtube-viewer/youtube-viewer-9999.ebuild
index 7b76e6cc1499..7e870b6b0c01 100644
--- a/net-misc/youtube-viewer/youtube-viewer-9999.ebuild
+++ b/net-misc/youtube-viewer/youtube-viewer-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-viewer/youtube-viewer-9999.ebuild,v 1.8 2012/11/20 18:40:59 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/youtube-viewer/youtube-viewer-9999.ebuild,v 1.9 2013/01/07 19:33:20 hasufell Exp $
EAPI=4
@@ -14,7 +14,7 @@ EGIT_REPO_URI="git://github.com/trizen/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="gtk"
RDEPEND="
>=dev-lang/perl-5.16.0
@@ -26,7 +26,13 @@ RDEPEND="
virtual/perl-File-Spec
virtual/perl-Getopt-Long
virtual/perl-Scalar-List-Utils
- virtual/perl-Term-ANSIColor"
+ virtual/perl-Term-ANSIColor
+ gtk? (
+ >=dev-perl/gtk2-perl-1.244.0
+ !net-misc/gtk-youtube-viewer
+ virtual/freedesktop-icon-theme
+ x11-libs/gdk-pixbuf:2[X,jpeg]
+ )"
DEPEND="virtual/perl-Module-Build"
EGIT_SOURCEDIR="${WORKDIR}"
@@ -34,6 +40,17 @@ S=${WORKDIR}/WWW-YoutubeViewer
SRC_TEST="do"
+# build system installs files on "perl Build.PL" too
+# do all the work in src_install
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ use gtk && local myconf="--gtk-youtube-viewer"
+ perl-module_src_configure
+ perl-module_src_install
+}
+
pkg_postinst() {
perl-module_pkg_postinst
einfo