summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2005-01-04 01:21:12 +0000
committerWolfram Schlich <wschlich@gentoo.org>2005-01-04 01:21:12 +0000
commit286f77548be8fe1b23ef291615dd5259dea0d3bd (patch)
treea696332cb1c5bb93543a3e990ace403e10583ab4 /net-misc/wol
parentupdates for embedded systems (Manifest recommit) (diff)
downloadgentoo-2-286f77548be8fe1b23ef291615dd5259dea0d3bd.tar.gz
gentoo-2-286f77548be8fe1b23ef291615dd5259dea0d3bd.tar.bz2
gentoo-2-286f77548be8fe1b23ef291615dd5259dea0d3bd.zip
initial import
Diffstat (limited to 'net-misc/wol')
-rw-r--r--net-misc/wol/ChangeLog10
-rw-r--r--net-misc/wol/Manifest4
-rw-r--r--net-misc/wol/files/digest-wol-0.7.11
-rw-r--r--net-misc/wol/metadata.xml15
-rw-r--r--net-misc/wol/wol-0.7.1.ebuild32
5 files changed, 62 insertions, 0 deletions
diff --git a/net-misc/wol/ChangeLog b/net-misc/wol/ChangeLog
new file mode 100644
index 000000000000..28705eaffca4
--- /dev/null
+++ b/net-misc/wol/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/wol
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wol/ChangeLog,v 1.1 2005/01/04 01:21:12 wschlich Exp $
+
+*wol-0.7.1 (04 Jan 2005)
+
+ 04 Jan 2005; Wolfram Schlich <wschlich@gentoo.org> +metadata.xml,
+ +wol-0.7.1.ebuild:
+ initial import
+
diff --git a/net-misc/wol/Manifest b/net-misc/wol/Manifest
new file mode 100644
index 000000000000..d1849e63d1ce
--- /dev/null
+++ b/net-misc/wol/Manifest
@@ -0,0 +1,4 @@
+MD5 1f4541ef71f264f2ad3336a6f9978f89 wol-0.7.1.ebuild 733
+MD5 1c2628739cc6796853a41d91b00ad554 metadata.xml 614
+MD5 28c707a7ee85eeac22b3823f578ba016 ChangeLog 246
+MD5 1868681f609da06939ef047d9acdf058 files/digest-wol-0.7.1 61
diff --git a/net-misc/wol/files/digest-wol-0.7.1 b/net-misc/wol/files/digest-wol-0.7.1
new file mode 100644
index 000000000000..54cc303d9b89
--- /dev/null
+++ b/net-misc/wol/files/digest-wol-0.7.1
@@ -0,0 +1 @@
+MD5 c2fa9d7e771134ac8c89d56b8197d4ca wol-0.7.1.tar.gz 445648
diff --git a/net-misc/wol/metadata.xml b/net-misc/wol/metadata.xml
new file mode 100644
index 000000000000..782cca8b6c5b
--- /dev/null
+++ b/net-misc/wol/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant.
+Consider you have a sleeping or turned-off computer and you want to remotely wake him up. Just type
+"wol MAC-ADDRESS" and the host wakes up (OK, it will boot ;-).
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/wol/wol-0.7.1.ebuild b/net-misc/wol/wol-0.7.1.ebuild
new file mode 100644
index 000000000000..ff533fe00a76
--- /dev/null
+++ b/net-misc/wol/wol-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wol/wol-0.7.1.ebuild,v 1.1 2005/01/04 01:21:12 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant."
+HOMEPAGE="http://ahh.sourceforge.net/wol/"
+SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}