summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-09-11 06:14:12 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-09-11 06:14:12 +0000
commit53bfb2953c0b520652bee0b2f097e97c560f0e14 (patch)
treefb6e085f5561a0d3e2c711b6b5a8ccdcad8612ea /net-misc/vpnc
parentRemove obsolete version. Inherit pam.eclass (#191943). (diff)
downloadgentoo-2-53bfb2953c0b520652bee0b2f097e97c560f0e14.tar.gz
gentoo-2-53bfb2953c0b520652bee0b2f097e97c560f0e14.tar.bz2
gentoo-2-53bfb2953c0b520652bee0b2f097e97c560f0e14.zip
* vpnc-0.5.1.tar.gz Mon Sep 10 23:16:41 CEST 2007
- link against -lcrypto instead of -lssl, fix from: Christophe Thil - fixed crashes on 64bit platforms by Tomas Mraz, report by Brian Downing - fixes to keepalive code from Brian Downing - generate options part of the manpage automatically, by Wolfram Sang - fix dead peer detection problems with Sonicwall, by Gerald Hanusch and Wolfgang Astleitner - fix disconnect problems with Sonicwall (please test if it fixes the known problems with Cisco), by Gerald Hanusch and Wolfgang Astleitner - again special thanks Joerg Mayer for handling all patches since the last release (-: - various other fixes contributed by Scott Rankin, Markus Meschederu (Portage version: 2.1.2.12)
Diffstat (limited to 'net-misc/vpnc')
-rw-r--r--net-misc/vpnc/ChangeLog7
-rw-r--r--net-misc/vpnc/files/digest-vpnc-0.5.13
-rw-r--r--net-misc/vpnc/vpnc-0.5.1.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/net-misc/vpnc/ChangeLog b/net-misc/vpnc/ChangeLog
index 323604e0cfbd..915922086369 100644
--- a/net-misc/vpnc/ChangeLog
+++ b/net-misc/vpnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vpnc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.48 2007/08/31 22:03:10 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/ChangeLog,v 1.49 2007/09/11 06:14:11 opfer Exp $
+
+*vpnc-0.5.1 (11 Sep 2007)
+
+ 11 Sep 2007; Christian Faulhammer <opfer@gentoo.org> +vpnc-0.5.1.ebuild:
+ version bump, including some run-time fixes on amd64
31 Aug 2007; Christian Faulhammer <opfer@gentoo.org> vpnc-0.5.0.ebuild:
adding hybrid authentication support. As distribution of binaries with that
diff --git a/net-misc/vpnc/files/digest-vpnc-0.5.1 b/net-misc/vpnc/files/digest-vpnc-0.5.1
new file mode 100644
index 000000000000..ac1fb53b1a03
--- /dev/null
+++ b/net-misc/vpnc/files/digest-vpnc-0.5.1
@@ -0,0 +1,3 @@
+MD5 7a8e94dbe94f39a4fd89b72e0125f66f vpnc-0.5.1.tar.gz 91496
+RMD160 76dd5a3a38bd2109cf8e1fbad85e2762e8489832 vpnc-0.5.1.tar.gz 91496
+SHA256 f63660bd020bbe6a39e8eb67ad60c54d719046c6198a6834371d098947f9a2ed vpnc-0.5.1.tar.gz 91496
diff --git a/net-misc/vpnc/vpnc-0.5.1.ebuild b/net-misc/vpnc/vpnc-0.5.1.ebuild
new file mode 100644
index 000000000000..b12f0a2a5c2b
--- /dev/null
+++ b/net-misc/vpnc/vpnc-0.5.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vpnc/vpnc-0.5.1.ebuild,v 1.1 2007/09/11 06:14:11 opfer Exp $
+
+inherit linux-info
+
+DESCRIPTION="Free client for Cisco VPN routing software"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~massar/vpnc/"
+SRC_URI="http://www.unix-ag.uni-kl.de/~massar/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="hybrid-auth bindist"
+
+DEPEND=">=dev-libs/libgcrypt-1.1.91
+ >=sys-apps/iproute2-2.6.19.20061214
+ !bindist? ( hybrid-auth? ( dev-libs/openssl ) )"
+
+RDEPEND="${DEPEND}
+ net-dns/resolvconf-gentoo"
+
+pkg_setup() {
+ if use hybrid-auth && use bindist; then
+ ewarn "Hybrid authentication will be disabled for this packages as you will"
+ ewarn "redistribute it in binary form. This is not allowed due to linking"
+ ewarn "of OpenSSL."
+ fi
+ local CONFIG_CHECK="TUN"
+ check_extra_config
+}
+
+src_compile() {
+ # only allowed if not distributed in binary form!
+ if use hybrid-auth && ! use bindist; then
+ hybridauthopts="OPENSSL_GPL_VIOLATION=-DOPENSSL_GPL_VIOLATION OPENSSLLIBS=-lcrypto"
+ fi
+ emake ${hybridauthopts} || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO VERSION
+ keepdir /var/run/vpnc
+ newinitd "${FILESDIR}/vpnc-1.init" vpnc
+ newconfd "${FILESDIR}/vpnc.confd" vpnc
+}
+
+pkg_postinst() {
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is to be found in http://www.gentoo.org/doc/en/vpnc-howto.xml"
+}