summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-22 15:46:37 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-22 15:46:37 +0000
commit879ef3597aedd4d7f5f0444bb2cf9e0bca19137f (patch)
treef963535fe60a8583fd0e8494e7caaf321d90bc08 /net-misc/ssh
parentworks on amd64 according to bug #42478 (Manifest recommit) (diff)
downloadgentoo-2-879ef3597aedd4d7f5f0444bb2cf9e0bca19137f.tar.gz
gentoo-2-879ef3597aedd4d7f5f0444bb2cf9e0bca19137f.tar.bz2
gentoo-2-879ef3597aedd4d7f5f0444bb2cf9e0bca19137f.zip
Version bump.
Diffstat (limited to 'net-misc/ssh')
-rw-r--r--net-misc/ssh/ChangeLog9
-rw-r--r--net-misc/ssh/Manifest6
-rw-r--r--net-misc/ssh/files/digest-ssh-3.2.9.11
-rw-r--r--net-misc/ssh/ssh-3.2.9.1.ebuild50
4 files changed, 62 insertions, 4 deletions
diff --git a/net-misc/ssh/ChangeLog b/net-misc/ssh/ChangeLog
index ee903888952a..f0b55a6267c1 100644
--- a/net-misc/ssh/ChangeLog
+++ b/net-misc/ssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ssh
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh/ChangeLog,v 1.1 2003/09/26 06:26:07 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh/ChangeLog,v 1.2 2004/02/22 15:46:37 aliz Exp $
+
+*ssh-3.2.9.1 (22 Feb 2004)
+
+ 22 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> ssh-3.2.9.1.ebuild:
+ Version bump.
*ssh-3.2.5 (26 Sep 2003)
diff --git a/net-misc/ssh/Manifest b/net-misc/ssh/Manifest
index 47f3d40e180b..c2fe64959fac 100644
--- a/net-misc/ssh/Manifest
+++ b/net-misc/ssh/Manifest
@@ -1,5 +1,7 @@
+MD5 8cb0b12a60e004cec8021a63b5afbb59 ssh-3.2.9.1.ebuild 1224
+MD5 8cb0b12a60e004cec8021a63b5afbb59 ssh-3.2.5.ebuild 1224
+MD5 379780175270edc0ef716a13454a8eac ChangeLog 375
MD5 38aabe8024e31fd394536ad3badcaba7 files/digest-ssh-3.2.5 62
MD5 5da2716771a56ddd869bed98e9164cc4 files/pamd.sshd2 425
MD5 697a78790526cc87cf32a23e99af4341 files/sshd2 653
-MD5 8cb0b12a60e004cec8021a63b5afbb59 ssh-3.2.5.ebuild 1224
-MD5 379780175270edc0ef716a13454a8eac ChangeLog 375
+MD5 1a0c708380931effd610c9567fac4303 files/digest-ssh-3.2.9.1 64
diff --git a/net-misc/ssh/files/digest-ssh-3.2.9.1 b/net-misc/ssh/files/digest-ssh-3.2.9.1
new file mode 100644
index 000000000000..60f249dbd000
--- /dev/null
+++ b/net-misc/ssh/files/digest-ssh-3.2.9.1
@@ -0,0 +1 @@
+MD5 f3ed49f13419d97dc1d0d3bfb4bb99bf ssh-3.2.9.1.tar.gz 2269281
diff --git a/net-misc/ssh/ssh-3.2.9.1.ebuild b/net-misc/ssh/ssh-3.2.9.1.ebuild
new file mode 100644
index 000000000000..673960ea52e9
--- /dev/null
+++ b/net-misc/ssh/ssh-3.2.9.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ssh/ssh-3.2.9.1.ebuild,v 1.1 2004/02/22 15:46:37 aliz Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="Ssh.com Non-Comercial Use ssh version"
+HOMEPAGE="http://www.ssh.com/"
+SRC_URI="ftp://ftp.ssh.com/pub/ssh/${P}.tar.gz"
+
+LICENSE="ssh"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X ipv6 crypt openssh"
+
+DEPEND="X? ( virtual/x11 )
+ !openssh? ( !virtual/ssh )"
+PROVIDE="virtual/ssh"
+
+src_compile() {
+ gnuconfig_update
+
+ econf \
+ `use_with ipv6 ipv6` \
+ `use_with X` \
+ `use_with crypt gpg` \
+ || die "configure failed"
+ make || die "make failed"
+}
+
+src_install() {
+ if [ -e ${ROOT}/etc/ssh2/hostkey ] ; then
+ # this keeps the install from generating these keys again
+ insinto /etc/ssh2
+ doins ${ROOT}/etc/ssh2/hostkey{,.pub}
+ fperms go-rwx /etc/ssh2/hostkey
+ fi
+
+ make install DESTDIR=${D} || die "install failed"
+ chmod 600 ${D}/etc/ssh2/sshd2_config
+ dodoc CHANGES FAQ HOWTO.anonymous.sftp README* SSH2.QUICKSTART
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/pamd.sshd2 sshd2
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/sshd2 sshd2
+
+ cd ${D}/usr
+ [ `use openssh` ] && find bin sbin share/man -type l -exec rm '{}' \;
+}