summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-04-28 17:13:09 +0000
committerJeroen Roovers <jer@gentoo.org>2009-04-28 17:13:09 +0000
commit85d7e9bd4362f315696d83cbfe6b7cbd48441214 (patch)
treec6dd4a327f4ea42d4e11f5c018fda6e1afc27538 /net-misc/smbc/files
parentamd64 stable and move flag-o-matic usage to src_configure where it should be. (diff)
downloadgentoo-2-85d7e9bd4362f315696d83cbfe6b7cbd48441214.tar.gz
gentoo-2-85d7e9bd4362f315696d83cbfe6b7cbd48441214.tar.bz2
gentoo-2-85d7e9bd4362f315696d83cbfe6b7cbd48441214.zip
Convert to EAPI=2. Run autoreconf. Do not DEPEND on system packages. Set RDEPEND. Use CFLAGS. Remove separator comments. Apply Debian patch to build on amd64. Marked ~hppa too.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'net-misc/smbc/files')
-rw-r--r--net-misc/smbc/files/smbc-1.2.2-cflags.patch13
-rw-r--r--net-misc/smbc/files/smbc-1.2.2-size_t.patch16
2 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/smbc/files/smbc-1.2.2-cflags.patch b/net-misc/smbc/files/smbc-1.2.2-cflags.patch
new file mode 100644
index 000000000000..f0125f7ca756
--- /dev/null
+++ b/net-misc/smbc/files/smbc-1.2.2-cflags.patch
@@ -0,0 +1,13 @@
+Do not define CFLAGS
+
+--- smbc-1.2.2/src/Makefile.am.orig 2005-06-29 14:14:02.000000000 +0200
++++ smbc-1.2.2/src/Makefile.am 2009-04-28 18:18:26.000000000 +0200
+@@ -18,7 +18,7 @@
+ smb-ext.c smb-ext.h
+
+ smbc_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -Wall
+-CFLAGS = -O3
++#CFLAGS = -O3
+
+ if GDB
+ smbc_CFLAGS += -ggdb -g
diff --git a/net-misc/smbc/files/smbc-1.2.2-size_t.patch b/net-misc/smbc/files/smbc-1.2.2-size_t.patch
new file mode 100644
index 000000000000..e423bec1deaf
--- /dev/null
+++ b/net-misc/smbc/files/smbc-1.2.2-size_t.patch
@@ -0,0 +1,16 @@
+Patch to enable running on amd64 (borrowed from http://bugs.debian.org/366580)
+
+--- smbc-1.2.2.orig/src/convert.c
++++ smbc-1.2.2/src/convert.c
+@@ -98,8 +98,9 @@
+
+ char *inbuf = (char*) src;
+ char *outbuf = param->dst;
+- int inbytesleft = src_len - 1;
+- int outbytesleft = param->dst_len - 1;
++ /* iconv requires size_t and not int ! */
++ size_t inbytesleft = src_len - 1;
++ size_t outbytesleft = param->dst_len - 1;
+ bzero(param->dst, param->dst_len);
+ // Need some error handling here
+ iconv(param->cd, &inbuf, &inbytesleft, &outbuf, &outbytesleft);