summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-01-09 09:27:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-01-09 09:27:36 +0000
commitc2b966e425fb87daa2f3153f77299801184fd18d (patch)
tree32e1adb7fa34211d752c2278c4791f9feb539393 /net-misc/rsync
parentVersion bump. Stabilise newer. Drop oldest. (diff)
downloadgentoo-2-c2b966e425fb87daa2f3153f77299801184fd18d.tar.gz
gentoo-2-c2b966e425fb87daa2f3153f77299801184fd18d.tar.bz2
gentoo-2-c2b966e425fb87daa2f3153f77299801184fd18d.zip
Install the rsync contrib scripts (includes useful rsync log parsing scripts, and atomic rsync helpers).
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/ChangeLog10
-rw-r--r--net-misc/rsync/rsync-3.0.7-r1.ebuild68
2 files changed, 76 insertions, 2 deletions
diff --git a/net-misc/rsync/ChangeLog b/net-misc/rsync/ChangeLog
index b1b56e1c308f..c20e729a18d6 100644
--- a/net-misc/rsync/ChangeLog
+++ b/net-misc/rsync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/rsync
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.204 2010/10/09 17:26:48 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.205 2011/01/09 09:27:36 robbat2 Exp $
+
+*rsync-3.0.7-r1 (09 Jan 2011)
+
+ 09 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> +rsync-3.0.7-r1.ebuild:
+ Install the rsync contrib scripts (includes useful rsync log parsing scripts,
+ and atomic rsync helpers).
09 Oct 2010; Raúl Porcel <armin76@gentoo.org> rsync-3.0.7.ebuild:
arm/ia64/m68k/s390/sh/sparc stable wrt #337537
diff --git a/net-misc/rsync/rsync-3.0.7-r1.ebuild b/net-misc/rsync/rsync-3.0.7-r1.ebuild
new file mode 100644
index 000000000000..32fbb8aebaaf
--- /dev/null
+++ b/net-misc/rsync/rsync-3.0.7-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-3.0.7-r1.ebuild,v 1.1 2011/01/09 09:27:36 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/src/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="acl iconv ipv6 static xattr"
+
+DEPEND=">=dev-libs/popt-1.5
+ acl? ( virtual/acl )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )
+ iconv? ( virtual/libiconv )"
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch_user
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf \
+ --without-included-popt \
+ $(use_enable acl acl-support) \
+ $(use_enable xattr xattr-support) \
+ $(use_enable ipv6) \
+ $(use_enable iconv) \
+ --with-rsyncd-conf=/etc/rsyncd.conf \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ newconfd "${FILESDIR}"/rsyncd.conf.d rsyncd
+ newinitd "${FILESDIR}"/rsyncd.init.d rsyncd || die
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ insinto /etc
+ doins "${FILESDIR}"/rsyncd.conf || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/rsyncd.logrotate rsyncd
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/rsyncd.xinetd rsyncd
+
+ # Install the useful contrib scripts
+ exeinto /usr/share/rsync/
+ doexe atomic-rsync cvs2includes deny-rsync file-attr-restore files-to-excludes git-set-file-times logfilter lsh mnt-excl munge-symlinks rrsync rsyncstats
+}
+
+pkg_postinst() {
+ if egrep -qis '^[[:space:]]use chroot[[:space:]]*=[[:space:]]*(no|0|false)' \
+ "${ROOT}"/etc/rsyncd.conf "${ROOT}"/etc/rsync/rsyncd.conf ; then
+ ewarn "You have disabled chroot support in your rsyncd.conf. This"
+ ewarn "is a security risk which you should fix. Please check your"
+ ewarn "/etc/rsyncd.conf file and fix the setting 'use chroot'."
+ fi
+}