summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-11-03 09:15:11 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-11-03 09:15:11 +0000
commita2a7fcd347edfbfd81074c7ac94cab34ba8b634b (patch)
tree1b79b24bb595f3d21f0d8449af15b8901f866d0d /net-misc/rdesktop
parentUpdate version of nginx-rtmp-module, bug #525836. Bump to 1.7.7. Thanks to Jo... (diff)
downloadgentoo-2-a2a7fcd347edfbfd81074c7ac94cab34ba8b634b.tar.gz
gentoo-2-a2a7fcd347edfbfd81074c7ac94cab34ba8b634b.tar.bz2
gentoo-2-a2a7fcd347edfbfd81074c7ac94cab34ba8b634b.zip
Version bump, should fix bug #527568
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/rdesktop')
-rw-r--r--net-misc/rdesktop/ChangeLog7
-rw-r--r--net-misc/rdesktop/rdesktop-1.8.3.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-misc/rdesktop/ChangeLog b/net-misc/rdesktop/ChangeLog
index c63bcb952804..cf7ba9fb81fa 100644
--- a/net-misc/rdesktop/ChangeLog
+++ b/net-misc/rdesktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/rdesktop
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/ChangeLog,v 1.165 2014/10/29 09:39:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/ChangeLog,v 1.166 2014/11/03 09:15:11 voyageur Exp $
+
+*rdesktop-1.8.3 (03 Nov 2014)
+
+ 03 Nov 2014; Bernard Cafarelli <voyageur@gentoo.org> +rdesktop-1.8.3.ebuild:
+ Version bump, should fix bug #527568
29 Oct 2014; Agostino Sarubbo <ago@gentoo.org> rdesktop-1.8.2.ebuild:
Stable for sparc, wrt bug #516658
diff --git a/net-misc/rdesktop/rdesktop-1.8.3.ebuild b/net-misc/rdesktop/rdesktop-1.8.3.ebuild
new file mode 100644
index 000000000000..c59281b7c5e1
--- /dev/null
+++ b/net-misc/rdesktop/rdesktop-1.8.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rdesktop/rdesktop-1.8.3.ebuild,v 1.1 2014/11/03 09:15:11 voyageur Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PV=${PV/_/-}
+
+DESCRIPTION="A Remote Desktop Protocol Client"
+HOMEPAGE="http://rdesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa ao debug ipv6 kerberos libsamplerate oss pcsc-lite"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+RDEPEND=">=dev-libs/openssl-0.9.6b
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ alsa? ( media-libs/alsa-lib )
+ ao? ( >=media-libs/libao-0.8.6 )
+ kerberos? ( net-libs/libgssglue )
+ libsamplerate? ( media-libs/libsamplerate )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.6.6 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-libs/libXt"
+
+src_prepare() {
+ # Prevent automatic stripping
+ local strip="$(echo '$(STRIP) $(DESTDIR)$(bindir)/rdesktop')"
+ sed -i -e "s:${strip}::" Makefile.in \
+ || die "sed failed in Makefile.in"
+
+ # Automagic dependency on libsamplerate
+ epatch "${FILESDIR}"/${PN}-1.6.0-sound_configure.patch
+ # bug #280923
+ epatch "${FILESDIR}"/${PN}-1.7.0-libao_crash.patch
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ if use ao; then
+ sound_conf=$(use_with ao sound libao)
+ else if use alsa; then
+ sound_conf=$(use_with alsa sound alsa)
+ else
+ sound_conf=$(use_with oss sound oss)
+ fi
+ fi
+
+ econf \
+ --with-openssl="${EPREFIX}"/usr \
+ $(use_with debug) \
+ $(use_with ipv6) \
+ $(use_with libsamplerate) \
+ $(use_enable kerberos credssp) \
+ $(use_enable pcsc-lite smartcard) \
+ ${sound_conf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/HACKING doc/TODO doc/keymapping.txt
+}