summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-01 12:30:54 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-01 12:30:54 +0000
commit1d40cd3d7532c83f405762a8d47d2ed7bf4ae92f (patch)
tree546f30467ccdc3187f6a1e30ca5752217e944fcd /net-misc/proxytunnel
parentold (diff)
downloadgentoo-2-1d40cd3d7532c83f405762a8d47d2ed7bf4ae92f.tar.gz
gentoo-2-1d40cd3d7532c83f405762a8d47d2ed7bf4ae92f.tar.bz2
gentoo-2-1d40cd3d7532c83f405762a8d47d2ed7bf4ae92f.zip
Version bump.
(Portage version: 2.1.4_rc12)
Diffstat (limited to 'net-misc/proxytunnel')
-rw-r--r--net-misc/proxytunnel/ChangeLog9
-rw-r--r--net-misc/proxytunnel/files/digest-proxytunnel-1.8.03
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.8.0.ebuild28
3 files changed, 38 insertions, 2 deletions
diff --git a/net-misc/proxytunnel/ChangeLog b/net-misc/proxytunnel/ChangeLog
index f66736aefaa1..a2628256949d 100644
--- a/net-misc/proxytunnel/ChangeLog
+++ b/net-misc/proxytunnel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/proxytunnel
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.19 2007/07/15 08:52:26 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/ChangeLog,v 1.20 2008/01/01 12:30:53 vapier Exp $
+
+*proxytunnel-1.8.0 (01 Jan 2008)
+
+ 01 Jan 2008; Mike Frysinger <vapier@gentoo.org> +proxytunnel-1.8.0.ebuild:
+ Version bump.
15 Jul 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Assigning to m-needed, as beu is being retired (#66608).
diff --git a/net-misc/proxytunnel/files/digest-proxytunnel-1.8.0 b/net-misc/proxytunnel/files/digest-proxytunnel-1.8.0
new file mode 100644
index 000000000000..4cd03309f7dc
--- /dev/null
+++ b/net-misc/proxytunnel/files/digest-proxytunnel-1.8.0
@@ -0,0 +1,3 @@
+MD5 5ac12bf5308fa7617169c6730ef93b21 proxytunnel-1.8.0.tgz 155586
+RMD160 f9d9dbec3b6c5c040b08785a58cc494a18d06bc0 proxytunnel-1.8.0.tgz 155586
+SHA256 8c652addb50384efe3ef8cb3d5d500bc64eacc9b1b55dd6265c55eabb3884705 proxytunnel-1.8.0.tgz 155586
diff --git a/net-misc/proxytunnel/proxytunnel-1.8.0.ebuild b/net-misc/proxytunnel/proxytunnel-1.8.0.ebuild
new file mode 100644
index 000000000000..174cd921c3d2
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/proxytunnel-1.8.0.ebuild,v 1.1 2008/01/01 12:30:53 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="program that connects stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy"
+HOMEPAGE="http://proxytunnel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/proxytunnel/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install PREFIX=/usr DESTDIR="${D}" || die
+ dodoc CHANGES CREDITS KNOWN_ISSUES README
+}