summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-09-23 07:33:26 +0000
committerYixun Lan <dlan@gentoo.org>2014-09-23 07:33:26 +0000
commitafd64480b3e190ce07923115491436e5067fca89 (patch)
treef74f3fc639f0f1ee12fa9d0d2289856980972417 /net-misc/ofono/ofono-1.12.ebuild
parentStable for HPPA (bug #523484). (diff)
downloadgentoo-2-afd64480b3e190ce07923115491436e5067fca89.tar.gz
gentoo-2-afd64480b3e190ce07923115491436e5067fca89.tar.bz2
gentoo-2-afd64480b3e190ce07923115491436e5067fca89.zip
drop old, bump new, bug 523480, thanks Vadim Efimov
(Portage version: 2.2.13/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-misc/ofono/ofono-1.12.ebuild')
-rw-r--r--net-misc/ofono/ofono-1.12.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/net-misc/ofono/ofono-1.12.ebuild b/net-misc/ofono/ofono-1.12.ebuild
deleted file mode 100644
index cf1d005f02f8..000000000000
--- a/net-misc/ofono/ofono-1.12.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ofono/ofono-1.12.ebuild,v 1.6 2014/08/10 20:45:44 slyfox Exp $
-
-EAPI=5
-
-inherit eutils multilib systemd
-
-DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
-HOMEPAGE="http://ofono.org/"
-SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem threads test tools +udev"
-
-REQUIRED_USE="dundee? ( bluetooth )"
-
-RDEPEND=">=sys-apps/dbus-1.4
- >=dev-libs/glib-2.28
- net-misc/mobile-broadband-provider-info
- bluetooth? ( >=net-wireless/bluez-4.99 )
- udev? ( virtual/udev )
- examples? ( dev-python/dbus-python )
- tools? ( virtual/libusb:1 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( ChangeLog AUTHORS )
-
-src_prepare() {
- default
-
- epatch "${FILESDIR}"/${P}-sys-types.patch
-}
-
-src_configure() {
- econf \
- $(use_enable threads) \
- $(use_enable udev) \
- $(use_enable isimodem) \
- $(use_enable atmodem) \
- $(use_enable cdmamodem) \
- $(use_enable datafiles) \
- $(use_enable dundee) \
- $(use_enable bluetooth) \
- $(use_enable phonesim) \
- $(use_enable provision) \
- $(use_enable qmimodem) \
- $(use_enable tools) \
- $(use_enable test) \
- --disable-maintainer-mode \
- --localstatedir=/var \
- --with-systemdunitdir="$(systemd_get_unitdir)"
-}
-
-src_install() {
- default
-
- if ! use examples ; then
- rm -rf "${D}/usr/$(get_libdir)/ofono/test" || die
- fi
-
- if use tools ; then
- dobin tools/{auto-enable,huawei-audio}
- fi
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- use doc && dodoc doc/*.txt
-}