summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-11-08 13:14:40 +0000
committerCédric Krier <cedk@gentoo.org>2008-11-08 13:14:40 +0000
commita2d55adfdbf5567853f9e198be5ea60c200e9454 (patch)
treebe48ed393913ccaa6edd6300fd9e6a0b2bf3ea60 /net-misc/netpipes
parentStable on ppc wrt bug 245096 (diff)
downloadgentoo-2-a2d55adfdbf5567853f9e198be5ea60c200e9454.tar.gz
gentoo-2-a2d55adfdbf5567853f9e198be5ea60c200e9454.tar.bz2
gentoo-2-a2d55adfdbf5567853f9e198be5ea60c200e9454.zip
Fix C(XX)FLAGS for bug #241074, add missing quote and add missing string.h
(Portage version: 2.1.4.5)
Diffstat (limited to 'net-misc/netpipes')
-rw-r--r--net-misc/netpipes/ChangeLog8
-rw-r--r--net-misc/netpipes/files/netpipes-4.2-string.patch10
-rw-r--r--net-misc/netpipes/netpipes-4.2.ebuild21
3 files changed, 32 insertions, 7 deletions
diff --git a/net-misc/netpipes/ChangeLog b/net-misc/netpipes/ChangeLog
index 392eb93f3086..7e1143978eb5 100644
--- a/net-misc/netpipes/ChangeLog
+++ b/net-misc/netpipes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/netpipes
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipes/ChangeLog,v 1.5 2007/02/20 01:06:01 jokey Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipes/ChangeLog,v 1.6 2008/11/08 13:14:40 cedk Exp $
+
+ 08 Nov 2008; Cédric Krier <cedk@gentoo.org>
+ +files/netpipes-4.2-string.patch, netpipes-4.2.ebuild:
+ Fix C(XX)FLAGS for bug #241074, add missing quote and add missing string.h
20 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/net-misc/netpipes/files/netpipes-4.2-string.patch b/net-misc/netpipes/files/netpipes-4.2-string.patch
new file mode 100644
index 000000000000..a0f5f8ea9fb2
--- /dev/null
+++ b/net-misc/netpipes/files/netpipes-4.2-string.patch
@@ -0,0 +1,10 @@
+--- timelimit.c~ 2008-11-08 14:05:28.000000000 +0100
++++ timelimit.c 2008-11-08 14:05:48.000000000 +0100
+@@ -30,6 +30,7 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <errno.h>
++#include <string.h>
+ extern int errno;
+ #include "common.h"
+
diff --git a/net-misc/netpipes/netpipes-4.2.ebuild b/net-misc/netpipes/netpipes-4.2.ebuild
index b5cb2fafb3f2..38537a868b92 100644
--- a/net-misc/netpipes/netpipes-4.2.ebuild
+++ b/net-misc/netpipes/netpipes-4.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipes/netpipes-4.2.ebuild,v 1.2 2006/10/22 01:32:37 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipes/netpipes-4.2.ebuild,v 1.3 2008/11/08 13:14:40 cedk Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="netpipes - a package to manipulate BSD TCP/IP stream sockets"
HOMEPAGE="http://web.purplefrog.com/~thoth/netpipes/"
@@ -16,11 +16,22 @@ IUSE=""
S=${WORKDIR}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/" \
+ Makefile || die "sed failed"
+
+ epatch "${FILESDIR}/${P}-string.patch"
+}
+
src_compile () {
emake CC=$(tc-getCC) || die
}
src_install() {
- mkdir -p ${D}/usr/share/man || die
- emake INSTROOT=${D}/usr INSTMAN=${D}/usr/share/man install || die
+ mkdir -p "${D}"/usr/share/man || die
+ emake INSTROOT="${D}"/usr INSTMAN="${D}"/usr/share/man install || die
}