summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-08-28 16:15:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-08-28 16:15:28 +0000
commiteefbd65869e7bcba3906716c5f4feb3f2a49c704 (patch)
tree3627040f61a285bd8dbc0d838c1f28f9d7f59c94 /net-misc/netifrc/netifrc-9999.ebuild
parentVersion bump. Delete "extensions" USE flag and unconditionally enable support... (diff)
downloadgentoo-2-eefbd65869e7bcba3906716c5f4feb3f2a49c704.tar.gz
gentoo-2-eefbd65869e7bcba3906716c5f4feb3f2a49c704.tar.bz2
gentoo-2-eefbd65869e7bcba3906716c5f4feb3f2a49c704.zip
Per bug #482604, start include a changelog. Also install the other docs.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/netifrc/netifrc-9999.ebuild')
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index 07559342d9cd..16d7cf991b2a 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.4 2013/08/27 17:01:53 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.5 2013/08/28 16:15:28 robbat2 Exp $
EAPI=5
@@ -32,6 +32,8 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
local ver="git-${EGIT_VERSION:0:6}"
sed -i "/^GITVER[[:space:]]*=/s:=.*:=${ver}:" mk/git.mk || die
+ einfo "Producing ChangeLog from Git history"
+ GIT_DIR="${S}/.git" git log >"${S}"/ChangeLog
fi
# Allow user patches to be applied without modifying the ebuild
@@ -49,7 +51,7 @@ src_compile() {
src_install() {
emake ${MAKE_ARGS} DESTDIR="${D}" install
- dodoc README
+ dodoc README CREDITS FEATURE-REMOVAL-SCHEDULE STYLE TODO ChangeLog
}
pkg_postinst() {