summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-04-07 04:11:42 +0000
committerMike Gilbert <floppym@gentoo.org>2013-04-07 04:11:42 +0000
commit561cca093296c53d3f7701355b57a1d604202fd0 (patch)
treedabe74ae4d158948074881374967bb8824c6391b /net-misc/netctl
parentVersion bump. (diff)
downloadgentoo-2-561cca093296c53d3f7701355b57a1d604202fd0.tar.gz
gentoo-2-561cca093296c53d3f7701355b57a1d604202fd0.tar.bz2
gentoo-2-561cca093296c53d3f7701355b57a1d604202fd0.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'net-misc/netctl')
-rw-r--r--net-misc/netctl/ChangeLog7
-rw-r--r--net-misc/netctl/netctl-0.8.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/net-misc/netctl/ChangeLog b/net-misc/netctl/ChangeLog
index ba4a9a41a97a..3abf40d2e7a2 100644
--- a/net-misc/netctl/ChangeLog
+++ b/net-misc/netctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/netctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.2 2013/03/20 00:01:10 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/ChangeLog,v 1.3 2013/04/07 04:11:42 floppym Exp $
+
+*netctl-0.8 (07 Apr 2013)
+
+ 07 Apr 2013; Mike Gilbert <floppym@gentoo.org> +netctl-0.8.ebuild:
+ Version bump.
*netctl-0.7 (20 Mar 2013)
diff --git a/net-misc/netctl/netctl-0.8.ebuild b/net-misc/netctl/netctl-0.8.ebuild
new file mode 100644
index 000000000000..6990e022b612
--- /dev/null
+++ b/net-misc/netctl/netctl-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netctl/netctl-0.8.ebuild,v 1.1 2013/04/07 04:11:42 floppym Exp $
+
+EAPI=5
+
+inherit eutils
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://projects.archlinux.org/netctl.git"
+ inherit git-2
+else
+ SRC_URI="ftp://ftp.archlinux.org/other/packages/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Profile based network connection tool from Arch Linux"
+HOMEPAGE="https://www.archlinux.org/netctl/"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=net-dns/openresolv-3.5.4[systemd]
+ sys-apps/iproute2
+ sys-apps/systemd
+"
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" SHELL=bash install
+ dodoc AUTHORS NEWS README
+}