summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-02-28 23:12:22 +0000
committerChris Reffett <creffett@gentoo.org>2013-02-28 23:12:22 +0000
commit620b2144cb4d7ece10965c776c51241a5fadc7bd (patch)
tree58534afd79628262f3ad144e5a5d5ef6713537f4 /net-misc/mirall
parentVersion bump wrt bug 459476 (diff)
downloadgentoo-2-620b2144cb4d7ece10965c776c51241a5fadc7bd.tar.gz
gentoo-2-620b2144cb4d7ece10965c776c51241a5fadc7bd.tar.bz2
gentoo-2-620b2144cb4d7ece10965c776c51241a5fadc7bd.zip
Version bump wrt bug 459476
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'net-misc/mirall')
-rw-r--r--net-misc/mirall/ChangeLog7
-rw-r--r--net-misc/mirall/mirall-1.2.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/net-misc/mirall/ChangeLog b/net-misc/mirall/ChangeLog
index 6913ae48d66c..a355aef8569c 100644
--- a/net-misc/mirall/ChangeLog
+++ b/net-misc/mirall/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/mirall
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mirall/ChangeLog,v 1.17 2013/02/07 22:37:57 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mirall/ChangeLog,v 1.18 2013/02/28 23:12:22 creffett Exp $
+
+*mirall-1.2.1 (28 Feb 2013)
+
+ 28 Feb 2013; Chris Reffett <creffett@gentoo.org> +mirall-1.2.1.ebuild:
+ Version bump wrt bug 459476
07 Feb 2013; Ulrich Müller <ulm@gentoo.org> mirall-1.2.0.ebuild:
Move Creative Commons licenses to shorter names.
diff --git a/net-misc/mirall/mirall-1.2.1.ebuild b/net-misc/mirall/mirall-1.2.1.ebuild
new file mode 100644
index 000000000000..ec0781b7cdd7
--- /dev/null
+++ b/net-misc/mirall/mirall-1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mirall/mirall-1.2.1.ebuild,v 1.1 2013/02/28 23:12:22 creffett Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_P="${PN}-${PV/_/}"
+
+DESCRIPTION="Synchronization of your folders with another computers"
+HOMEPAGE="http://owncloud.org/"
+SRC_URI="http://download.owncloud.com/download/${MY_P}.tar.bz2"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=net-misc/csync-0.70.4
+ sys-fs/inotify-tools
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-test:4
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx virtual/latex-base )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # Yay for fcked detection.
+ export CSYNC_DIR="${EPREFIX}/usr/include/ocsync/"
+
+ epatch "${FILESDIR}/${PN}-1.2.0_beta2-automagicness.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with doc SPHINX)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! has_version net-misc/csync[samba]; then
+ elog "For samba support, build net-misc/csync with USE=samba"
+ fi
+ if ! has_version net-misc/csync[sftp]; then
+ elog "For sftp support, build net-misc/csync with USE=sftp"
+ fi
+}