summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-08-09 18:37:22 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-08-09 18:37:22 +0000
commitdb1de955461b1ae8142cf774963ddbca91465f77 (patch)
tree3060240463e3dd36f711934c3c3cc923a695ca60 /net-misc/mico
parentversion bump (diff)
downloadgentoo-2-db1de955461b1ae8142cf774963ddbca91465f77.tar.gz
gentoo-2-db1de955461b1ae8142cf774963ddbca91465f77.tar.bz2
gentoo-2-db1de955461b1ae8142cf774963ddbca91465f77.zip
fixed qt USE flag and tcltk USE flag to conform to bug #137785
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'net-misc/mico')
-rw-r--r--net-misc/mico/ChangeLog8
-rw-r--r--net-misc/mico/mico-2.3.11-r1.ebuild16
-rw-r--r--net-misc/mico/mico-2.3.11.ebuild10
-rw-r--r--net-misc/mico/mico-2.3.7.ebuild10
-rw-r--r--net-misc/mico/mico-2.3.9.ebuild10
5 files changed, 29 insertions, 25 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
index 77e5fb542e14..e47300d81981 100644
--- a/net-misc/mico/ChangeLog
+++ b/net-misc/mico/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/mico
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.11 2005/08/04 20:33:58 azarah Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.12 2006/08/09 18:37:22 cardoe Exp $
+
+ 09 Aug 2006; <dougg@gentoo.org> mico-2.3.7.ebuild, mico-2.3.9.ebuild,
+ mico-2.3.11.ebuild, mico-2.3.11-r1.ebuild:
+ fixed qt USE flag and tcltk USE flag to conform to bug #137785
*mico-2.3.11-r1 (04 Aug 2005)
diff --git a/net-misc/mico/mico-2.3.11-r1.ebuild b/net-misc/mico/mico-2.3.11-r1.ebuild
index 384ea094c02e..edc99e8fec56 100644
--- a/net-misc/mico/mico-2.3.11-r1.ebuild
+++ b/net-misc/mico/mico-2.3.11-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.11-r1.ebuild,v 1.1 2005/08/04 20:33:58 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.11-r1.ebuild,v 1.2 2006/08/09 18:37:22 cardoe Exp $
-inherit eutils
+inherit eutils qt3
-IUSE="ssl tcltk qt gtk postgres"
+IUSE="ssl tcl qt3 gtk postgres"
DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
HOMEPAGE="http://www.mico.org/"
@@ -17,8 +17,8 @@ DEPEND="virtual/libc
>=sys-devel/flex-2.5.2
>=sys-devel/bison-1.22
ssl? ( dev-libs/openssl )
- tcltk? ( dev-lang/tcl )
- qt? ( x11-libs/qt )
+ tcl? ( dev-lang/tcl )
+ qt3? ( $(qt_min_version 3.3) )
postgres? ( dev-db/postgresql )"
S="${WORKDIR}/${PN}"
@@ -38,9 +38,9 @@ src_compile() {
use ssl && myopts="${myopts} --with-ssl=/usr" \
|| myopts="${myopts} --without-ssl"
- use tcltk && myopts="${myopts} --with-tcl=/usr" \
+ use tcl && myopts="${myopts} --with-tcl=/usr" \
|| myopts="${myopts} --without-tcl"
- use qt && myopts="${myopts} --with-qt=${QTDIR}" \
+ use qt3 && myopts="${myopts} --with-qt=${QTDIR}" \
|| myopts="${myopts} --without-qt"
use gtk && myopts="${myopts} --with-gtk=/usr" \
|| myopts="${myopts} --without-gtk"
diff --git a/net-misc/mico/mico-2.3.11.ebuild b/net-misc/mico/mico-2.3.11.ebuild
index 5aa9c6709f48..0275f8cd45e9 100644
--- a/net-misc/mico/mico-2.3.11.ebuild
+++ b/net-misc/mico/mico-2.3.11.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.11.ebuild,v 1.6 2004/07/01 21:28:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.11.ebuild,v 1.7 2006/08/09 18:37:22 cardoe Exp $
-IUSE="ssl tcltk"
+IUSE="ssl tcl"
DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
HOMEPAGE="http://www.mico.org/"
@@ -15,7 +15,7 @@ DEPEND="virtual/libc
sys-devel/flex
sys-devel/bison
ssl? ( dev-libs/openssl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
S="${WORKDIR}/${PN}"
@@ -33,7 +33,7 @@ src_compile() {
use ssl && myopts="${myopts} --with-ssl=/usr" \
|| myopts="${myopts} --without-ssl"
- use tcltk && myopts="${myopts} --with-tcl=/usr" \
+ use tcl && myopts="${myopts} --with-tcl=/usr" \
|| myopts="${myopts} --without-tcl"
./configure \
diff --git a/net-misc/mico/mico-2.3.7.ebuild b/net-misc/mico/mico-2.3.7.ebuild
index 41d3233c49bd..80a7d479c76e 100644
--- a/net-misc/mico/mico-2.3.7.ebuild
+++ b/net-misc/mico/mico-2.3.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.7.ebuild,v 1.6 2004/07/01 21:28:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.7.ebuild,v 1.7 2006/08/09 18:37:22 cardoe Exp $
-IUSE="ssl tcltk"
+IUSE="ssl tcl"
DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
HOMEPAGE="http://www.mico.org/"
@@ -15,7 +15,7 @@ DEPEND="virtual/libc
sys-devel/flex
sys-devel/bison
ssl? ( dev-libs/openssl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
S="${WORKDIR}/${PN}"
@@ -33,7 +33,7 @@ src_compile() {
use ssl && myopts="${myopts} --with-ssl=/usr" \
|| myopts="${myopts} --without-ssl"
- use tcltk && myopts="${myopts} --with-tcl=/usr" \
+ use tcl && myopts="${myopts} --with-tcl=/usr" \
|| myopts="${myopts} --without-tcl"
./configure \
diff --git a/net-misc/mico/mico-2.3.9.ebuild b/net-misc/mico/mico-2.3.9.ebuild
index 0dc5c35c64b0..042fc7b79002 100644
--- a/net-misc/mico/mico-2.3.9.ebuild
+++ b/net-misc/mico/mico-2.3.9.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.9.ebuild,v 1.6 2004/07/01 21:28:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.9.ebuild,v 1.7 2006/08/09 18:37:22 cardoe Exp $
-IUSE="ssl tcltk"
+IUSE="ssl tcl"
DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
HOMEPAGE="http://www.mico.org/"
@@ -15,7 +15,7 @@ DEPEND="virtual/libc
sys-devel/flex
sys-devel/bison
ssl? ( dev-libs/openssl )
- tcltk? ( dev-lang/tcl )"
+ tcl? ( dev-lang/tcl )"
S="${WORKDIR}/${PN}"
@@ -33,7 +33,7 @@ src_compile() {
use ssl && myopts="${myopts} --with-ssl=/usr" \
|| myopts="${myopts} --without-ssl"
- use tcltk && myopts="${myopts} --with-tcl=/usr" \
+ use tcl && myopts="${myopts} --with-tcl=/usr" \
|| myopts="${myopts} --without-tcl"
./configure \