summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-11-20 17:01:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-11-20 17:01:59 +0000
commitb12ac1150466657d140f416619886e5b8bc98e45 (patch)
tree231876d721335a1076d523d86168fd0d51eaee28 /net-misc/icecast
parentKeyworded on alpha, bug 518436 (diff)
downloadgentoo-2-b12ac1150466657d140f416619886e5b8bc98e45.tar.gz
gentoo-2-b12ac1150466657d140f416619886e5b8bc98e45.tar.bz2
gentoo-2-b12ac1150466657d140f416619886e5b8bc98e45.zip
Security bump (bug #529956)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-misc/icecast')
-rw-r--r--net-misc/icecast/ChangeLog8
-rw-r--r--net-misc/icecast/files/icecast.xml1
-rw-r--r--net-misc/icecast/icecast-2.4.1.ebuild83
3 files changed, 90 insertions, 2 deletions
diff --git a/net-misc/icecast/ChangeLog b/net-misc/icecast/ChangeLog
index bcb4904b6d1d..82bfb4fea83f 100644
--- a/net-misc/icecast/ChangeLog
+++ b/net-misc/icecast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/icecast
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.103 2014/05/23 17:14:14 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/ChangeLog,v 1.104 2014/11/20 17:01:59 polynomial-c Exp $
+
+*icecast-2.4.1 (20 Nov 2014)
+
+ 20 Nov 2014; Lars Wendler <polynomial-c@gentoo.org> +icecast-2.4.1.ebuild,
+ files/icecast.xml:
+ Security bump (bug #529956) with kind permission by hwoarang.
*icecast-2.4.0 (23 May 2014)
diff --git a/net-misc/icecast/files/icecast.xml b/net-misc/icecast/files/icecast.xml
index 4d0fd5dc6159..3415885deba4 100644
--- a/net-misc/icecast/files/icecast.xml
+++ b/net-misc/icecast/files/icecast.xml
@@ -2,7 +2,6 @@
<limits>
<clients>100</clients>
<sources>2</sources>
- <threadpool>5</threadpool>
<queue-size>524288</queue-size>
<client-timeout>30</client-timeout>
<header-timeout>15</header-timeout>
diff --git a/net-misc/icecast/icecast-2.4.1.ebuild b/net-misc/icecast/icecast-2.4.1.ebuild
new file mode 100644
index 000000000000..2e945a45aa92
--- /dev/null
+++ b/net-misc/icecast/icecast-2.4.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icecast/icecast-2.4.1.ebuild,v 1.1 2014/11/20 17:01:59 polynomial-c Exp $
+
+EAPI=5
+inherit eutils autotools systemd user
+
+DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
+HOMEPAGE="http://www.icecast.org/"
+SRC_URI="http://downloads.xiph.org/releases/icecast/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="kate logrotate +speex +ssl +theora +yp"
+
+#Although there is a --with-ogg and --with-orbis configure option, they're
+#only useful for specifying paths, not for disabling.
+DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ media-libs/libogg
+ media-libs/libvorbis
+ kate? ( media-libs/libkate )
+ logrotate? ( app-admin/logrotate )
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ yp? ( net-misc/curl )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewuser icecast -1 -1 -1 nogroup
+}
+
+src_prepare() {
+ # bug #368539
+ epatch "${FILESDIR}"/${PN}-2.3.3-libkate.patch
+ # bug #430434
+ epatch "${FILESDIR}"/${PN}-2.3.3-fix-xiph_openssl.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ --sysconfdir=/etc/icecast2 \
+ $(use_enable kate) \
+ $(use_with theora) \
+ $(use_with speex) \
+ $(use_with yp curl) \
+ $(use_with ssl openssl) \
+ $(use_enable yp)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
+ dohtml -A chm,hhc,hhp doc/*
+
+ newinitd "${FILESDIR}"/init.d.icecast-2 icecast
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ insinto /etc/icecast2
+ doins "${FILESDIR}"/icecast.xml
+ fperms 600 /etc/icecast2/icecast.xml
+
+ if use logrotate; then
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+ fi
+ diropts -m0764 -o icecast -g nogroup
+ dodir /var/log/icecast
+ keepdir /var/log/icecast
+ rm -rf "${D}"/usr/share/doc/icecast
+}
+
+pkg_postinst() {
+ touch "${ROOT}"var/log/icecast/{access,error}.log
+ chown icecast:nogroup "${ROOT}"var/log/icecast/{access,error}.log
+}