summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-14 03:47:53 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-14 03:47:53 +0000
commit738a0ee12d9413a15e3f90d2d56153f383867607 (patch)
tree79849277d9d51a753167751872f5b4932d58abbf /net-misc/htun
parentFix building with glibc-2.8 #240914 by Diego E. Pettenò. (diff)
downloadgentoo-2-738a0ee12d9413a15e3f90d2d56153f383867607.tar.gz
gentoo-2-738a0ee12d9413a15e3f90d2d56153f383867607.tar.bz2
gentoo-2-738a0ee12d9413a15e3f90d2d56153f383867607.zip
Fix building with newer glibc #248100 by Diego E. Pettenò.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'net-misc/htun')
-rw-r--r--net-misc/htun/ChangeLog8
-rw-r--r--net-misc/htun/files/htun-0.9.5-glibc.patch40
-rw-r--r--net-misc/htun/htun-0.9.5.ebuild36
3 files changed, 68 insertions, 16 deletions
diff --git a/net-misc/htun/ChangeLog b/net-misc/htun/ChangeLog
index 775dd544d592..1dabf3e9ec5e 100644
--- a/net-misc/htun/ChangeLog
+++ b/net-misc/htun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/htun
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htun/ChangeLog,v 1.7 2008/04/21 17:58:57 phreak Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htun/ChangeLog,v 1.8 2009/01/14 03:47:53 vapier Exp $
+
+ 14 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/htun-0.9.5-glibc.patch, htun-0.9.5.ebuild:
+ Fix building with newer glibc #248100 by Diego E. Pettenò.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/net-misc/htun/files/htun-0.9.5-glibc.patch b/net-misc/htun/files/htun-0.9.5-glibc.patch
new file mode 100644
index 000000000000..e568e443586c
--- /dev/null
+++ b/net-misc/htun/files/htun-0.9.5-glibc.patch
@@ -0,0 +1,40 @@
+get things building with glibc-2.8
+
+http://bugs.gentoo.org/248100
+
+--- include/common.h
++++ include/common.h
+@@ -23,6 +23,7 @@
+ #ifndef __COMMON_H
+ #define __COMMON_H
+
++#include <limits.h>
+ #include <netinet/in.h>
+ #include <time.h>
+ #include "queue.h"
+--- src/queue.c
++++ src/queue.c
+@@ -34,8 +34,8 @@
+ #define q_lock(q, cnt) do { int _old; \
+ pthread_setcanceltype(PTHREAD_CANCEL_DEFERRED,&_old); \
+ pthread_cleanup_push(q_sempost,q); \
+- pthread_cleanup_push(q_release,q) \
+- pthread_cleanup_push(q_decrement, cnt) \
++ pthread_cleanup_push(q_release,q); \
++ pthread_cleanup_push(q_decrement, cnt); \
+ pthread_mutex_lock(&((q)->mutex)); \
+ (*(cnt))++; \
+ pthread_testcancel()
+@@ -43,9 +43,9 @@
+ /* q_unlock() is called when intentionally exiting critical section */
+ #define q_unlock(cond) \
+ pthread_testcancel(); \
+- pthread_cleanup_pop(1) \
+- pthread_cleanup_pop(1) \
+- pthread_cleanup_pop(1) \
++ pthread_cleanup_pop(1); \
++ pthread_cleanup_pop(1); \
++ pthread_cleanup_pop(1); \
+ if(cond) pthread_cond_broadcast(cond); \
+ pthread_setcanceltype(_old,NULL); } while(0)
+
diff --git a/net-misc/htun/htun-0.9.5.ebuild b/net-misc/htun/htun-0.9.5.ebuild
index 0e8b6016f86f..161a37e86ade 100644
--- a/net-misc/htun/htun-0.9.5.ebuild
+++ b/net-misc/htun/htun-0.9.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htun/htun-0.9.5.ebuild,v 1.7 2007/07/12 02:52:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htun/htun-0.9.5.ebuild,v 1.8 2009/01/14 03:47:53 vapier Exp $
+
+inherit eutils
DESCRIPTION="Project to tunnel IP traffic over HTTP"
HOMEPAGE="http://htun.runslinux.net/"
@@ -9,27 +11,34 @@ SRC_URI="http://htun.runslinux.net/dist/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-
IUSE=""
-DEPEND="virtual/libc
- dev-util/yacc"
+DEPEND="dev-util/yacc"
RDEPEND=""
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc.patch #248100
+ sed -i \
+ -e '/^CFLAGS/s:=\(.*\)-O :+=\1 $(CPPFLAGS) :' \
+ -e '/LDFLAGS/s:=:+=:' \
+ src/Makefile || die
+}
- cd ${S}/src
- make all || die
+src_compile() {
+ cd src
+ emake all || die
}
src_install() {
- dosbin ${S}/src/htund
-
+ dosbin src/htund || die
insinto /etc
- doins ${S}/doc/htund.conf
- dodoc doc/*
+ doins doc/htund.conf
+ dodoc doc/* README
+}
- einfo
+pkg_postinst() {
einfo "NOTE: HTun requires the Universal TUN/TAP module"
einfo "available in the Linux kernel. Make sure you have"
einfo "compiled the tun.o driver as a module!"
@@ -41,5 +50,4 @@ src_install() {
einfo " # mknod /dev/net/tun c 10 200"
einfo " # echo \"alias char-major-10-200 tun\" >> /etc/modules.conf"
einfo " # depmod -e"
- einfo
}