summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-08-13 10:35:38 +0000
committerMike Gardiner <obz@gentoo.org>2003-08-13 10:35:38 +0000
commit52d6946824f10b979c2a2286581823511339c287 (patch)
treeac83ef927c5a90d625fbe1f8fc7fc627a2b688b7 /net-misc/gwget2
parentChanged ~sparc keyword to sparc to fix bug #25664. (diff)
downloadgentoo-2-52d6946824f10b979c2a2286581823511339c287.tar.gz
gentoo-2-52d6946824f10b979c2a2286581823511339c287.tar.bz2
gentoo-2-52d6946824f10b979c2a2286581823511339c287.zip
ebuild clean up
Diffstat (limited to 'net-misc/gwget2')
-rw-r--r--net-misc/gwget2/ChangeLog5
-rw-r--r--net-misc/gwget2/Manifest4
-rw-r--r--net-misc/gwget2/gwget2-0.5.ebuild35
3 files changed, 18 insertions, 26 deletions
diff --git a/net-misc/gwget2/ChangeLog b/net-misc/gwget2/ChangeLog
index c4e5b649071e..c7b05d66c9d3 100644
--- a/net-misc/gwget2/ChangeLog
+++ b/net-misc/gwget2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/gwget2
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget2/ChangeLog,v 1.1 2003/08/13 03:58:02 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget2/ChangeLog,v 1.2 2003/08/13 10:35:15 obz Exp $
+
+ 13 Aug 2003; Mike Gardiner <obz@gentoo.org> gwget2-0.5.ebuild:
+ Moved gettext dependency to DEPEND, general clean up
*gwget2-0.5 (13 Aug 2003)
diff --git a/net-misc/gwget2/Manifest b/net-misc/gwget2/Manifest
index 4fec770d123d..876f6e992b5a 100644
--- a/net-misc/gwget2/Manifest
+++ b/net-misc/gwget2/Manifest
@@ -1,3 +1,3 @@
-MD5 d52c9e2dad82eb4ed636b33f52334639 gwget2-0.5.ebuild 1273
-MD5 f61041df25010d27a35428431ecae7bd ChangeLog 390
+MD5 7fb0387d309730ee2db051403f2783de gwget2-0.5.ebuild 1128
+MD5 d18b03aaad8c740b118007e112274608 ChangeLog 511
MD5 b8468bb83ac1e65518a1cc32439d9195 files/digest-gwget2-0.5 62
diff --git a/net-misc/gwget2/gwget2-0.5.ebuild b/net-misc/gwget2/gwget2-0.5.ebuild
index b7475fa30ffa..ecf29a45b118 100644
--- a/net-misc/gwget2/gwget2-0.5.ebuild
+++ b/net-misc/gwget2/gwget2-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget2/gwget2-0.5.ebuild,v 1.1 2003/08/13 03:58:02 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget2/gwget2-0.5.ebuild,v 1.2 2003/08/13 10:35:15 obz Exp $
inherit gnome2
@@ -14,20 +14,20 @@ KEYWORDS="~x86"
LICENSE="GPL-2"
RDEPEND=">=net-misc/wget-1.8
- >=x11-libs/gtk+-2.0
- >=gnome-base/gconf-2
- >=gnome-base/libgnomeui-2.0
- nls? ( sys-devel/gettext )"
+ >=x11-libs/gtk+-2.0
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2.0"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
DOCS="ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO"
-# gwget2 isnt all finished, and there is support for
-# gconf planned, so when that comes in, this should be
-# okay thanks to the eclass.
-
+use nls \
+ && G2CONF="${G2CONF} --with-included-gettext=no" \
+ || G2CONF="${G2CONF} --disable-nls"
+
src_unpack( ) {
unpack ${A}
@@ -40,21 +40,10 @@ src_unpack( ) {
}
-
-src_compile( ) {
-
- local myconf
- use nls \
- && myconf="--with-included-gettext=no" \
- || myconf="--disable-nls"
-
- gnome2_src_compile ${myconf}
-
-}
-
src_install( ) {
gnome2_src_install
+ # remove extra documentation, keeping /usr/share/doc
rm -rf ${D}/usr/doc
}