summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-26 14:18:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-26 14:18:45 +0000
commit7b2995475746146ca11ddc47fb0ffbcf9ffa3451 (patch)
treef3961be83f82593793076c1fbe6c4791440bfe31 /net-misc/dhcp
parentuse toolchain-funcs to determine compiler (Manifest recommit) (diff)
downloadgentoo-2-7b2995475746146ca11ddc47fb0ffbcf9ffa3451.tar.gz
gentoo-2-7b2995475746146ca11ddc47fb0ffbcf9ffa3451.tar.bz2
gentoo-2-7b2995475746146ca11ddc47fb0ffbcf9ffa3451.zip
old
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/dhcp-3.0_p2-r4.ebuild108
-rw-r--r--net-misc/dhcp/dhcp-3.0_p2-r5.ebuild132
-rw-r--r--net-misc/dhcp/dhcp-3.0_p2-r6.ebuild136
-rw-r--r--net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch24
-rw-r--r--net-misc/dhcp/files/dhcp-3.0pl2-user-option-fix.patch54
-rw-r--r--net-misc/dhcp/files/dhcp.rc732
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_p2-r41
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_p2-r51
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0_p2-r61
9 files changed, 0 insertions, 489 deletions
diff --git a/net-misc/dhcp/dhcp-3.0_p2-r4.ebuild b/net-misc/dhcp/dhcp-3.0_p2-r4.ebuild
deleted file mode 100644
index c0dace8b6f43..000000000000
--- a/net-misc/dhcp/dhcp-3.0_p2-r4.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_p2-r4.ebuild,v 1.5 2004/07/01 20:56:39 squinky86 Exp $
-
-IUSE="selinux"
-
-inherit flag-o-matic eutils
-
-#This should be fairly consistant now, unless we have any _pre releases...
-MY_P="${P/_p/pl}"
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="ISC Dynamic Host Configuration Protocol"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz"
-HOMEPAGE="http://www.isc.org/products/DHCP"
-
-SLOT="0"
-LICENSE="isc-dhcp"
-KEYWORDS="x86 ppc sparc ~mips amd64"
-
-RDEPEND="virtual/libc
- selinux? ( sec-policy/selinux-dhcp )"
-DEPEND="${RDEPEND}
- sys-apps/groff"
-
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/dhclient.c-3.0-dw-cli-fix.patch
-
- cd ${S}/includes
- cat <<- END >> site.h
-#define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
-#define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
-#define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- END
-}
-
-src_compile() {
- # 01/Mar/2003: Fix for bug #11960 by Jason Wever <weeve@gentoo.org>
- # start fix
- if [ ${ARCH} = "sparc" ]
- then
- filter-flags "-O3"
- filter-flags "-O2"
- filter-flags "-O"
- fi
- # end fix
- cat <<- END > site.conf
-CC = gcc ${CFLAGS}
-ETC = /etc/dhcp
-VARDB = /var/lib/dhcp
-ADMMANDIR = /usr/share/man/man8
-FFMANDIR = /usr/share/man/man5
-LIBMANDIR = /usr/share/man/man3
-END
- ./configure --with-nsupdate || die
- emake || die
-}
-
-src_install() {
- dodir /var/lib/dhcp
- touch ${D}/var/lib/dhcp/dhclient.leases
- touch ${D}/var/lib/dhcp/dhcpd.leases
-
- cd ${S}/work.linux-2.2/client
- into / ; dosbin dhclient
- doman *.5 *.8
-
- cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
- insinto /usr/include ; doins dhcpctl.h
-
- cd ../omapip ; dolib libomapi.a ; doman *.3
- cd ../relay ; dosbin dhcrelay ; doman *.8
- cd ../common ; doman *.5
- cd ../server ; dosbin dhcpd ; doman *.5 *.8
-
- cd ${S}/client
- # admins might wanna edit dhclient-script, so /etc is proper for it.
- dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
- insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
- exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
-
- cd ${S}/server
- insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
-
- cd ${S}/includes/omapip
- insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
-
- cd ${S}/includes/isc-dhcp
- insinto /usr/include/isc-dhcp
- doins boolean.h dst.h int.h lang.h list.h result.h types.h
-
- cd ${S}
- dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
- docinto doc ; dodoc doc/*
-
- insinto /etc/conf.d
- newins ${FILESDIR}/conf.dhcpd dhcp
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/dhcp.rc7 dhcp
-}
diff --git a/net-misc/dhcp/dhcp-3.0_p2-r5.ebuild b/net-misc/dhcp/dhcp-3.0_p2-r5.ebuild
deleted file mode 100644
index b72fcaf3c7a1..000000000000
--- a/net-misc/dhcp/dhcp-3.0_p2-r5.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_p2-r5.ebuild,v 1.5 2004/07/18 06:02:28 vapier Exp $
-
-IUSE="static selinux"
-
-inherit eutils flag-o-matic
-
-MY_P=${P/_p/pl}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="ISC Dynamic Host Configuration Protocol."
-HOMEPAGE="http://www.isc.org/products/DHCP"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz"
-
-LICENSE="isc-dhcp"
-SLOT="0"
-KEYWORDS="x86 ppc sparc ~mips ppc64 hppa"
-
-DEPEND="virtual/libc
- >=sys-apps/sed-4"
-
-RDEPEND="selinux? ( sec-policy/selinux-dhcp )"
-
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A} && cd "${S}"
- epatch "${FILESDIR}/dhcp-3.0pl2-user-option-fix.patch"
- epatch "${FILESDIR}/dhclient.c-3.0-dw-cli-fix.patch"
- epatch "${FILESDIR}/dhcp-3.0+paranoia.patch"
-}
-
-src_compile() {
- # 01/Mar/2003: Fix for bug #11960 by Jason Wever <weeve@gentoo.org>
- if [ "${ARCH}" = "sparc" ] ; then
- filter-flags "-O3"
- filter-flags "-O2"
- filter-flags "-O"
- fi
-
- use static && append-flags -static
-
- cat <<-END >> includes/site.h
- #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
- #define _PATH_DHCPD_PID "/var/run/dhcp/dhcpd.pid"
- #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
- #define DHCPD_LOG_FACILITY LOG_LOCAL1
- END
-
- cat <<-END > site.conf
- CC = gcc
- LIBDIR = /usr/lib
- INCDIR = /usr/include
- ETC = /etc/dhcp
- VARDB = /var/lib/dhcp
- VARRUN = /var/run/dhcp
- ADMMANDIR = /usr/share/man/man8
- FFMANDIR = /usr/share/man/man5
- LIBMANDIR = /usr/share/man/man3
- USRMANDIR = /usr/share/man/man1
- END
-
- ./configure --with-nsupdate \
- --copts "-DPARANOIA -DEARLY_CHROOT ${CFLAGS}" || die "configure failed"
-
- emake || die "compile problem"
-}
-
-src_install() {
- enewgroup dhcp
- enewuser dhcp -1 /bin/false /var/lib/dhcp dhcp
-
- einstall DESTDIR="${D}"
-
- insinto /etc/dhcp
- newins server/dhcpd.conf dhcpd.conf.sample
- newins client/dhclient.conf dhclient.conf.sample
- dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" \
- /etc/dhcp/dhclient.conf.sample
- mv "${D}/sbin/dhclient-script" "${D}/etc/dhcp/dhclient-script.sample"
-
- dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES doc/*
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
-
- insinto /etc/conf.d
- newins "${FILESDIR}/dhcp.conf" dhcp
- exeinto /etc/init.d
- newexe "${FILESDIR}/dhcp.rc6" dhcp
-
- keepdir /var/{lib,run}/dhcp
-}
-
-pkg_postinst() {
- chown dhcp:dhcp "${ROOT}/var/lib/dhcp" "${ROOT}/var/run/dhcp"
-
- einfo "You can edit /etc/conf.d/dhcp to customize dhcp settings"
- einfo
- einfo "The DHCP ebuild now includes chroot support."
- einfo "If you like to run dhcpd in chroot AND this is a new install OR"
- einfo "your dhcpd doesn't already run in chroot, simply run:"
- einfo " ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
- einfo "Before running the above command you might want to change the chroot"
- einfo "dir in /etc/conf.d/dhcp, otherwise /chroot/dhcp will be used."
- echo
-}
-
-pkg_config() {
- CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/dhcp 2>/dev/null`
-
- if [ ! -d "${CHROOT:=/chroot/dhcp}" ] ; then
- ebegin "Setting up the chroot directory"
- mkdir -m 0755 -p "${CHROOT}/"{dev,etc,var/lib,var/run}
- cp -R /etc/dhcp "${CHROOT}/etc/"
- cp -R /var/lib/dhcp "${CHROOT}/var/lib"
- chown -R dhcp:dhcp "${CHROOT}/var/lib" "${CHROOT}/var/run"
- eend
-
- if [ "`grep '^#[[:blank:]]\?CHROOT' /etc/conf.d/dhcp`" ] ; then
- sed -e '/^#[[:blank:]]\?CHROOT/s/^#[[:blank:]]\?//' -i /etc/conf.d/dhcp
- fi
-
- einfo "To enable logging from the DHCP server, configure your"
- einfo "logger (`best_version virtual/logger`) to listen on ${CHROOT}/dev/log"
- else
- eerror
- eerror "${CHROOT} already exists. Quitting."
- eerror
- fi
-}
diff --git a/net-misc/dhcp/dhcp-3.0_p2-r6.ebuild b/net-misc/dhcp/dhcp-3.0_p2-r6.ebuild
deleted file mode 100644
index aa3c9b3318eb..000000000000
--- a/net-misc/dhcp/dhcp-3.0_p2-r6.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0_p2-r6.ebuild,v 1.5 2004/07/18 06:02:28 vapier Exp $
-
-IUSE="static selinux"
-
-inherit eutils flag-o-matic
-
-MY_P=${P/_p/pl}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="ISC Dynamic Host Configuration Protocol."
-HOMEPAGE="http://www.isc.org/products/DHCP"
-SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="isc-dhcp"
-KEYWORDS="x86 ~ppc ~ppc64 sparc ~mips hppa"
-
-RDEPEND="virtual/libc
- selinux? ( sec-policy/selinux-dhcp )"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-PROVIDE="virtual/dhcpc"
-
-src_unpack() {
- unpack ${A} && cd "${S}"
- epatch "${FILESDIR}/dhcp-3.0pl2-user-option-fix.patch"
- epatch "${FILESDIR}/dhclient.c-3.0-dw-cli-fix.patch"
- epatch "${FILESDIR}/dhcp-3.0+paranoia.patch"
- epatch "${FILESDIR}/dhcp-3.0pl2-fix-perms.patch"
-}
-
-src_compile() {
- # 01/Mar/2003: Fix for bug #11960 by Jason Wever <weeve@gentoo.org>
- if [ "${ARCH}" = "sparc" ] ; then
- filter-flags "-O3"
- filter-flags "-O2"
- filter-flags "-O"
- fi
-
- use static && append-flags -static
-
- cat <<-END >> includes/site.h
- #define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
- #define _PATH_DHCPD_PID "/var/run/dhcp/dhcpd.pid"
- #define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
- #define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
- #define DHCPD_LOG_FACILITY LOG_LOCAL1
- END
-
- cat <<-END > site.conf
- CC = gcc
- LIBDIR = /usr/lib
- INCDIR = /usr/include
- ETC = /etc/dhcp
- VARDB = /var/lib/dhcp
- VARRUN = /var/run/dhcp
- ADMMANDIR = /usr/share/man/man8
- FFMANDIR = /usr/share/man/man5
- LIBMANDIR = /usr/share/man/man3
- USRMANDIR = /usr/share/man/man1
- END
-
- ./configure --with-nsupdate \
- --copts "-DPARANOIA -DEARLY_CHROOT ${CFLAGS}" || die "configure failed"
-
- emake || die "compile problem"
-}
-
-src_install() {
- enewgroup dhcp
- enewuser dhcp -1 /bin/false /var/lib/dhcp dhcp
-
- einstall DESTDIR="${D}"
-
- insinto /etc/dhcp
- newins server/dhcpd.conf dhcpd.conf.sample
- newins client/dhclient.conf dhclient.conf.sample
- dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" \
- /etc/dhcp/dhclient.conf.sample
- mv "${D}/sbin/dhclient-script" "${D}/etc/dhcp/dhclient-script.sample"
-
- dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES doc/*
- newdoc client/dhclient.conf dhclient.conf.sample
- newdoc client/scripts/linux dhclient-script.sample
- newdoc server/dhcpd.conf dhcpd.conf.sample
-
- exeinto /etc/init.d
- newexe "${FILESDIR}/dhcp.rc6" dhcp
- newexe "${FILESDIR}/dhcrelay.rc6" dhcrelay
- insinto /etc/conf.d
- newins "${FILESDIR}/dhcp.conf" dhcp
- newins "${FILESDIR}/dhcrelay.conf" dhcrelay
-
- keepdir /var/{lib,run}/dhcp
-}
-
-pkg_postinst() {
- chown dhcp:dhcp "${ROOT}/var/lib/dhcp" "${ROOT}/var/run/dhcp"
-
- einfo "You can edit /etc/conf.d/dhcp to customize dhcp settings"
- einfo
- einfo "The DHCP ebuild now includes chroot support."
- einfo "If you like to run dhcpd in chroot AND this is a new install OR"
- einfo "your dhcpd doesn't already run in chroot, simply run:"
- einfo " ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
- einfo "Before running the above command you might want to change the chroot"
- einfo "dir in /etc/conf.d/dhcp, otherwise /chroot/dhcp will be used."
- echo
-}
-
-pkg_config() {
- CHROOT=`sed -n 's/^[[:blank:]]\?CHROOT="\([^"]\+\)"/\1/p' /etc/conf.d/dhcp 2>/dev/null`
-
- if [ ! -d "${CHROOT:=/chroot/dhcp}" ] ; then
- ebegin "Setting up the chroot directory"
- mkdir -m 0755 -p "${CHROOT}/"{dev,etc,var/lib,var/run/dhcp}
- cp -R /etc/dhcp "${CHROOT}/etc/"
- cp -R /var/lib/dhcp "${CHROOT}/var/lib"
- chown -R dhcp:dhcp "${CHROOT}/var/lib" "${CHROOT}/var/run/dhcp"
- eend
-
- if [ "`grep '^#[[:blank:]]\?CHROOT' /etc/conf.d/dhcp`" ] ; then
- sed -e '/^#[[:blank:]]\?CHROOT/s/^#[[:blank:]]\?//' -i /etc/conf.d/dhcp
- fi
-
- einfo "To enable logging from the DHCP server, configure your"
- einfo "logger (`best_version virtual/logger`) to listen on ${CHROOT}/dev/log"
- else
- eerror
- eerror "${CHROOT} already exists. Quitting."
- eerror
- fi
-}
diff --git a/net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch b/net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch
deleted file mode 100644
index dd3c8934aeb8..000000000000
--- a/net-misc/dhcp/files/dhclient.c-3.0-dw-cli-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-+++ client/dhclient.c Wed Aug 8 10:46:14 2001
---- client/dhclient.c.fix Sat Sep 21 12:15:21 2002
-***************
-*** 198,205 ****
- } else if (!strcmp (argv [i], "-w")) {
- /* do not exit if there are no broadcast interfaces. */
- persist = 1;
-- } else if (argv [i][0] == '-') {
-- usage ();
- } else if (!strcmp (argv [i], "-e")) {
- struct string_list *tmp;
- if (++i == argc)
---- 198,203 ----
-***************
-*** 216,221 ****
---- 214,221 ----
- exit (0);
- } else if (!strcmp (argv [i], "-nw")) {
- nowait = 1;
-+ } else if (argv [i][0] == '-') {
-+ usage ();
- } else {
- struct interface_info *tmp = (struct interface_info *)0;
- status = interface_allocate (&tmp, MDL);
diff --git a/net-misc/dhcp/files/dhcp-3.0pl2-user-option-fix.patch b/net-misc/dhcp/files/dhcp-3.0pl2-user-option-fix.patch
deleted file mode 100644
index ea385c1a1de3..000000000000
--- a/net-misc/dhcp/files/dhcp-3.0pl2-user-option-fix.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -ur dhcp-current/client/clparse.c dhcp-rentec/client/clparse.c
---- dhcp-current/client/clparse.c Tue Jun 26 20:29:27 2001
-+++ dhcp-rentec/client/clparse.c Thu Oct 17 16:37:31 2002
-@@ -599,34 +599,41 @@
- struct parse *cfile;
- u_int32_t **list;
- {
-- int ix, i;
-+ int ix;
- int token;
- const char *val;
- pair p = (pair)0, q, r;
-+ struct option *option;
-
- ix = 0;
- do {
-- token = next_token (&val, (unsigned *)0, cfile);
-- if (token == SEMI)
-+ token = peek_token (&val, (unsigned *)0, cfile);
-+ if (token == SEMI) {
-+ token = next_token (&val, (unsigned *)0, cfile);
- break;
-+ }
- if (!is_identifier (token)) {
- parse_warn (cfile, "%s: expected option name.", val);
-+ token = next_token (&val, (unsigned *)0, cfile);
- skip_to_semi (cfile);
- return;
- }
-- for (i = 0; i < 256; i++) {
-- if (!strcasecmp (dhcp_options [i].name, val))
-- break;
-+ option = parse_option_name (cfile, 0, NULL);
-+ if (!option) {
-+ parse_warn (cfile, "expected option name.");
-+ return;
- }
-- if (i == 256) {
-- parse_warn (cfile, "%s: expected option name.", val);
-+ if (option -> universe != &dhcp_universe) {
-+ parse_warn (cfile, "%s.%s: Only global options allowed.",
-+ option -> universe -> name,
-+ option -> name);
- skip_to_semi (cfile);
- return;
- }
- r = new_pair (MDL);
- if (!r)
- log_fatal ("can't allocate pair for option code.");
-- r -> car = (caddr_t)(long)i;
-+ r -> car = (caddr_t)(long)option -> code;
- r -> cdr = (pair)0;
- if (p)
- q -> cdr = r;
diff --git a/net-misc/dhcp/files/dhcp.rc7 b/net-misc/dhcp/files/dhcp.rc7
deleted file mode 100644
index 15c64469bd98..000000000000
--- a/net-misc/dhcp/files/dhcp.rc7
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/files/dhcp.rc7,v 1.6 2004/07/14 23:56:54 agriffis Exp $
-
-#configuration is done in /etc/conf.d/dhcp
-
-depend() {
- need net
- use named
-}
-
-checkconfig() {
- if [ ! -e /etc/dhcp/dhcpd.conf ] ; then
- eerror "You need an /etc/dhcp/dhcpd.conf file to run dhcpd"
- eerror "There is a sample conf file in /usr/share/doc/dhcp"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting dhcpd"
- start-stop-daemon --start --quiet --exec /usr/sbin/dhcpd -- ${DHCPD_OPTS} ${IFACE}
- eend $?
-}
-
-stop() {
- ebegin "Stopping dhcpd"
- start-stop-daemon --stop --quiet --exec /usr/sbin/dhcpd
- eend $?
-}
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_p2-r4 b/net-misc/dhcp/files/digest-dhcp-3.0_p2-r4
deleted file mode 100644
index 69ed0169648a..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_p2-r4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2cb5db7a0c23deaef4724b5fc3f9a869 dhcp-3.0pl2.tar.gz 865196
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_p2-r5 b/net-misc/dhcp/files/digest-dhcp-3.0_p2-r5
deleted file mode 100644
index 69ed0169648a..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_p2-r5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2cb5db7a0c23deaef4724b5fc3f9a869 dhcp-3.0pl2.tar.gz 865196
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0_p2-r6 b/net-misc/dhcp/files/digest-dhcp-3.0_p2-r6
deleted file mode 100644
index 69ed0169648a..000000000000
--- a/net-misc/dhcp/files/digest-dhcp-3.0_p2-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2cb5db7a0c23deaef4724b5fc3f9a869 dhcp-3.0pl2.tar.gz 865196