summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2012-07-31 12:18:01 +0000
committerTony Vroon <chainsaw@gentoo.org>2012-07-31 12:18:01 +0000
commit49d3d8ae198e036e929b899d918dfcbfe82f3acc (patch)
treebe5f2130325633d4de5205cc4b294be0d72ba0ee /net-misc/connman
parentNot compatible with xorg-server-1.13 yet (diff)
downloadgentoo-2-49d3d8ae198e036e929b899d918dfcbfe82f3acc.tar.gz
gentoo-2-49d3d8ae198e036e929b899d918dfcbfe82f3acc.tar.bz2
gentoo-2-49d3d8ae198e036e929b899d918dfcbfe82f3acc.zip
Version bump as requested by "teidakankan" in bug #427658. Also adding intermediate versions in case any bugs got introduced by the rather extensive feature additions. Remove now unused google & ntpd locale USE flag descriptions.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/ChangeLog14
-rw-r--r--net-misc/connman/connman-1.1.ebuild64
-rw-r--r--net-misc/connman/connman-1.2.ebuild64
-rw-r--r--net-misc/connman/connman-1.3.ebuild64
-rw-r--r--net-misc/connman/connman-1.4.ebuild64
-rw-r--r--net-misc/connman/metadata.xml2
6 files changed, 269 insertions, 3 deletions
diff --git a/net-misc/connman/ChangeLog b/net-misc/connman/ChangeLog
index 88d46566601e..f62064ac355e 100644
--- a/net-misc/connman/ChangeLog
+++ b/net-misc/connman/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-misc/connman
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.56 2012/07/19 20:41:36 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/ChangeLog,v 1.57 2012/07/31 12:18:01 chainsaw Exp $
+
+*connman-1.4 (31 Jul 2012)
+*connman-1.3 (31 Jul 2012)
+*connman-1.2 (31 Jul 2012)
+*connman-1.1 (31 Jul 2012)
+
+ 31 Jul 2012; Tony Vroon <chainsaw@gentoo.org> +connman-1.1.ebuild,
+ +connman-1.2.ebuild, +connman-1.3.ebuild, +connman-1.4.ebuild, metadata.xml:
+ Version bump as requested by "teidakankan" in bug #427658. Also adding
+ intermediate versions in case any bugs got introduced by the rather extensive
+ feature additions. Remove now unused google & ntpd locale USE flag
+ descriptions.
19 Jul 2012; Markus Meier <maekke@gentoo.org> connman-1.0-r1.ebuild:
arm stable, bug #424625
diff --git a/net-misc/connman/connman-1.1.ebuild b/net-misc/connman/connman-1.1.ebuild
new file mode 100644
index 000000000000..a6dd07f1a809
--- /dev/null
+++ b/net-misc/connman/connman-1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.1.ebuild,v 1.1 2012/07/31 12:18:01 chainsaw Exp $
+
+EAPI="4"
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn policykit threads tools vpnc +wifi wimax"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=dev-libs/libnl-1.1
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )
+ wimax? ( net-wireless/wimax )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wimax iwmx builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/cm || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}
diff --git a/net-misc/connman/connman-1.2.ebuild b/net-misc/connman/connman-1.2.ebuild
new file mode 100644
index 000000000000..d7ff5b8d0ec0
--- /dev/null
+++ b/net-misc/connman/connman-1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.2.ebuild,v 1.1 2012/07/31 12:18:01 chainsaw Exp $
+
+EAPI="4"
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn policykit threads tools vpnc +wifi wimax"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=dev-libs/libnl-1.1
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )
+ wimax? ( net-wireless/wimax )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wimax iwmx builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/cm || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}
diff --git a/net-misc/connman/connman-1.3.ebuild b/net-misc/connman/connman-1.3.ebuild
new file mode 100644
index 000000000000..d28435ec7dfe
--- /dev/null
+++ b/net-misc/connman/connman-1.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.3.ebuild,v 1.1 2012/07/31 12:18:01 chainsaw Exp $
+
+EAPI="4"
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn policykit threads tools vpnc +wifi wimax"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=dev-libs/libnl-1.1
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )
+ wimax? ( net-wireless/wimax )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wimax iwmx builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/cm || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}
diff --git a/net-misc/connman/connman-1.4.ebuild b/net-misc/connman/connman-1.4.ebuild
new file mode 100644
index 000000000000..8f161d91b3d7
--- /dev/null
+++ b/net-misc/connman/connman-1.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/connman/connman-1.4.ebuild,v 1.1 2012/07/31 12:18:01 chainsaw Exp $
+
+EAPI="4"
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="http://connman.net"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug doc examples +ethernet ofono openvpn policykit threads tools vpnc +wifi wimax"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ >=dev-libs/libnl-1.1
+ >=net-firewall/iptables-1.4.8
+ net-libs/gnutls
+ bluetooth? ( net-wireless/bluez )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ openvpn? ( net-misc/openvpn )
+ vpnc? ( net-misc/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-0.7[dbus] )
+ wimax? ( net-wireless/wimax )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wimax iwmx builtin) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable threads) \
+ $(use_enable tools) \
+ --disable-iospm \
+ --disable-hh2serial-gps \
+ --disable-openconnect
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin client/cm || die "client installation failed"
+
+ keepdir /var/lib/${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+}
diff --git a/net-misc/connman/metadata.xml b/net-misc/connman/metadata.xml
index e36695a97d25..bd48167bc004 100644
--- a/net-misc/connman/metadata.xml
+++ b/net-misc/connman/metadata.xml
@@ -7,8 +7,6 @@
</maintainer>
<use>
<flag name="ethernet">Enable ethernet support.</flag>
- <flag name="google">Enable Google Public DNS support.</flag>
- <flag name="ntpd">Use <pkg>net-misc/ntp</pkg> for nptd plugin.</flag>
<flag name="ofono">Use <pkg>net-misc/ofono</pkg> for telephony support.</flag>
<flag name="openvpn">Use <pkg>net-misc/openvpn</pkg> for openvpn support.</flag>
<flag name="tools">Enable testing tools.</flag>