summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-02-11 18:45:45 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-02-11 18:45:45 +0000
commit06673517679c1284122de060ba5a6f774bc520db (patch)
treef2ac313834b56242377bf3eeab44aebe8110b84c /net-misc/axel
parentamd64 stable wrt bug #201405 (diff)
downloadgentoo-2-06673517679c1284122de060ba5a6f774bc520db.tar.gz
gentoo-2-06673517679c1284122de060ba5a6f774bc520db.tar.bz2
gentoo-2-06673517679c1284122de060ba5a6f774bc520db.zip
Version Bump wrt bug #209577
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-misc/axel')
-rw-r--r--net-misc/axel/ChangeLog7
-rw-r--r--net-misc/axel/axel-1.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-misc/axel/ChangeLog b/net-misc/axel/ChangeLog
index 05d9793a6627..32eec1c52813 100644
--- a/net-misc/axel/ChangeLog
+++ b/net-misc/axel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/axel
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.36 2008/02/03 16:13:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/ChangeLog,v 1.37 2008/02/11 18:45:45 drizzt Exp $
+
+*axel-1.1 (11 Feb 2008)
+
+ 11 Feb 2008; Timothy Redaelli <drizzt@gentoo.org> +axel-1.1.ebuild:
+ Version Bump wrt bug #209577
03 Feb 2008; Fabian Groffen <grobian@gentoo.org> axel-1.0b.ebuild,
axel-1.0b-r1.ebuild, axel-1.0b-r2.ebuild:
diff --git a/net-misc/axel/axel-1.1.ebuild b/net-misc/axel/axel-1.1.ebuild
new file mode 100644
index 000000000000..ba1f7bf6e1b7
--- /dev/null
+++ b/net-misc/axel/axel-1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-1.1.ebuild,v 1.1 2008/02/11 18:45:45 drizzt Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2287/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Set LDFLAGS and fix expr
+ sed -i -e 's/expr/& --/' -e "s/^LFLAGS=$/&${LDFLAGS}/" configure
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--debug=1"
+ use nls && myconf="--i18n=1"
+ econf \
+ --strip=0 \
+ --etcdir=/etc \
+ ${myconf} \
+ || die
+
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc API CHANGES CREDITS README axelrc.example
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND="/usr/bin/axel -a -o \${DISTDIR}/\${FILE} \${URI}"'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}