summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-09-29 16:34:45 +0000
committerJim Ramsay <lack@gentoo.org>2008-09-29 16:34:45 +0000
commit29c8f191f39fe5e33ead063c3bfdab200165eb1b (patch)
tree457934dd7f6df5527d4ec00396835885bd7a8ed3 /net-misc/amazonmp3/amazonmp3-1.0.3-r2.ebuild
parentVersion bump, net-misc/wicd-1.5.3 (diff)
downloadgentoo-2-29c8f191f39fe5e33ead063c3bfdab200165eb1b.tar.gz
gentoo-2-29c8f191f39fe5e33ead063c3bfdab200165eb1b.tar.bz2
gentoo-2-29c8f191f39fe5e33ead063c3bfdab200165eb1b.zip
Forcing boost version to 1.34, on advice of boost maintainers.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'net-misc/amazonmp3/amazonmp3-1.0.3-r2.ebuild')
-rw-r--r--net-misc/amazonmp3/amazonmp3-1.0.3-r2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/amazonmp3/amazonmp3-1.0.3-r2.ebuild b/net-misc/amazonmp3/amazonmp3-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..759141284fdd
--- /dev/null
+++ b/net-misc/amazonmp3/amazonmp3-1.0.3-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/amazonmp3/amazonmp3-1.0.3-r2.ebuild,v 1.1 2008/09/29 16:34:45 lack Exp $
+
+EAPI=2
+
+inherit rpm fdo-mime multilib
+
+DESCRIPTION="AmazonMp3 is a download manager which interfaces with the http://mp3.amazon.com music store"
+HOMEPAGE="http://www.amazon.com/gp/dmusic/help/amd.html/"
+SRC_URI="amazonmp3.rpm"
+RESTRICT="fetch strip"
+
+LICENSE="amazonmp3"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+
+RDEPEND="dev-cpp/gtkmm:2.4[accessibility]
+ net-misc/curl
+ dev-libs/openssl
+ =dev-libs/boost-1.34*"
+DEPEND=""
+
+S="${WORKDIR}/usr/"
+
+pkg_nofetch() {
+ einfo "Due to licensing restrictions, you must download this software from"
+ einfo "amazon.com manually:"
+ einfo " - Visit ${HOMEPAGE}"
+ einfo " - Agree to the Terms of Service, click the agreement box, and"
+ einfo " download the version for 'Fedora 8'. It will be called"
+ einfo " 'amazonmp3.rpm'"
+ einfo " - Copy 'amazonmp3.rpm' into ${DISTDIR}"
+ einfo " - Run 'ebuild amazonmp3' again."
+ einfo "If the version does not match or if you get any errors about the"
+ einfo "rpm you just downloaded, file a bug at http://bugs.gentoo.org, and"
+ einfo "be sure to include the output of 'file amazonmp3.rpm'"
+}
+
+src_install() {
+ # Their binary, compiled for Fedora 8, needs some odd library names, so we
+ # symlink them:
+ dosym libboost_date_time.so /usr/$(get_libdir)/libboost_date_time.so.3
+ dosym libboost_iostreams.so /usr/$(get_libdir)/libboost_iostreams.so.3
+ dosym libboost_signals.so /usr/$(get_libdir)/libboost_signals.so.3
+ dosym libboost_thread-mt.so /usr/$(get_libdir)/libboost_thread-mt.so.3
+ dosym libcrypto.so /usr/$(get_libdir)/libcrypto.so.6
+ dosym libssl.so /usr/$(get_libdir)/libssl.so.6
+
+ dobin bin/amazonmp3 || die "dobin failed"
+
+ insinto "/usr/share"
+ doins -r share/{applications,pixmaps,mime,mime-info,mimelnk} || die "doins failed"
+
+ dodoc share/doc/amazonmp3/releasenotes
+ dohtml share/doc/amazonmp3/*.html
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}