summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-11-15 00:57:34 +0000
committerJeroen Roovers <jer@gentoo.org>2014-11-15 00:57:34 +0000
commite50e9b774867e0073690ccbaa3119dbdcea163fa (patch)
tree3c339facec7010317e7571ff999e28b8e19869ff /net-mail
parentold (diff)
downloadgentoo-2-e50e9b774867e0073690ccbaa3119dbdcea163fa.tar.gz
gentoo-2-e50e9b774867e0073690ccbaa3119dbdcea163fa.tar.bz2
gentoo-2-e50e9b774867e0073690ccbaa3119dbdcea163fa.zip
Fix building against sys-libs/ncurses[tinfo] (bug #527664). Do not install static plugins.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pfqueue/ChangeLog10
-rw-r--r--net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch10
-rw-r--r--net-mail/pfqueue/pfqueue-0.5.6.ebuild36
3 files changed, 39 insertions, 17 deletions
diff --git a/net-mail/pfqueue/ChangeLog b/net-mail/pfqueue/ChangeLog
index beecb1dab56b..8ffaac1582f0 100644
--- a/net-mail/pfqueue/ChangeLog
+++ b/net-mail/pfqueue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/pfqueue
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pfqueue/ChangeLog,v 1.44 2010/05/07 04:15:42 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pfqueue/ChangeLog,v 1.45 2014/11/15 00:57:34 jer Exp $
+
+ 15 Nov 2014; Jeroen Roovers <jer@gentoo.org> +files/pfqueue-0.5.6-tinfo.patch,
+ pfqueue-0.5.6.ebuild:
+ Fix building against sys-libs/ncurses[tinfo] (bug #527664). Do not install
+ static plugins.
07 May 2010; Jeroen Roovers <jer@gentoo.org> pfqueue-0.5.6.ebuild:
Fix implicit RDEPEND (bug #221631).
@@ -194,4 +199,3 @@
05 Jan 2005; Andrej Kacian <ticho@gentoo.org> +metadata.xml,
+pfqueue-0.2.0.ebuild:
Initial import, ebuild submitted by eGore <egore@gmx.de>. Closes #75173.
-
diff --git a/net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch b/net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch
new file mode 100644
index 000000000000..6efd5bb0d74b
--- /dev/null
+++ b/net-mail/pfqueue/files/pfqueue-0.5.6-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -38,6 +38,7 @@
+
+ dnl Checks for library functions.
+ AC_CHECK_LIB(ncurses,newwin)
++AC_SEARCH_LIBS(COLS, tinfo)
+ AC_CHECK_LIB(pthread,pthread_create)
+ AC_CHECK_LIB(c_r,pthread_create)
+ AC_CHECK_LIB(dl,dlopen)
diff --git a/net-mail/pfqueue/pfqueue-0.5.6.ebuild b/net-mail/pfqueue/pfqueue-0.5.6.ebuild
index 9c06374c3068..8049d1d775c8 100644
--- a/net-mail/pfqueue/pfqueue-0.5.6.ebuild
+++ b/net-mail/pfqueue/pfqueue-0.5.6.ebuild
@@ -1,27 +1,35 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pfqueue/pfqueue-0.5.6.ebuild,v 1.7 2010/05/07 04:15:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pfqueue/pfqueue-0.5.6.ebuild,v 1.8 2014/11/15 00:57:34 jer Exp $
-inherit eutils toolchain-funcs
+EAPI=5
+inherit autotools eutils toolchain-funcs
-DESCRIPTION="pfqueue is an ncurses console-based tool for managing Postfix
-queued messages"
+DESCRIPTION="pfqueue is an ncurses console-based tool for managing Postfix queued messages"
HOMEPAGE="http://pfqueue.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND="sys-devel/libtool
- sys-libs/ncurses"
-RDEPEND=""
-src_compile() {
- econf || die "econf failed"
- emake || die "make failed"
+RDEPEND="
+ sys-libs/ncurses
+ sys-devel/libtool
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
}
+DOCS=( README ChangeLog NEWS TODO AUTHORS )
+
src_install() {
- make DESTDIR="${D}" install || die
- dodoc README ChangeLog NEWS TODO AUTHORS
+ default
+ prune_libtool_files
}