summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-12-05 11:24:12 +0000
committerEray Aslan <eras@gentoo.org>2011-12-05 11:24:12 +0000
commitc2b0c4ebe962a36d95c8d93f49748416e141caf7 (patch)
treea2e360b23812f0fa7e4d846e52a330009ffca706 /net-mail
parentDrop gnome team from metadata as talked with leio and eva. (diff)
downloadgentoo-2-c2b0c4ebe962a36d95c8d93f49748416e141caf7.tar.gz
gentoo-2-c2b0c4ebe962a36d95c8d93f49748416e141caf7.tar.bz2
gentoo-2-c2b0c4ebe962a36d95c8d93f49748416e141caf7.zip
Fix sieve SRC_URI and directories - bug #393173
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog5
-rw-r--r--net-mail/dovecot/dovecot-2.1_rc1.ebuild27
2 files changed, 22 insertions, 10 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index f2d5a0b1cb2e..bc4f90987b62 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/dovecot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.331 2011/12/04 06:59:12 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.332 2011/12/05 11:24:12 eras Exp $
+
+ 05 Dec 2011; Eray Aslan <eras@gentoo.org> dovecot-2.1_rc1.ebuild:
+ Fix sieve SRC_URI and directories - bug #393173
*dovecot-2.1_rc1 (04 Dec 2011)
diff --git a/net-mail/dovecot/dovecot-2.1_rc1.ebuild b/net-mail/dovecot/dovecot-2.1_rc1.ebuild
index 61136cca5084..1fe65c14548d 100644
--- a/net-mail/dovecot/dovecot-2.1_rc1.ebuild
+++ b/net-mail/dovecot/dovecot-2.1_rc1.ebuild
@@ -1,28 +1,31 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-2.1_rc1.ebuild,v 1.1 2011/12/04 06:59:12 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-2.1_rc1.ebuild,v 1.2 2011/12/05 11:24:12 eras Exp $
EAPI=4
-inherit eutils versionator ssl-cert
+inherit eutils versionator ssl-cert autotools
MY_P="${P/_/.}"
major_minor="$( get_version_component_range 1-2 )"
+major_dash_minor="$( replace_version_separator 1 - ${major_minor} )"
sieve_version="0.3.0"
sieve_snapshot="b3bff60a18da"
SRC_URI="http://www.dovecot.org/releases/${major_minor}/rc/${MY_P}.tar.gz
sieve? (
- http://www.rename-it.nl/${PN}/${major_minor}/${PN}-${major_minor}-pigeonhole-${sieve_snapshot}.tar.bz2
+ http://hg.rename-it.nl/${PN}-${major_minor}-pigeonhole/archive/{sieve_snapshot}.tar.bz2 \
+ -> ${PN}-${major_minor}-pigeonhole-${sieve_snapshot}.tar.bz2
)
managesieve? (
- http://www.rename-it.nl/${PN}/${major_minor}/${PN}-${major_minor}-pigeonhole-${sieve_snapshot}.tar.bz2
+ http://hg.rename-it.nl/${PN}-${major_minor}-pigeonhole/archive/{sieve_snapshot}.tar.bz2 \
+ -> ${PN}-${major_minor}-pigeonhole-${sieve_snapshot}.tar.bz2
) "
DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
HOMEPAGE="http://www.dovecot.org/"
SLOT="0"
LICENSE="LGPL-2.1 MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~s390 ~sparc ~x86 ~x86-fbsd"
IUSE="bzip2 caps cydir sdbox doc ipv6 imapc kerberos ldap lucene +maildir managesieve mbox
mdbox mysql pam postgres sieve sqlite +ssl static-libs suid vpopmail zlib"
@@ -45,6 +48,7 @@ RDEPEND="${DEPEND}
S=${WORKDIR}/${MY_P}
pkg_setup() {
+ elog "${PN}-${major_minor}-pigeonhole-${sieve_snapshot}.tar.bz2"
if use managesieve && ! use sieve; then
ewarn "managesieve USE flag selected but sieve USE flag unselected"
ewarn "sieve USE flag will be turned on"
@@ -65,6 +69,11 @@ pkg_setup() {
src_prepare() {
cp "${FILESDIR}/SnowballAnalyzer.h" "${S}/src/plugins/fts-lucene" || die
cp "${FILESDIR}/SnowballFilter.h" "${S}/src/plugins/fts-lucene" || die
+ if use sieve || use managesieve ; then
+ cd "../dovecot-${major_dash_minor}-pigeonhole-${sieve_snapshot}" \
+ || die "cd failed"
+ eautoreconf
+ fi
}
src_configure() {
@@ -107,7 +116,7 @@ src_configure() {
# The sieve plugin needs this file to be build to determine the plugin
# directory and the list of libraries to link to.
emake dovecot-config || die "emake dovecot-config failed"
- cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ cd "../dovecot-${major_dash_minor}-pigeonhole-${sieve_snapshot}" || die "cd failed"
econf \
$( use_enable static-libs static ) \
--localstatedir="${EPREFIX}/var" \
@@ -121,7 +130,7 @@ src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
if use sieve || use managesieve ; then
- cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ cd "../dovecot-${major_dash_minor}-pigeonhole-${sieve_snapshot}" || die "cd failed"
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
fi
}
@@ -129,7 +138,7 @@ src_compile() {
src_test() {
default_src_test
if use sieve || use managesieve ; then
- cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ cd "../dovecot-${major_dash_minor}-pigeonhole-${sieve_snapshot}" || die "cd failed"
default_src_test
fi
}
@@ -243,7 +252,7 @@ src_install () {
fi
if use sieve || use managesieve ; then
- cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+ cd "../dovecot-${major_dash_minor}-pigeonhole-${sieve_snapshot}" || die "cd failed"
emake DESTDIR="${ED}" install
sed -i -e \
's/^[[:space:]]*#mail_plugins = $mail_plugins/mail_plugins = sieve/' "${confd}/15-lda.conf" \