summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-02-20 23:48:21 +0000
committerDonny Davies <woodchip@gentoo.org>2002-02-20 23:48:21 +0000
commita2e37eab2a41d5f2f37e85954b631866e2613c31 (patch)
tree6d822611d4dadc7ab0c02c43d8157858e05af9b9 /net-mail
parentadded slots (diff)
downloadgentoo-2-a2e37eab2a41d5f2f37e85954b631866e2613c31.tar.gz
gentoo-2-a2e37eab2a41d5f2f37e85954b631866e2613c31.tar.bz2
gentoo-2-a2e37eab2a41d5f2f37e85954b631866e2613c31.zip
fixed permissions on postdrop and postqueue.
fixed silly ccargs/auxlibs nukage. doh!
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/postfix/ChangeLog11
-rw-r--r--net-mail/postfix/files/digest-postfix-1.1.3-r2 (renamed from net-mail/postfix/files/digest-postfix-1.1.3-r1)0
-rw-r--r--net-mail/postfix/postfix-1.1.3-r2.ebuild (renamed from net-mail/postfix/postfix-1.1.3-r1.ebuild)41
3 files changed, 38 insertions, 14 deletions
diff --git a/net-mail/postfix/ChangeLog b/net-mail/postfix/ChangeLog
index 5a9f0087e8cd..1c10a73dadee 100644
--- a/net-mail/postfix/ChangeLog
+++ b/net-mail/postfix/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-mail/postfix
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.3 2002/02/19 00:57:17 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.4 2002/02/20 23:48:21 woodchip Exp $
+
+*postfix-1.1.3-r2 (20 Feb 2002)
+
+ 20 Feb 2002; Donny Davies <woodchip@gentoo.org> postfix-1.1.3-r2.ebuild :
+
+ This update fixes the permissions and ownership on /usr/sbin/postdrop and
+ /usr/sbin/postqueue, which were not set correctly last time. Moved the
+ postdrop group detection/creation into pkg_setup() to facilitate this.
+ *Really* fix the CCARGS and AUXLIBS getting nuked this time. Hooray!
*postfix-1.1.3-r1 (18 Feb 2002)
diff --git a/net-mail/postfix/files/digest-postfix-1.1.3-r1 b/net-mail/postfix/files/digest-postfix-1.1.3-r2
index d112907360b5..d112907360b5 100644
--- a/net-mail/postfix/files/digest-postfix-1.1.3-r1
+++ b/net-mail/postfix/files/digest-postfix-1.1.3-r2
diff --git a/net-mail/postfix/postfix-1.1.3-r1.ebuild b/net-mail/postfix/postfix-1.1.3-r2.ebuild
index 9dbcbd3f5594..e32e8138a85d 100644
--- a/net-mail/postfix/postfix-1.1.3-r1.ebuild
+++ b/net-mail/postfix/postfix-1.1.3-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-1.1.3-r1.ebuild,v 1.1 2002/02/19 00:57:17 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-1.1.3-r2.ebuild,v 1.1 2002/02/20 23:48:21 woodchip Exp $
DESCRIPTION="A fast and secure drop-in replacement for sendmail"
HOMEPAGE="http://www.postfix.org/"
@@ -22,11 +22,19 @@ DEPEND="virtual/glibc
mta-tls? ( >=dev-libs/openssl-0.9.6c )"
RDEPEND="${DEPEND} >=net-mail/mailbase-0.00 !virtual/mta"
+pkg_setup() {
+ if ! grep -q ^postdrop: /etc/group ; then
+ groupadd postdrop || die "problem adding group postdrop"
+ fi
+}
+
src_unpack() {
unpack ${A}
- use mta-tls && \
- ( cd ${S} ; patch -p1 < ${WORKDIR}/pfixtls-${POSTFIX_TLS_VER}/pfixtls.diff || die )
+ if [ "`use mta-tls`" ] ; then
+ cd ${S}
+ patch -p1 < ${WORKDIR}/pfixtls-${POSTFIX_TLS_VER}/pfixtls.diff || die
+ fi
cd ${S}/conf
cp main.cf main.cf.orig
@@ -36,12 +44,20 @@ src_unpack() {
cp mail_params.h mail_params.h.orig
sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" mail_params.h.orig > mail_params.h
- use mta-mysql && \
- ( CCARGS="${CCARGS} -DHAS_MYSQL" ; AUXLIBS="${AUXLIBS} -lmysqlclient -lm" )
- use mta-ldap && \
- ( CCARGS="${CCARGS} -DHAS_LDAP" ; AUXLIBS="${AUXLIBS} -lldap -llber" )
- use mta-tls && \
- ( CCARGS="${CCARGS} -DHAS_SSL" ; AUXLIBS="${AUXLIBS} -lssl" )
+ if [ "`use mta-mysql`" ] ; then
+ CCARGS="${CCARGS} -DHAS_MYSQL"
+ AUXLIBS="${AUXLIBS} -lmysqlclient -lm"
+ fi
+
+ if [ "`use mta-ldap`" ] ; then
+ CCARGS="${CCARGS} -DHAS_LDAP"
+ AUXLIBS="${AUXLIBS} -lldap -llber"
+ fi
+
+ if [ "`use mta-tls`" ] ; then
+ CCARGS="${CCARGS} -DHAS_SSL"
+ AUXLIBS="${AUXLIBS} -lssl"
+ fi
# stuff we always want...
CCARGS="${CCARGS} -I/usr/include -DHAS_PCRE -DUSE_SASL_AUTH"
@@ -63,6 +79,9 @@ src_install () {
cd ${S}/bin
dosbin post* sendmail
+ chown root.postdrop ${D}/usr/sbin/{postdrop,postqueue}
+ chmod 2755 ${D}/usr/sbin/{postdrop,postqueue}
+
dosym /usr/sbin/sendmail /usr/bin/mail
dosym /usr/sbin/sendmail /usr/bin/mailq
dosym /usr/sbin/sendmail /usr/bin/newaliases
@@ -98,10 +117,6 @@ src_install () {
pkg_postinst() {
install -d 0755 ${ROOT}/var/spool/postfix
- if ! grep -q ^postdrop: /etc/group ; then
- groupadd postdrop || die "problem adding group postdrop"
- fi
-
echo
echo "*****************************************************************"
echo "* NOTE: Be sure to update /etc/postfix/master.cf to the latest *"