summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-07-06 15:11:40 +0000
committerTorsten Veller <tove@gentoo.org>2010-07-06 15:11:40 +0000
commit1f1d46dd826f53fd54970378b1c080c53fd99672 (patch)
tree757e4b940879dc2dc8920497b313d7ea2b1e31ae /net-mail
parentUse PYTHON_DEPEND instead of NEED_PYTHON. (diff)
downloadgentoo-2-1f1d46dd826f53fd54970378b1c080c53fd99672.tar.gz
gentoo-2-1f1d46dd826f53fd54970378b1c080c53fd99672.tar.bz2
gentoo-2-1f1d46dd826f53fd54970378b1c080c53fd99672.zip
Version bump (#327125). Thanks to Tim Harder
(Portage version: 2.2_rc67_p182/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/lbdb/ChangeLog9
-rw-r--r--net-mail/lbdb/lbdb-0.37.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/net-mail/lbdb/ChangeLog b/net-mail/lbdb/ChangeLog
index db21d3b34fd8..9afa0cbe4e76 100644
--- a/net-mail/lbdb/ChangeLog
+++ b/net-mail/lbdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/lbdb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.49 2009/12/08 21:15:24 tcunha Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.50 2010/07/06 15:11:40 tove Exp $
+
+*lbdb-0.37 (06 Jul 2010)
+
+ 06 Jul 2010; Torsten Veller <tove@gentoo.org> +lbdb-0.37.ebuild:
+ Version bump (#327125). Thanks to Tim Harder
08 Dec 2009; Tiago Cunha <tcunha@gentoo.org> lbdb-0.36-r1.ebuild:
stable sparc, bug 289954
diff --git a/net-mail/lbdb/lbdb-0.37.ebuild b/net-mail/lbdb/lbdb-0.37.ebuild
new file mode 100644
index 000000000000..e9bc7850bda1
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.37.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.37.ebuild,v 1.1 2010/07/06 15:11:40 tove Exp $
+
+EAPI=3
+
+inherit versionator eutils
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE="pda ldap finger nis abook crypt evo"
+
+DEPEND="dev-libs/libvformat
+ evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )
+ nis? ( net-nds/yp-tools )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/p5-Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_configure() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if use evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/$(get_version_component_range 1-2 ${evoversion})/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ $(use_with nis ypcat) \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --enable-lbdb-dotlock \
+ --without-pgp5 --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb
+}
+
+src_install () {
+ emake install_prefix="${D}" install || die
+ dodoc README TODO debian/changelog
+}