summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-01-19 03:12:04 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-01-19 03:12:04 +0000
commit0cdab695c108fc761ffb9e91fbf6cd42259ca57c (patch)
tree8979105062f34a0248fa331879ea2b7b2ce6a261 /net-mail
parentrepoman: Fix leading whitespace (Manifest recommit) (diff)
downloadgentoo-2-0cdab695c108fc761ffb9e91fbf6cd42259ca57c.tar.gz
gentoo-2-0cdab695c108fc761ffb9e91fbf6cd42259ca57c.tar.bz2
gentoo-2-0cdab695c108fc761ffb9e91fbf6cd42259ca57c.zip
Version bump.
(Portage version: 2.0.51-r13)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.3.11
-rw-r--r--net-mail/getmail/getmail-4.3.1.ebuild49
3 files changed, 56 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 2ac6294fe394..269bcfb000b9 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.46 2005/01/17 19:41:28 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.47 2005/01/19 03:12:04 ticho Exp $
+
+*getmail-4.3.1 (19 Jan 2005)
+
+ 19 Jan 2005; Andrej Kacian <ticho@gentoo.org> +getmail-4.3.1.ebuild:
+ Version bump.
17 Jan 2005; Gustavo Zacarias <gustavoz@gentoo.org> getmail-4.2.5.ebuild:
Stable on sparc
diff --git a/net-mail/getmail/files/digest-getmail-4.3.1 b/net-mail/getmail/files/digest-getmail-4.3.1
new file mode 100644
index 000000000000..99e62a8cbb4f
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.3.1
@@ -0,0 +1 @@
+MD5 5b73b4b068d8d070ef01d31c7b553d35 getmail-4.3.1.tar.gz 128854
diff --git a/net-mail/getmail/getmail-4.3.1.ebuild b/net-mail/getmail/getmail-4.3.1.ebuild
new file mode 100644
index 000000000000..6b533a94246e
--- /dev/null
+++ b/net-mail/getmail/getmail-4.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.3.1.ebuild,v 1.1 2005/01/19 03:12:04 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://www.qcc.ca/~charlesc/software/getmail-4/"
+SRC_URI="http://www.qcc.ca/~charlesc/software/getmail-4/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ mkdir ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+ gzip --silent ${D}/usr/share/doc/${PF}/*
+}
+
+pkg_postinst() {
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}