summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-01-30 19:18:13 +0000
committerJeroen Roovers <jer@gentoo.org>2011-01-30 19:18:13 +0000
commitfd76ea7b76dc49236c60842259e4720fe678ecbb (patch)
treed7fde3ae19ae9ba34d595aa7b0d7703bd9776db1 /net-mail/serialmail
parentalpha/arm/ia64/s390/sh/sparc stable wrt #348987 (diff)
downloadgentoo-2-fd76ea7b76dc49236c60842259e4720fe678ecbb.tar.gz
gentoo-2-fd76ea7b76dc49236c60842259e4720fe678ecbb.tar.bz2
gentoo-2-fd76ea7b76dc49236c60842259e4720fe678ecbb.zip
Fix quoting issues. RDEPEND on virtual/daemontools (bug #353211). Whitespace.
(Portage version: 2.2.0_alpha19/cvs/Linux i686)
Diffstat (limited to 'net-mail/serialmail')
-rw-r--r--net-mail/serialmail/ChangeLog10
-rw-r--r--net-mail/serialmail/serialmail-0.75-r2.ebuild6
-rw-r--r--net-mail/serialmail/serialmail-0.75-r3.ebuild48
3 files changed, 59 insertions, 5 deletions
diff --git a/net-mail/serialmail/ChangeLog b/net-mail/serialmail/ChangeLog
index 62f566b4a88a..210558698928 100644
--- a/net-mail/serialmail/ChangeLog
+++ b/net-mail/serialmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/serialmail
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/serialmail/ChangeLog,v 1.19 2009/09/23 19:13:10 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/serialmail/ChangeLog,v 1.20 2011/01/30 19:18:13 jer Exp $
+
+*serialmail-0.75-r3 (30 Jan 2011)
+
+ 30 Jan 2011; Jeroen Roovers <jer@gentoo.org> serialmail-0.75-r2.ebuild,
+ +serialmail-0.75-r3.ebuild:
+ Fix quoting issues. RDEPEND on virtual/daemontools (bug #353211). Whitespace.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> serialmail-0.75-r2.ebuild:
Remove virtual/libc
diff --git a/net-mail/serialmail/serialmail-0.75-r2.ebuild b/net-mail/serialmail/serialmail-0.75-r2.ebuild
index 79e178e7646a..1980ac759827 100644
--- a/net-mail/serialmail/serialmail-0.75-r2.ebuild
+++ b/net-mail/serialmail/serialmail-0.75-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/serialmail/serialmail-0.75-r2.ebuild,v 1.10 2009/09/23 19:13:10 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/serialmail/serialmail-0.75-r2.ebuild,v 1.11 2011/01/30 19:18:12 jer Exp $
inherit eutils
@@ -14,7 +14,7 @@ DEPEND="sys-apps/groff
RDEPEND="sys-apps/groff
>=sys-apps/ucspi-tcp-0.88
- >=sys-process/daemontools-0.76-r1"
+ virtual/daemontools"
SLOT="0"
LICENSE="as-is"
diff --git a/net-mail/serialmail/serialmail-0.75-r3.ebuild b/net-mail/serialmail/serialmail-0.75-r3.ebuild
new file mode 100644
index 000000000000..3908eb073bec
--- /dev/null
+++ b/net-mail/serialmail/serialmail-0.75-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/serialmail/serialmail-0.75-r3.ebuild,v 1.1 2011/01/30 19:18:12 jer Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="A serialmail is a collection of tools for passing mail across serial links."
+HOMEPAGE="http://cr.yp.to/serialmail.html"
+SRC_URI="http://cr.yp.to/software/${P}.tar.gz
+ mirror://gentoo/${P}-patch.tar.bz2"
+
+DEPEND="sys-apps/groff
+ >=sys-apps/ucspi-tcp-0.88"
+
+RDEPEND="sys-apps/groff
+ >=sys-apps/ucspi-tcp-0.88
+ virtual/daemontools"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="static"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-gentoo.patch
+ epatch "${WORKDIR}"/${P}-smtpauth.patch
+ epatch "${WORKDIR}"/${P}-smtpauth_comp.patch
+ sed -i "s:@CFLAGS@:${CFLAGS}:" conf-cc
+ use static && LDFLAGS="${LDFLAGS} -static"
+ sed -i "s:@LDFLAGS@:${LDFLAGS}:" conf-ld
+}
+
+src_compile() {
+ grep -v man hier.c | grep -v doc > hier.c.tmp ; mv hier.c.tmp hier.c
+ emake it man || die
+}
+
+src_install() {
+ dobin setlock serialsmtp serialqmtp maildirsmtp maildirserial maildirqmtp
+
+ dodoc AUTOTURN CHANGES FROMISP SYSDEPS THANKS TOISP \
+ BLURB FILES INSTALL README TARGETS TODO VERSION
+
+ doman maildirqmtp.1 maildirserial.1 maildirsmtp.1 \
+ serialqmtp.1 serialsmtp.1 setlock.1
+}