summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-01 19:25:15 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-01 19:25:15 +0000
commit9b60b3a78fc3462c7305ddd87bdbd1e7e08b50e1 (patch)
tree9c5e8b1bdf678998420a138b503fdcfd0dde9e27 /net-mail/evolution
parentfixed wrong url (diff)
downloadgentoo-2-9b60b3a78fc3462c7305ddd87bdbd1e7e08b50e1.tar.gz
gentoo-2-9b60b3a78fc3462c7305ddd87bdbd1e7e08b50e1.tar.bz2
gentoo-2-9b60b3a78fc3462c7305ddd87bdbd1e7e08b50e1.zip
new evolution ebuild
Diffstat (limited to 'net-mail/evolution')
-rw-r--r--net-mail/evolution/evolution-1.0.2.ebuild131
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.22
2 files changed, 133 insertions, 0 deletions
diff --git a/net-mail/evolution/evolution-1.0.2.ebuild b/net-mail/evolution/evolution-1.0.2.ebuild
new file mode 100644
index 000000000000..636404b6394f
--- /dev/null
+++ b/net-mail/evolution/evolution-1.0.2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Mikael Hallendal <hallski@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.2.ebuild,v 1.1 2002/02/01 19:25:14 drobbins Exp $
+
+DB3=db-3.1.17
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz
+ ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
+ http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+RDEPEND=">=gnome-extra/bonobo-conf-0.14
+ >=gnome-base/bonobo-1.0.18
+ >=gnome-extra/gal-0.19
+ >=gnome-base/gconf-1.0.7
+ >=gnome-extra/gtkhtml-1.0.1
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/libglade-0.17-r1
+ >=media-libs/gdk-pixbuf-0.14.0
+ >=dev-libs/libxml-1.8.16
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/gnome-print-0.34
+ >=app-text/scrollkeeper-0.2
+ ssl? ( >=net-www/mozilla-0.9.6-r3 )
+ ldap? ( >=net-nds/openldap-2.0 )
+ mozilla? ( >=net-www/mozilla-0.9.6-r3 )
+ pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.11
+ >=sys-devel/libtool-1.4.1-r1
+ sys-devel/gettext"
+
+src_compile() {
+
+ libtoolize --copy --force
+
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+ make || die # make -j 4 doesn't work, use make
+ make prefix=${WORKDIR}/db3 install || die
+
+ cd ${S}
+
+ local myconf=""
+
+ MOZILLA=$MOZILLA_FIVE_HOME
+
+ if [ "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ if [ "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes"
+ fi
+
+ if [ "`use ssl`" ] ; then
+ myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nss-libs --without-nss-includes"
+ fi
+
+ # SSL needs NSPR libs ...
+ if [ "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-file-locking=no \
+ --with-db3=${WORKDIR}/db3 \
+ --disable-python-bindings \
+ ${myconf} || die
+
+ # emake might not work, so fall back to make
+ emake || make || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ # Don't use DESTDIR it violates sandbox // Hallski
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ KDE_APPLNK_DIR=${D}/usr/share/applnk \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
diff --git a/net-mail/evolution/files/digest-evolution-1.0.2 b/net-mail/evolution/files/digest-evolution-1.0.2
new file mode 100644
index 000000000000..98f0a4c7acfd
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.0.2
@@ -0,0 +1,2 @@
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1957888
+MD5 05ca33abfabeaa14b8fd61c682fddad3 evolution-1.0.2.tar.gz 12124160