summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-12-14 23:39:37 +0000
committerRoy Marples <uberlord@gentoo.org>2005-12-14 23:39:37 +0000
commit2809e9963d71830d0a8feecf93a0a38d4ca042f9 (patch)
tree034422b8f730726ecb7d0cbd3356410fb630c551 /net-mail/dovecot
parent nopop3d USE flag changed to pop3d - I hate double negatives (diff)
downloadgentoo-2-2809e9963d71830d0a8feecf93a0a38d4ca042f9.tar.gz
gentoo-2-2809e9963d71830d0a8feecf93a0a38d4ca042f9.tar.bz2
gentoo-2-2809e9963d71830d0a8feecf93a0a38d4ca042f9.zip
punted old versions
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-mail/dovecot')
-rw-r--r--net-mail/dovecot/dovecot-0.99.11-r1.ebuild159
-rw-r--r--net-mail/dovecot/dovecot-0.99.13.ebuild159
-rw-r--r--net-mail/dovecot/dovecot-0.99.14.ebuild159
-rw-r--r--net-mail/dovecot/dovecot-1.0_alpha2.ebuild166
-rw-r--r--net-mail/dovecot/dovecot-1.0_alpha3.ebuild166
-rw-r--r--net-mail/dovecot/files/digest-dovecot-0.99.11-r11
-rw-r--r--net-mail/dovecot/files/digest-dovecot-0.99.131
-rw-r--r--net-mail/dovecot/files/digest-dovecot-0.99.141
-rw-r--r--net-mail/dovecot/files/digest-dovecot-1.0_alpha21
-rw-r--r--net-mail/dovecot/files/digest-dovecot-1.0_alpha31
-rw-r--r--net-mail/dovecot/files/dovecot.pam5
11 files changed, 0 insertions, 819 deletions
diff --git a/net-mail/dovecot/dovecot-0.99.11-r1.ebuild b/net-mail/dovecot/dovecot-0.99.11-r1.ebuild
deleted file mode 100644
index 9ee175448861..000000000000
--- a/net-mail/dovecot/dovecot-0.99.11-r1.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-0.99.11-r1.ebuild,v 1.4 2005/08/23 13:41:49 ticho Exp $
-
-IUSE="debug ipv6 ldap mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
-inherit eutils
-
-DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
-HOMEPAGE="http://dovecot.org/"
-SRC_URI="http://dovecot.org/releases/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 ~amd64 ~sparc ~ppc"
-
-#PROVIDE="virtual/imapd"
-
-# Note: current dovecot will break on gnutls
-# http://www.dovecot.org/list/dovecot/2004-November/005169.html
-DEPEND=">=sys-libs/db-3.2
- >=sys-apps/sed-4
- ldap? ( >=net-nds/openldap-1.2 )
- pam? ( sys-libs/pam )
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
- ssl? ( >=dev-libs/openssl-0.9.6g )
- postgres? ( dev-db/postgresql )
- mysql? ( dev-db/mysql )
- vpopmail? ( net-mail/vpopmail )"
- #gnutls? ( <=net-libs/gnutls-1.0.4 )
-
-RDEPEND="${DEPEND}
- net-mail/mailbase"
-
-
-pkg_setup() {
- # Add user and group for login process (same as for fedora/redhat)
- enewgroup dovecot 97
- enewuser dovecot 97 -1 /dev/null dovecot
-}
-
-src_compile() {
- local myconf
- use debug && myconf="--enable-debug"
- use ldap && myconf="${myconf} --with-ldap"
- use ipv6 || myconf="${myconf} --disable-ipv6"
- use nopop3d && myconf="${myconf} --without-pop3d"
- use pam || myconf="${myconf} --without-pam"
- use postgres && myconf="${myconf} --with-pgsql"
- use mysql && myconf="${myconf} --with-mysql"
- use sasl && myconf="${myconf} --with-cyrus-sasl2"
- # gnutls support no longer working
- # (http://www.dovecot.org/list/dovecot/2004-November/005169.html)
- use ssl && myconf="${myconf} --with-ssl=openssl"
- if use gnutls; then
- eerror 'GNUTLS support no longer available, see'
- eerror 'http://www.dovecot.org/list/dovecot/2004-November/005169.html'
- eerror
- eerror 'Please set USE="-gnutls ssl" if you want TLS support.'
- die
- fi
- # prefer gnutls to ssl if both gnutls and ssl are defined
- #use gnutls && myconf="${myconf} --with-ssl=gnutls"
- #use ssl && ! use gnutls && myconf="${myconf} --with-ssl=openssl"
- #! use gnutls && ! use ssl && myconf="${myconf} --without-ssl"
- use vpopmail || myconf="${myconf} --without-vpopmail"
-
- ./configure \
- --prefix=/usr \
- --host=${CHOST} \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var \
- ${myconf} || die "configure failed"
- emake || die
-}
-
-src_install () {
- # Create the dovecot.conf file from the dovecot-example.conf file that
- # the dovecot folks nicely left for us, changing the default
- # mail spool locations to the Gentoo defaults.
- if use mbox
- then
- # /var/spool/mail/$USER mail spool
- # The location of the INDEX may be overridden by the user if desired.
- if [ -z ${DOVECOT_INDEX_PATH} ]
- then
- DOVECOT_INDEX_PATH="/var/dovecot/%d/%n"
- dodir /var/dovecot
- fi
- sed -e \
- "s|#default_mail_env =|#default_mail_env = mbox:/var/spool/mail/%u:INDEX=${DOVECOT_INDEX_PATH}|" \
- dovecot-example.conf > dovecot.conf
- else
- # $HOME/.maildir mail spool.
- sed -e \
- 's|#default_mail_env =|default_mail_env = maildir:%h/.maildir|' \
- dovecot-example.conf > dovecot.conf
- fi
- insinto /etc
- doins dovecot.conf
-
- make DESTDIR=${D} install || die
- rm ${D}/etc/dovecot-example.conf
-
- # Documentation
- rm -fr ${D}/usr/share/doc/dovecot
- cd ${S}
- dodoc AUTHORS COPYING* NEWS README TODO dovecot-example.conf
- dodoc doc/*.txt doc/*.conf doc/*.cnf
-
- # per default dovecot wants it ssl cert called dovecot.pem
- # fix this in mkcert.sh, which we use to generate the ssl certs
- cd ${S}/doc
- sed -i -e 's/imapd.pem/dovecot.pem/g' mkcert.sh
- dodoc mkcert.sh
-
- # rc script
- exeinto /etc/init.d
- newexe ${FILESDIR}/dovecot.init dovecot
-
- # PAM
- if use pam
- then
- dodir /etc/pam.d
- insinto /etc/pam.d
- newins ${FILESDIR}/dovecot.pam dovecot
- fi
-
- # Create SSL certificates
- if use ssl || use gnutls
- then
- cd ${S}/doc
- dodir /etc/ssl/certs
- dodir /etc/ssl/private
- # Let's not make a new certificate if we already have one
- [ -e /etc/ssl/certs/dovecot.pem -a -e /etc/ssl/private/dovecot.pem ] \
- || SSLDIR=${D}/etc/ssl sh mkcert.sh
- fi
-
- dodir /var/run/dovecot
- fowners root:root /var/run/dovecot
- fperms 0700 /var/run/dovecot
- keepdir /var/run/dovecot/login
- fowners root:dovecot /var/run/dovecot/login
- fperms 0750 /var/run/dovecot/login
- fperms 0600 /etc/dovecot.conf
-}
-
-pkg_postinst() {
- if use pam
- then
- ewarn "If you are upgrading from Dovecot prior to 0.99.10, be aware"
- ewarn "that the PAM profile was changed from 'imap' to 'dovecot'."
- einfo "Please review /etc/pam.d/dovecot."
- fi
- einfo "Please review /etc/dovecot.conf, particularly auth_userdb and auth_passdb."
-}
diff --git a/net-mail/dovecot/dovecot-0.99.13.ebuild b/net-mail/dovecot/dovecot-0.99.13.ebuild
deleted file mode 100644
index af1331a2ba3f..000000000000
--- a/net-mail/dovecot/dovecot-0.99.13.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-0.99.13.ebuild,v 1.4 2005/08/23 13:41:49 ticho Exp $
-
-IUSE="debug ipv6 ldap mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
-inherit eutils
-
-DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
-HOMEPAGE="http://dovecot.org/"
-SRC_URI="http://dovecot.org/releases/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="x86 ~amd64 ~sparc ~ppc"
-
-#PROVIDE="virtual/imapd"
-
-# Note: current dovecot will break on gnutls
-# http://www.dovecot.org/list/dovecot/2004-November/005169.html
-DEPEND=">=sys-libs/db-3.2
- >=sys-apps/sed-4
- ldap? ( >=net-nds/openldap-1.2 )
- pam? ( sys-libs/pam )
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
- ssl? ( >=dev-libs/openssl-0.9.6g )
- postgres? ( dev-db/postgresql )
- mysql? ( dev-db/mysql )
- vpopmail? ( net-mail/vpopmail )"
- #gnutls? ( <=net-libs/gnutls-1.0.4 )
-
-RDEPEND="${DEPEND}
- net-mail/mailbase"
-
-
-pkg_setup() {
- # Add user and group for login process (same as for fedora/redhat)
- enewgroup dovecot 97
- enewuser dovecot 97 -1 /dev/null dovecot
-}
-
-src_compile() {
- local myconf
- use debug && myconf="--enable-debug"
- use ldap && myconf="${myconf} --with-ldap"
- use ipv6 || myconf="${myconf} --disable-ipv6"
- use nopop3d && myconf="${myconf} --without-pop3d"
- use pam || myconf="${myconf} --without-pam"
- use postgres && myconf="${myconf} --with-pgsql"
- use mysql && myconf="${myconf} --with-mysql"
- use sasl && myconf="${myconf} --with-cyrus-sasl2"
- # gnutls support no longer working
- # (http://www.dovecot.org/list/dovecot/2004-November/005169.html)
- use ssl && myconf="${myconf} --with-ssl=openssl"
- if use gnutls; then
- eerror 'GNUTLS support no longer available, see'
- eerror 'http://www.dovecot.org/list/dovecot/2004-November/005169.html'
- eerror
- eerror 'Please set USE="-gnutls ssl" if you want TLS support.'
- die
- fi
- # prefer gnutls to ssl if both gnutls and ssl are defined
- #use gnutls && myconf="${myconf} --with-ssl=gnutls"
- #use ssl && ! use gnutls && myconf="${myconf} --with-ssl=openssl"
- #! use gnutls && ! use ssl && myconf="${myconf} --without-ssl"
- use vpopmail || myconf="${myconf} --without-vpopmail"
-
- ./configure \
- --prefix=/usr \
- --host=${CHOST} \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var \
- ${myconf} || die "configure failed"
- emake || die
-}
-
-src_install () {
- # Create the dovecot.conf file from the dovecot-example.conf file that
- # the dovecot folks nicely left for us, changing the default
- # mail spool locations to the Gentoo defaults.
- if use mbox
- then
- # /var/spool/mail/$USER mail spool
- # The location of the INDEX may be overridden by the user if desired.
- if [ -z ${DOVECOT_INDEX_PATH} ]
- then
- DOVECOT_INDEX_PATH="/var/dovecot/%d/%n"
- dodir /var/dovecot
- fi
- sed -e \
- "s|#default_mail_env =|#default_mail_env = mbox:/var/spool/mail/%u:INDEX=${DOVECOT_INDEX_PATH}|" \
- dovecot-example.conf > dovecot.conf
- else
- # $HOME/.maildir mail spool.
- sed -e \
- 's|#default_mail_env =|default_mail_env = maildir:%h/.maildir|' \
- dovecot-example.conf > dovecot.conf
- fi
- insinto /etc
- doins dovecot.conf
-
- make DESTDIR=${D} install || die
- rm ${D}/etc/dovecot-example.conf
-
- # Documentation
- rm -fr ${D}/usr/share/doc/dovecot
- cd ${S}
- dodoc AUTHORS COPYING* NEWS README TODO dovecot-example.conf
- dodoc doc/*.txt doc/*.conf doc/*.cnf
-
- # per default dovecot wants it ssl cert called dovecot.pem
- # fix this in mkcert.sh, which we use to generate the ssl certs
- cd ${S}/doc
- sed -i -e 's/imapd.pem/dovecot.pem/g' mkcert.sh
- dodoc mkcert.sh
-
- # rc script
- exeinto /etc/init.d
- newexe ${FILESDIR}/dovecot.init dovecot
-
- # PAM
- if use pam
- then
- dodir /etc/pam.d
- insinto /etc/pam.d
- newins ${FILESDIR}/dovecot.pam dovecot
- fi
-
- # Create SSL certificates
- if use ssl || use gnutls
- then
- cd ${S}/doc
- dodir /etc/ssl/certs
- dodir /etc/ssl/private
- # Let's not make a new certificate if we already have one
- [ -e /etc/ssl/certs/dovecot.pem -a -e /etc/ssl/private/dovecot.pem ] \
- || SSLDIR=${D}/etc/ssl sh mkcert.sh
- fi
-
- dodir /var/run/dovecot
- fowners root:root /var/run/dovecot
- fperms 0700 /var/run/dovecot
- keepdir /var/run/dovecot/login
- fowners root:dovecot /var/run/dovecot/login
- fperms 0750 /var/run/dovecot/login
- fperms 0600 /etc/dovecot.conf
-}
-
-pkg_postinst() {
- if use pam
- then
- ewarn "If you are upgrading from Dovecot prior to 0.99.10, be aware"
- ewarn "that the PAM profile was changed from 'imap' to 'dovecot'."
- einfo "Please review /etc/pam.d/dovecot."
- fi
- einfo "Please review /etc/dovecot.conf, particularly auth_userdb and auth_passdb."
-}
diff --git a/net-mail/dovecot/dovecot-0.99.14.ebuild b/net-mail/dovecot/dovecot-0.99.14.ebuild
deleted file mode 100644
index c9f970fecf86..000000000000
--- a/net-mail/dovecot/dovecot-0.99.14.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-0.99.14.ebuild,v 1.3 2005/08/23 13:41:49 ticho Exp $
-
-IUSE="debug ipv6 ldap mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
-inherit eutils
-
-DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
-HOMEPAGE="http://dovecot.org/"
-SRC_URI="http://dovecot.org/releases/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
-
-#PROVIDE="virtual/imapd"
-
-# Note: current dovecot will break on gnutls
-# http://www.dovecot.org/list/dovecot/2004-November/005169.html
-DEPEND=">=sys-libs/db-3.2
- >=sys-apps/sed-4
- ldap? ( >=net-nds/openldap-1.2 )
- pam? ( sys-libs/pam )
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
- ssl? ( >=dev-libs/openssl-0.9.6g )
- postgres? ( dev-db/postgresql )
- mysql? ( dev-db/mysql )
- vpopmail? ( net-mail/vpopmail )"
- #gnutls? ( <=net-libs/gnutls-1.0.4 )
-
-RDEPEND="${DEPEND}
- net-mail/mailbase"
-
-
-pkg_setup() {
- # Add user and group for login process (same as for fedora/redhat)
- enewgroup dovecot 97
- enewuser dovecot 97 -1 /dev/null dovecot
-}
-
-src_compile() {
- local myconf
- use debug && myconf="--enable-debug"
- use ldap && myconf="${myconf} --with-ldap"
- use ipv6 || myconf="${myconf} --disable-ipv6"
- use nopop3d && myconf="${myconf} --without-pop3d"
- use pam || myconf="${myconf} --without-pam"
- use postgres && myconf="${myconf} --with-pgsql"
- use mysql && myconf="${myconf} --with-mysql"
- use sasl && myconf="${myconf} --with-cyrus-sasl2"
- # gnutls support no longer working
- # (http://www.dovecot.org/list/dovecot/2004-November/005169.html)
- use ssl && myconf="${myconf} --with-ssl=openssl"
- if use gnutls; then
- eerror 'GNUTLS support no longer available, see'
- eerror 'http://www.dovecot.org/list/dovecot/2004-November/005169.html'
- eerror
- eerror 'Please set USE="-gnutls ssl" if you want TLS support.'
- die
- fi
- # prefer gnutls to ssl if both gnutls and ssl are defined
- #use gnutls && myconf="${myconf} --with-ssl=gnutls"
- #use ssl && ! use gnutls && myconf="${myconf} --with-ssl=openssl"
- #! use gnutls && ! use ssl && myconf="${myconf} --without-ssl"
- use vpopmail || myconf="${myconf} --without-vpopmail"
-
- ./configure \
- --prefix=/usr \
- --host=${CHOST} \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var \
- ${myconf} || die "configure failed"
- emake || die
-}
-
-src_install () {
- # Create the dovecot.conf file from the dovecot-example.conf file that
- # the dovecot folks nicely left for us, changing the default
- # mail spool locations to the Gentoo defaults.
- if use mbox
- then
- # /var/spool/mail/$USER mail spool
- # The location of the INDEX may be overridden by the user if desired.
- if [ -z ${DOVECOT_INDEX_PATH} ]
- then
- DOVECOT_INDEX_PATH="/var/dovecot/%d/%n"
- dodir /var/dovecot
- fi
- sed -e \
- "s|#default_mail_env =|#default_mail_env = mbox:/var/spool/mail/%u:INDEX=${DOVECOT_INDEX_PATH}|" \
- dovecot-example.conf > dovecot.conf
- else
- # $HOME/.maildir mail spool.
- sed -e \
- 's|#default_mail_env =|default_mail_env = maildir:%h/.maildir|' \
- dovecot-example.conf > dovecot.conf
- fi
- insinto /etc
- doins dovecot.conf
-
- make DESTDIR=${D} install || die
- rm ${D}/etc/dovecot-example.conf
-
- # Documentation
- rm -fr ${D}/usr/share/doc/dovecot
- cd ${S}
- dodoc AUTHORS COPYING* NEWS README TODO dovecot-example.conf
- dodoc doc/*.txt doc/*.conf doc/*.cnf
-
- # per default dovecot wants it ssl cert called dovecot.pem
- # fix this in mkcert.sh, which we use to generate the ssl certs
- cd ${S}/doc
- sed -i -e 's/imapd.pem/dovecot.pem/g' mkcert.sh
- dodoc mkcert.sh
-
- # rc script
- exeinto /etc/init.d
- newexe ${FILESDIR}/dovecot.init dovecot
-
- # PAM
- if use pam
- then
- dodir /etc/pam.d
- insinto /etc/pam.d
- newins ${FILESDIR}/dovecot.pam dovecot
- fi
-
- # Create SSL certificates
- if use ssl || use gnutls
- then
- cd ${S}/doc
- dodir /etc/ssl/certs
- dodir /etc/ssl/private
- # Let's not make a new certificate if we already have one
- [ -e /etc/ssl/certs/dovecot.pem -a -e /etc/ssl/private/dovecot.pem ] \
- || SSLDIR=${D}/etc/ssl sh mkcert.sh
- fi
-
- dodir /var/run/dovecot
- fowners root:root /var/run/dovecot
- fperms 0700 /var/run/dovecot
- keepdir /var/run/dovecot/login
- fowners root:dovecot /var/run/dovecot/login
- fperms 0750 /var/run/dovecot/login
- fperms 0600 /etc/dovecot.conf
-}
-
-pkg_postinst() {
- if use pam
- then
- ewarn "If you are upgrading from Dovecot prior to 0.99.10, be aware"
- ewarn "that the PAM profile was changed from 'imap' to 'dovecot'."
- einfo "Please review /etc/pam.d/dovecot."
- fi
- einfo "Please review /etc/dovecot.conf, particularly auth_userdb and auth_passdb."
-}
diff --git a/net-mail/dovecot/dovecot-1.0_alpha2.ebuild b/net-mail/dovecot/dovecot-1.0_alpha2.ebuild
deleted file mode 100644
index afeefd7e6e6e..000000000000
--- a/net-mail/dovecot/dovecot-1.0_alpha2.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_alpha2.ebuild,v 1.2 2005/09/13 21:42:06 wschlich Exp $
-
-IUSE="debug ipv6 ldap maildir mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
-inherit eutils
-
-DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
-HOMEPAGE="http://dovecot.org/"
-MY_P="${P/_/.}"
-S="${WORKDIR}/${MY_P}"
-SRC_URI="http://dovecot.org/releases/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-
-#PROVIDE="virtual/imapd"
-
-# Note: current dovecot will break on gnutls
-# http://www.dovecot.org/list/dovecot/2004-November/005169.html
-DEPEND=">=sys-libs/db-3.2
- >=sys-apps/sed-4
- ldap? ( >=net-nds/openldap-1.2 )
- pam? ( sys-libs/pam )
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
- ssl? ( >=dev-libs/openssl-0.9.6g )
- postgres? ( dev-db/postgresql )
- mysql? ( dev-db/mysql )
- vpopmail? ( net-mail/vpopmail )"
- #gnutls? ( <=net-libs/gnutls-1.0.4 )
-
-RDEPEND="${DEPEND}
- >=net-mail/mailbase-0.00-r8"
-
-pkg_setup() {
- # Add user and group for login process (same as for fedora/redhat)
- enewgroup dovecot 97
- enewuser dovecot 97 -1 /dev/null dovecot
-}
-
-src_compile() {
- local myconf=''
- useq debug && myconf="${myconf} --enable-debug"
- useq ldap && myconf="${myconf} --with-ldap"
- useq ipv6 || myconf="${myconf} --disable-ipv6"
- useq nopop3d && myconf="${myconf} --without-pop3d"
- useq pam || myconf="${myconf} --without-pam"
- useq postgres && myconf="${myconf} --with-pgsql"
- useq mysql && myconf="${myconf} --with-mysql"
- useq sasl && myconf="${myconf} --with-cyrus-sasl2"
- # gnutls support no longer working
- # (http://www.dovecot.org/list/dovecot/2004-November/005169.html)
- useq ssl && myconf="${myconf} --with-ssl=openssl"
- if useq gnutls; then
- eerror
- eerror 'GNUTLS support no longer available, see'
- eerror 'http://www.dovecot.org/list/dovecot/2004-November/005169.html'
- eerror
- eerror 'Please set USE="-gnutls ssl" if you want SSL support.'
- eerror
- die
- fi
- # prefer gnutls to ssl if both gnutls and ssl are defined
- #use gnutls && myconf="${myconf} --with-ssl=gnutls"
- #use ssl && ! use gnutls && myconf="${myconf} --with-ssl=openssl"
- #! use gnutls && ! use ssl && myconf="${myconf} --without-ssl"
- useq vpopmail || myconf="${myconf} --without-vpopmail"
-
- ./configure \
- --prefix=/usr \
- --host=${CHOST} \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var \
- ${myconf} || die "configure failed"
- emake || die "make failed"
-}
-
-src_install () {
- einstall || die "make install failed"
-
- # rc script
- exeinto /etc/init.d
- newexe ${FILESDIR}/dovecot.init dovecot
-
- # Create the dovecot.conf file from the dovecot-example.conf file that
- # the dovecot folks nicely left for us....
- mv ${D}/etc/dovecot-example.conf ${D}/etc/dovecot.conf
-
- # ...changing the default mail spool locations to the Gentoo defaults.
- if useq mbox; then
- if useq maildir; then
- ewarn "Both mbox and maildir USE flags set, using mbox"
- fi
- # /var/spool/mail/$USER mail spool
- # The location of the INDEX may be overridden by the user if desired.
- if [ -z ${DOVECOT_INDEX_PATH} ]; then
- DOVECOT_INDEX_PATH='/var/dovecot/%u'
- dodir /var/dovecot
- fi
- sed -i -e \
- "s|#default_mail_env =|default_mail_env = mbox:/var/spool/mail/%u:INDEX=${DOVECOT_INDEX_PATH}|" \
- ${D}/etc/dovecot.conf
- # enable dovecot to create dotlocks in /var/spool/mail
- sed -i -e \
- 's|#mail_extra_groups =|mail_extra_groups = mail|' \
- ${D}/etc/dovecot.conf
- elif useq maildir; then
- # $HOME/.maildir mail spool.
- sed -i -e \
- 's|#default_mail_env =|default_mail_env = maildir:%h/.maildir|' \
- ${D}/etc/dovecot.conf
- else
- einfo "Both mbox and maildir USE flags unset, not modifying"
- einfo "default_mail_env in /etc/dovecot.conf"
- fi
-
- # PAM
- # We're using pam files (imap and pop3) provided by mailbase-0.00-r8
- if useq pam; then
- sed -i -e '/passdb pam {/,+10s:#args = .*:args = \*:' ${D}/etc/dovecot.conf
- fi
-
- # Documentation
- rm -rf ${D}/usr/share/doc/dovecot
- dodoc AUTHORS COPYING* NEWS README TODO dovecot-example.conf
- dodoc doc/*.txt doc/*.conf doc/*.cnf doc/mkcert.sh
-
- # Create SSL certificates
- if useq ssl || useq gnutls; then
- dodir /etc/ssl/certs
- dodir /etc/ssl/private
- # Let's not make a new certificate if we already have one
- if ! [[ -e /etc/ssl/certs/dovecot.pem && \
- -e /etc/ssl/private/dovecot.pem ]]; then
- einfo "Generating X.509 certificate for SSL"
- pushd doc >/dev/null && \
- SSLDIR=${D}/etc/ssl sh mkcert.sh && \
- popd >/dev/null
- fi
- fi
-
- dodir /var/run/dovecot
- fowners root:root /var/run/dovecot
- fperms 0700 /var/run/dovecot
- keepdir /var/run/dovecot/login
- fowners root:dovecot /var/run/dovecot/login
- fperms 0750 /var/run/dovecot/login
- fperms 0600 /etc/dovecot.conf
-}
-
-pkg_postinst() {
- if useq pam; then
- ewarn "If you are upgrading from Dovecot prior to 0.99.14-r1. be aware that the PAM"
- ewarn "profile usage was changed. Dovecot's services now use distinctive profiles,"
- ewarn "i.e. IMAP uses profile 'imap', POP3S uses profile 'pop3s', etc..."
- echo
- einfo "The above applies for default configuration (\"auth_passdb = pam *\")."
- einfo "These PAM profiles are provided by net-mail/mailbase ebuild."
- echo
- fi
- einfo "Please review /etc/dovecot.conf, particularly auth_userdb and auth_passdb."
-}
diff --git a/net-mail/dovecot/dovecot-1.0_alpha3.ebuild b/net-mail/dovecot/dovecot-1.0_alpha3.ebuild
deleted file mode 100644
index 559b769f5e29..000000000000
--- a/net-mail/dovecot/dovecot-1.0_alpha3.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0_alpha3.ebuild,v 1.1 2005/09/23 23:34:59 wschlich Exp $
-
-IUSE="debug ipv6 ldap maildir mbox pam postgres sasl ssl gnutls vpopmail nopop3d mysql"
-inherit eutils
-
-DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
-HOMEPAGE="http://dovecot.org/"
-MY_P="${P/_/.}"
-S="${WORKDIR}/${MY_P}"
-SRC_URI="http://dovecot.org/releases/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-
-#PROVIDE="virtual/imapd"
-
-# Note: current dovecot will break on gnutls
-# http://www.dovecot.org/list/dovecot/2004-November/005169.html
-DEPEND=">=sys-libs/db-3.2
- >=sys-apps/sed-4
- ldap? ( >=net-nds/openldap-1.2 )
- pam? ( sys-libs/pam )
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
- ssl? ( >=dev-libs/openssl-0.9.6g )
- postgres? ( dev-db/postgresql )
- mysql? ( dev-db/mysql )
- vpopmail? ( net-mail/vpopmail )"
- #gnutls? ( <=net-libs/gnutls-1.0.4 )
-
-RDEPEND="${DEPEND}
- >=net-mail/mailbase-0.00-r8"
-
-pkg_setup() {
- # Add user and group for login process (same as for fedora/redhat)
- enewgroup dovecot 97
- enewuser dovecot 97 -1 /dev/null dovecot
-}
-
-src_compile() {
- local myconf=''
- useq debug && myconf="${myconf} --enable-debug"
- useq ldap && myconf="${myconf} --with-ldap"
- useq ipv6 || myconf="${myconf} --disable-ipv6"
- useq nopop3d && myconf="${myconf} --without-pop3d"
- useq pam || myconf="${myconf} --without-pam"
- useq postgres && myconf="${myconf} --with-pgsql"
- useq mysql && myconf="${myconf} --with-mysql"
- useq sasl && myconf="${myconf} --with-cyrus-sasl2"
- # gnutls support no longer working
- # (http://www.dovecot.org/list/dovecot/2004-November/005169.html)
- useq ssl && myconf="${myconf} --with-ssl=openssl"
- if useq gnutls; then
- eerror
- eerror 'GNUTLS support no longer available, see'
- eerror 'http://www.dovecot.org/list/dovecot/2004-November/005169.html'
- eerror
- eerror 'Please set USE="-gnutls ssl" if you want SSL support.'
- eerror
- die
- fi
- # prefer gnutls to ssl if both gnutls and ssl are defined
- #use gnutls && myconf="${myconf} --with-ssl=gnutls"
- #use ssl && ! use gnutls && myconf="${myconf} --with-ssl=openssl"
- #! use gnutls && ! use ssl && myconf="${myconf} --without-ssl"
- useq vpopmail || myconf="${myconf} --without-vpopmail"
-
- ./configure \
- --prefix=/usr \
- --host=${CHOST} \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --localstatedir=/var \
- ${myconf} || die "configure failed"
- emake || die "make failed"
-}
-
-src_install () {
- einstall || die "make install failed"
-
- # rc script
- exeinto /etc/init.d
- newexe ${FILESDIR}/dovecot.init dovecot
-
- # Create the dovecot.conf file from the dovecot-example.conf file that
- # the dovecot folks nicely left for us....
- mv ${D}/etc/dovecot-example.conf ${D}/etc/dovecot.conf
-
- # ...changing the default mail spool locations to the Gentoo defaults.
- if useq mbox; then
- if useq maildir; then
- ewarn "Both mbox and maildir USE flags set, using mbox"
- fi
- # /var/spool/mail/$USER mail spool
- # The location of the INDEX may be overridden by the user if desired.
- if [ -z ${DOVECOT_INDEX_PATH} ]; then
- DOVECOT_INDEX_PATH='/var/dovecot/%u'
- dodir /var/dovecot
- fi
- sed -i -e \
- "s|#default_mail_env =|default_mail_env = mbox:/var/spool/mail/%u:INDEX=${DOVECOT_INDEX_PATH}|" \
- ${D}/etc/dovecot.conf
- # enable dovecot to create dotlocks in /var/spool/mail
- sed -i -e \
- 's|#mail_extra_groups =|mail_extra_groups = mail|' \
- ${D}/etc/dovecot.conf
- elif useq maildir; then
- # $HOME/.maildir mail spool.
- sed -i -e \
- 's|#default_mail_env =|default_mail_env = maildir:%h/.maildir|' \
- ${D}/etc/dovecot.conf
- else
- einfo "Both mbox and maildir USE flags unset, not modifying"
- einfo "default_mail_env in /etc/dovecot.conf"
- fi
-
- # PAM
- # We're using pam files (imap and pop3) provided by mailbase-0.00-r8
- if useq pam; then
- sed -i -e '/passdb pam {/,+10s:#args = .*:args = \*:' ${D}/etc/dovecot.conf
- fi
-
- # Documentation
- rm -rf ${D}/usr/share/doc/dovecot
- dodoc AUTHORS COPYING* NEWS README TODO dovecot-example.conf
- dodoc doc/*.txt doc/*.conf doc/*.cnf doc/mkcert.sh
-
- # Create SSL certificates
- if useq ssl || useq gnutls; then
- dodir /etc/ssl/certs
- dodir /etc/ssl/private
- # Let's not make a new certificate if we already have one
- if ! [[ -e /etc/ssl/certs/dovecot.pem && \
- -e /etc/ssl/private/dovecot.pem ]]; then
- einfo "Generating X.509 certificate for SSL"
- pushd doc >/dev/null && \
- SSLDIR=${D}/etc/ssl sh mkcert.sh && \
- popd >/dev/null
- fi
- fi
-
- dodir /var/run/dovecot
- fowners root:root /var/run/dovecot
- fperms 0700 /var/run/dovecot
- keepdir /var/run/dovecot/login
- fowners root:dovecot /var/run/dovecot/login
- fperms 0750 /var/run/dovecot/login
- fperms 0600 /etc/dovecot.conf
-}
-
-pkg_postinst() {
- if useq pam; then
- ewarn "If you are upgrading from Dovecot prior to 0.99.14-r1. be aware that the PAM"
- ewarn "profile usage was changed. Dovecot's services now use distinctive profiles,"
- ewarn "i.e. IMAP uses profile 'imap', POP3S uses profile 'pop3s', etc..."
- echo
- einfo "The above applies for default configuration (\"auth_passdb = pam *\")."
- einfo "These PAM profiles are provided by net-mail/mailbase ebuild."
- echo
- fi
- einfo "Please review /etc/dovecot.conf, particularly auth_userdb and auth_passdb."
-}
diff --git a/net-mail/dovecot/files/digest-dovecot-0.99.11-r1 b/net-mail/dovecot/files/digest-dovecot-0.99.11-r1
deleted file mode 100644
index 7bf4daa05663..000000000000
--- a/net-mail/dovecot/files/digest-dovecot-0.99.11-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 05090ad784540b96c84f32080ada9f97 dovecot-0.99.11.tar.gz 863370
diff --git a/net-mail/dovecot/files/digest-dovecot-0.99.13 b/net-mail/dovecot/files/digest-dovecot-0.99.13
deleted file mode 100644
index 48d96371854e..000000000000
--- a/net-mail/dovecot/files/digest-dovecot-0.99.13
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a84896c4236232b843972370e3730729 dovecot-0.99.13.tar.gz 867787
diff --git a/net-mail/dovecot/files/digest-dovecot-0.99.14 b/net-mail/dovecot/files/digest-dovecot-0.99.14
deleted file mode 100644
index 780363b9c5d1..000000000000
--- a/net-mail/dovecot/files/digest-dovecot-0.99.14
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a12e26fd378a46c31ec3a81ab7b55b5b dovecot-0.99.14.tar.gz 871285
diff --git a/net-mail/dovecot/files/digest-dovecot-1.0_alpha2 b/net-mail/dovecot/files/digest-dovecot-1.0_alpha2
deleted file mode 100644
index 063a5629ae65..000000000000
--- a/net-mail/dovecot/files/digest-dovecot-1.0_alpha2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ea33ac1bf13a8252d880082ef6811081 dovecot-1.0.alpha2.tar.gz 1190702
diff --git a/net-mail/dovecot/files/digest-dovecot-1.0_alpha3 b/net-mail/dovecot/files/digest-dovecot-1.0_alpha3
deleted file mode 100644
index 44d1ab9c8bf8..000000000000
--- a/net-mail/dovecot/files/digest-dovecot-1.0_alpha3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2006624ce4328dcdef6a71376c3be05d dovecot-1.0.alpha3.tar.gz 1193017
diff --git a/net-mail/dovecot/files/dovecot.pam b/net-mail/dovecot/files/dovecot.pam
deleted file mode 100644
index 20dff0203ace..000000000000
--- a/net-mail/dovecot/files/dovecot.pam
+++ /dev/null
@@ -1,5 +0,0 @@
-#%PAM-1.0
-auth required pam_nologin.so
-auth required pam_stack.so service=system-auth
-account required pam_stack.so service=system-auth
-session required pam_stack.so service=system-auth