summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-08 02:28:59 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-08 02:28:59 +0000
commitdd42728af8c624732cdb6ac2a89192087ca9450f (patch)
tree76db2aec0457f5735320ea336b54472ad81a9b8d /net-libs
parentVersion Bump. Closes bug #149831. (diff)
downloadgentoo-2-dd42728af8c624732cdb6ac2a89192087ca9450f.tar.gz
gentoo-2-dd42728af8c624732cdb6ac2a89192087ca9450f.tar.bz2
gentoo-2-dd42728af8c624732cdb6ac2a89192087ca9450f.zip
Fix the as-needed patch again #150198 and move patches into a tarball on the mirrors.
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libwww/ChangeLog10
-rw-r--r--net-libs/libwww/files/digest-libwww-5.4.0-r76
-rw-r--r--net-libs/libwww/libwww-5.4.0-r7.ebuild63
3 files changed, 77 insertions, 2 deletions
diff --git a/net-libs/libwww/ChangeLog b/net-libs/libwww/ChangeLog
index 67403f1e8953..a71b2979dfd1 100644
--- a/net-libs/libwww/ChangeLog
+++ b/net-libs/libwww/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libwww
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.65 2006/10/05 17:30:15 grobian Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/ChangeLog,v 1.66 2006/10/08 02:28:59 vapier Exp $
+
+*libwww-5.4.0-r7 (08 Oct 2006)
+
+ 08 Oct 2006; Mike Frysinger <vapier@gentoo.org> +libwww-5.4.0-r7.ebuild:
+ Fix the as-needed patch again #150198 and move patches into a tarball on the
+ mirrors.
05 Oct 2006; Fabian Groffen <grobian@gentoo.org>
-files/libwww-5.4.0-automake-macos.patch, libwww-5.4.0-r3.ebuild,
diff --git a/net-libs/libwww/files/digest-libwww-5.4.0-r7 b/net-libs/libwww/files/digest-libwww-5.4.0-r7
new file mode 100644
index 000000000000..b875415203a8
--- /dev/null
+++ b/net-libs/libwww/files/digest-libwww-5.4.0-r7
@@ -0,0 +1,6 @@
+MD5 d26487ce0d745234a1a56976c103f7f2 libwww-5.4.0-patches-1.0.tar.bz2 15243
+RMD160 192f94f2ac697ccf7f6d4bf611798432d8a8aaa5 libwww-5.4.0-patches-1.0.tar.bz2 15243
+SHA256 d06ff10870beaa26d20bfd46cbb34b4b2400526f5ebcafa70f1b095709f273f4 libwww-5.4.0-patches-1.0.tar.bz2 15243
+MD5 c3734ca6caa405707e134cc8c6d7e422 w3c-libwww-5.4.0.tgz 1129121
+RMD160 12e55ecb2435f9048d627e56f8ae60d4c246648b w3c-libwww-5.4.0.tgz 1129121
+SHA256 64841cd99a41c84679cfbc777ebfbb78bdc2a499f7f6866ccf5cead391c867ef w3c-libwww-5.4.0.tgz 1129121
diff --git a/net-libs/libwww/libwww-5.4.0-r7.ebuild b/net-libs/libwww/libwww-5.4.0-r7.ebuild
new file mode 100644
index 000000000000..06959523523b
--- /dev/null
+++ b/net-libs/libwww/libwww-5.4.0-r7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libwww/libwww-5.4.0-r7.ebuild,v 1.1 2006/10/08 02:28:59 vapier Exp $
+
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+inherit eutils multilib autotools
+
+PATCHVER="1.0"
+MY_P=w3c-${P}
+DESCRIPTION="A general-purpose client side WEB API"
+HOMEPAGE="http://www.w3.org/Library/"
+SRC_URI="http://www.w3.org/Library/Distribution/${MY_P}.tgz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.bz2"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql ssl"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !dev-libs/9libs
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f configure.in
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
+ eautoreconf || die "autoreconf failed"
+}
+
+src_compile() {
+ if use mysql ; then
+ myconf="--with-mysql=/usr/$(get_libdir)/mysql/libmysqlclient.a"
+ else
+ myconf="--without-mysql"
+ fi
+
+ export ac_cv_header_appkit_appkit_h=no
+ econf \
+ --enable-shared \
+ --enable-static \
+ --with-zlib \
+ --with-md5 \
+ --with-expat \
+ $(use_with ssl) \
+ ${myconf} || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog
+ dohtml -r .
+}