summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-08-16 04:15:22 +0000
committerBen Lutgens <lamer@gentoo.org>2001-08-16 04:15:22 +0000
commitcfe4476e007c6bb7a2caf443f2259946f139cca6 (patch)
tree6015718ca8ee0c0abcca4fd249d4fe3ee1bdf95f /net-libs
parentmasked out pam-0.75-r1 until I make sure it works. (diff)
downloadgentoo-2-cfe4476e007c6bb7a2caf443f2259946f139cca6.tar.gz
gentoo-2-cfe4476e007c6bb7a2caf443f2259946f139cca6.tar.bz2
gentoo-2-cfe4476e007c6bb7a2caf443f2259946f139cca6.zip
Added two packages the first is hogwash which is a layer2 packet scrubber.
It lives right on top of the network driver and will drop or sanitize packets based on signature. The authors installed it on an unpatched RH-6.2 box and entered it into the capture the flag competition at defcon 9 and the box came back unscathed. I've included the rules file too. as well as some documentation I copied off thier website. I may write a manpage for them too. The second is a supporting library for it that provides an API for commonly used low-level network functions (mainly packet injection). Used by packet scrubbers and the like, not to be confused with the perl libnet. They hogwash folks have a how-to on thier site for setting up an packet scrubber with no IP stack to protect your network, sortof a stealth firewall. Since it never modifies the mac address it's nearly impossible to detect and attack. Will prevent spoofing of IPs as well as 95% of the common attacks.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnet/files/digest-libnet-1.0.2a1
-rw-r--r--net-libs/libnet/libnet-1.0.2a.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libnet/files/digest-libnet-1.0.2a b/net-libs/libnet/files/digest-libnet-1.0.2a
new file mode 100644
index 000000000000..a8ff04756738
--- /dev/null
+++ b/net-libs/libnet/files/digest-libnet-1.0.2a
@@ -0,0 +1 @@
+MD5 ddf53f0f484184390e8c2a1bd0853667 libnet.tar.gz
diff --git a/net-libs/libnet/libnet-1.0.2a.ebuild b/net-libs/libnet/libnet-1.0.2a.ebuild
new file mode 100644
index 000000000000..42d0ae6be998
--- /dev/null
+++ b/net-libs/libnet/libnet-1.0.2a.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.0.2a.ebuild,v 1.1 2001/08/16 04:15:22 lamer Exp $
+
+S=${WORKDIR}/Libnet-1.0.2a
+DESCRIPTION="library to provide an API for commonly used low-level network
+functions (mainly packet injection). Used by packet scrubbers and the like,
+not to be confused with the perl libnet"
+SRC_URI="http://www.packetfactory.net/libnet/dist/libnet.tar.gz"
+HOMEPAGE="http://www.packefactory.net/libnet/"
+DEPEND=""
+
+#RDEPEND=""
+
+src_compile() {
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+
+ try emake
+ #try make
+}
+
+src_install () {
+
+ # try make prefix=${D}/usr install
+
+ try make DESTDIR=${D} MAN_DIR=${D}/usr/share/man install
+ dodoc VERSION doc/{README,TODO*,CHANGELOG*,COPYING}
+ newdoc README README.1st
+ dodoc example/libnet*
+ docinto Ancillary
+ dodoc doc/Ancillary/*
+}
+