summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-27 17:11:37 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-27 17:11:37 +0000
commitbff74dc4776530c6741f80113941e590b50880ce (patch)
tree6aa6ba8df35a567f9ea92ee51ad71d7c4f4041c3 /net-libs
parentFixes CVS HEADER tag (diff)
downloadgentoo-2-bff74dc4776530c6741f80113941e590b50880ce.tar.gz
gentoo-2-bff74dc4776530c6741f80113941e590b50880ce.tar.bz2
gentoo-2-bff74dc4776530c6741f80113941e590b50880ce.zip
Version bump, closes #7039.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnet/ChangeLog7
-rw-r--r--net-libs/libnet/files/digest-libnet-1.1.01
-rw-r--r--net-libs/libnet/libnet-1.1.0.ebuild36
3 files changed, 43 insertions, 1 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index 803e1c6d88a4..7bcb0d4c2573 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnet
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.4 2002/08/06 14:30:50 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.5 2002/08/27 17:11:33 aliz Exp $
+
+*libnet-1.1.0 (27 Aug 2002)
+
+ 27 Aug 2002; Daniel Ahlberg <aliz@gentoo.org:
+ Version bump. Closes #7039. Ebuild contributed by michael.sterrett@coat.com.
*libnet-1.0.2a-r1 (27 Mar 2002)
diff --git a/net-libs/libnet/files/digest-libnet-1.1.0 b/net-libs/libnet/files/digest-libnet-1.1.0
new file mode 100644
index 000000000000..bdfe61b76eae
--- /dev/null
+++ b/net-libs/libnet/files/digest-libnet-1.1.0
@@ -0,0 +1 @@
+MD5 b46e650d9d0e7ad5ef9439c7cd281922 libnet-1.1.0.tar.gz 210621
diff --git a/net-libs/libnet/libnet-1.1.0.ebuild b/net-libs/libnet/libnet-1.1.0.ebuild
new file mode 100644
index 000000000000..b24ab23d8131
--- /dev/null
+++ b/net-libs/libnet/libnet-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.1.0.ebuild,v 1.1 2002/08/27 17:11:37 aliz Exp $
+
+S=${WORKDIR}/Libnet-latest
+DESCRIPTION="library to provide an API for commonly used low-level network
+functions (mainly packet injection). Used by packet scrubbers and the like,
+not to be confused with the perl libnet"
+SRC_URI="http://www.packetfactory.net/libnet/dist/${P}.tar.gz"
+HOMEPAGE="http://www.packetfactory.net/libnet/"
+DEPEND=""
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+
+ econf || die
+
+ emake || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ MAN_PREFIX=${D}/usr/share/man \
+ install || die
+
+ dodoc VERSION README doc/{CHANGELOG,COPYING,DESIGN_NOTES,PACKET_BUILDING}
+ dodoc doc/{RAWSOCKET_NON_SEQUITUR,TODO,BUGS,CONTRIB,MIGRATION,PORTED,SUPPORTED_PROTOCOLS}
+ docinto Ancillary
+ dodoc doc/Ancillary/README*
+}
+