summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-01-01 19:21:04 +0000
committerPacho Ramos <pacho@gentoo.org>2014-01-01 19:21:04 +0000
commitb9e988f547726742f65476e6cb74b8bb5e8ed011 (patch)
treefaca849db7a6f509c17b4b4904d8c0641ef3d48d /net-libs
parentRevision bump to remove filters useflag and dependency on foomatic-filters (diff)
downloadgentoo-2-b9e988f547726742f65476e6cb74b8bb5e8ed011.tar.gz
gentoo-2-b9e988f547726742f65476e6cb74b8bb5e8ed011.tar.bz2
gentoo-2-b9e988f547726742f65476e6cb74b8bb5e8ed011.zip
Disable gnutls support due bug #456306 to stop blocking gnutls-3 stabilization
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libdexter/ChangeLog9
-rw-r--r--net-libs/libdexter/libdexter-0.2.1-r1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-libs/libdexter/ChangeLog b/net-libs/libdexter/ChangeLog
index cd3b4fafbd7b..cc2dadca833c 100644
--- a/net-libs/libdexter/ChangeLog
+++ b/net-libs/libdexter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libdexter
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libdexter/ChangeLog,v 1.5 2013/01/17 17:37:20 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdexter/ChangeLog,v 1.6 2014/01/01 19:21:04 pacho Exp $
+
+*libdexter-0.2.1-r1 (01 Jan 2014)
+
+ 01 Jan 2014; Pacho Ramos <pacho@gentoo.org> +libdexter-0.2.1-r1.ebuild:
+ Disable gnutls support due bug #456306 to stop blocking gnutls-3 stabilization
*libdexter-0.2.1 (17 Jan 2013)
diff --git a/net-libs/libdexter/libdexter-0.2.1-r1.ebuild b/net-libs/libdexter/libdexter-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..5f1269065045
--- /dev/null
+++ b/net-libs/libdexter/libdexter-0.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libdexter/libdexter-0.2.1-r1.ebuild,v 1.1 2014/01/01 19:21:04 pacho Exp $
+
+EAPI=5
+inherit gnome2-utils eutils
+
+DESCRIPTION="A plugin-based, distributed sampling library"
+HOMEPAGE="http://libdexter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libdexter/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# gnutls disabled as will break with gnutls-3, bug #456306
+IUSE="tcpd" #gnutls
+
+#gnutls? ( >=net-libs/gnutls-1.4.4:= )
+RDEPEND="
+ tcpd? ( sys-apps/tcp-wrappers:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-libs/glib-2.30:2
+"
+
+src_prepare() {
+ gnome2_disable_deprecation_warning
+}
+
+src_configure() {
+ econf \
+ $(use_enable tcpd tcp-wrappers) \
+ --disable-tls
+# $(use_enable gnutls tls)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}