summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-03 00:26:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-03 00:26:50 +0000
commit971611d0b4dd38f14e1e5f82325fc7470e6db59a (patch)
tree2ed93806a5461129b25ac204d95aa8140b8d088d /net-libs
parentAdded patch for chan_misdn support on asterisk-1.0.x as requested by genstef. (diff)
downloadgentoo-2-971611d0b4dd38f14e1e5f82325fc7470e6db59a.tar.gz
gentoo-2-971611d0b4dd38f14e1e5f82325fc7470e6db59a.tar.bz2
gentoo-2-971611d0b4dd38f14e1e5f82325fc7470e6db59a.zip
clean up misc crap
(Portage version: 2.0.53)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.57-r1.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/net-libs/courier-authlib/courier-authlib-0.57-r1.ebuild b/net-libs/courier-authlib/courier-authlib-0.57-r1.ebuild
index 45f6e44a4e21..c80159d8a69d 100644
--- a/net-libs/courier-authlib/courier-authlib-0.57-r1.ebuild
+++ b/net-libs/courier-authlib/courier-authlib-0.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.57-r1.ebuild,v 1.11 2005/11/27 18:03:26 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.57-r1.ebuild,v 1.12 2005/12/03 00:26:50 vapier Exp $
inherit eutils gnuconfig flag-o-matic
@@ -10,14 +10,13 @@ DESCRIPTION="courier authentication library"
HOMEPAGE="http://www.courier-mta.org/"
S="${WORKDIR}/${P%%_pre}"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
IUSE="postgres ldap mysql berkdb gdbm pam crypt debug"
RESTRICT="nouserpriv"
-DEPEND="virtual/libc
- gdbm? ( sys-libs/gdbm )
+DEPEND="gdbm? ( sys-libs/gdbm )
!gdbm? ( >=sys-devel/autoconf-2.5 sys-libs/db )
>=dev-libs/openssl-0.9.6
pam? ( >=sys-libs/pam-0.75 )
@@ -25,12 +24,9 @@ DEPEND="virtual/libc
ldap? ( >=net-nds/openldap-1.2.11 )
postgres? ( >=dev-db/postgresql-7.2 )"
-RDEPEND="virtual/libc
- gdbm? ( sys-libs/gdbm )
+RDEPEND="gdbm? ( sys-libs/gdbm )
!gdbm? ( sys-libs/db )"
-filter-flags '-fomit-frame-pointer'
-
src_unpack() {
if ! has_version 'dev-tcltk/expect' ; then
ewarn 'The dev-tcltk/expect package is not installed.'
@@ -41,7 +37,6 @@ src_unpack() {
unpack ${A}
cd ${S}
sed -e"s|^chk_file .* |&\${DESTDIR}|g" -i.orig authmigrate.in
- use elibc_uclibc && sed -i -e 's:linux-gnu\*:linux-gnu\*\ \|\ linux-uclibc:' config.sub
if ! use gdbm ; then
epatch ${FILESDIR}/configure-db4.patch
export WANT_AUTOCONF="2.5"
@@ -63,6 +58,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags '-fomit-frame-pointer'
+
local myconf
myconf="`use_with pam authpam` `use_with ldap authldap`"