summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-23 03:41:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-23 03:41:43 +0000
commit843022cde8bb3f4ea5dce398a118acdff5440c58 (patch)
tree2dfb2a4c3aee3164da3b3f8845050a76bbb05fa3 /net-libs
parentAdd PYTHON_DEPS #487570 (diff)
downloadgentoo-2-843022cde8bb3f4ea5dce398a118acdff5440c58.tar.gz
gentoo-2-843022cde8bb3f4ea5dce398a118acdff5440c58.tar.bz2
gentoo-2-843022cde8bb3f4ea5dce398a118acdff5440c58.zip
Small fixes and unbundling for 0.10
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/ChangeLog7
-rw-r--r--net-libs/nodejs/nodejs-0.10.29-r1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index d0b521322d38..75b94ea8d529 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.121 2014/07/23 03:28:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.122 2014/07/23 03:41:43 patrick Exp $
+
+*nodejs-0.10.29-r1 (23 Jul 2014)
+
+ 23 Jul 2014; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.29-r1.ebuild:
+ Small fixes and unbundling for 0.10
23 Jul 2014; Patrick Lauer <patrick@gentoo.org> nodejs-0.10.29.ebuild,
nodejs-0.11.13.ebuild, nodejs-0.8.27.ebuild:
diff --git a/net-libs/nodejs/nodejs-0.10.29-r1.ebuild b/net-libs/nodejs/nodejs-0.10.29-r1.ebuild
new file mode 100644
index 000000000000..5b4fe6197c09
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.10.29-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.29-r1.ebuild,v 1.1 2014/07/23 03:41:43 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-any-r1 pax-utils toolchain-funcs
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm +snapshot"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ tc-export CC CXX
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+ ! use snapshot && myconf="${myconf} --without-snapshot"
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --shared-openssl --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ local V=1
+ export V
+ emake out/Makefile
+ emake -C out mksnapshot
+ pax-mark m out/Release/mksnapshot
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}"
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}