summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-28 01:43:58 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-28 01:43:58 +0000
commit82a0bdeba6e09343eb7903f34aad6602614c03d6 (patch)
tree96b7ec33514342c334708020138eaf2cc67c06cd /net-libs
parentnew version (diff)
downloadgentoo-2-82a0bdeba6e09343eb7903f34aad6602614c03d6.tar.gz
gentoo-2-82a0bdeba6e09343eb7903f34aad6602614c03d6.tar.bz2
gentoo-2-82a0bdeba6e09343eb7903f34aad6602614c03d6.zip
new linc version
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/linc/ChangeLog7
-rw-r--r--net-libs/linc/files/digest-linc-0.5.01
-rw-r--r--net-libs/linc/linc-0.5.0.ebuild58
3 files changed, 65 insertions, 1 deletions
diff --git a/net-libs/linc/ChangeLog b/net-libs/linc/ChangeLog
index 179871ddc5a4..471ee07d79ab 100644
--- a/net-libs/linc/ChangeLog
+++ b/net-libs/linc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/linc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.2 2002/05/23 19:15:18 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.3 2002/05/28 01:43:58 spider Exp $
+
+
+*linc-0.5.0 (27 May 2002)
+ 27 May 2002; Spider <spider@gentoo.org> linc-0.5.0.ebuild :
+ latest release!
*linc-0.1.22 (23 May 2002)
diff --git a/net-libs/linc/files/digest-linc-0.5.0 b/net-libs/linc/files/digest-linc-0.5.0
new file mode 100644
index 000000000000..596aace964e4
--- /dev/null
+++ b/net-libs/linc/files/digest-linc-0.5.0
@@ -0,0 +1 @@
+MD5 2793b19b769be65ed3cb7df786b8032e linc-0.5.0.tar.bz2 177900
diff --git a/net-libs/linc/linc-0.5.0.ebuild b/net-libs/linc/linc-0.5.0.ebuild
new file mode 100644
index 000000000000..9d024b42c0d5
--- /dev/null
+++ b/net-libs/linc/linc-0.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.5.0.ebuild,v 1.1 2002/05/28 01:43:58 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library to ease the writing of networked applications"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.0
+ >=dev-libs/openssl-0.9.6"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+# libtoolize --copy --force
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+
+ # if this is disabled (use) ORBit2 will fail to build. Just force it on
+ myconf="${myconf} --with-openssl"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --enable-debug=yes || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* INSTALL NEWS TODO
+}
+
+
+
+
+