summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-10-21 22:15:25 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-10-21 22:15:25 +0000
commit7c5f61befe5e85f71e137ec83912a42a67f6fd1f (patch)
tree71ccefcf8ee91718b8ff184b9e42c15d01a65a5a /net-libs
parentSimplify init script with the new declarative runscript. (diff)
downloadgentoo-2-7c5f61befe5e85f71e137ec83912a42a67f6fd1f.tar.gz
gentoo-2-7c5f61befe5e85f71e137ec83912a42a67f6fd1f.tar.bz2
gentoo-2-7c5f61befe5e85f71e137ec83912a42a67f6fd1f.zip
Version bump. Fix build with USE=-introspection, bug #383561.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp-igd/ChangeLog8
-rw-r--r--net-libs/gupnp-igd/files/gupnp-igd-0.1.11-disable_static_modules.patch10
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.1.11.ebuild106
3 files changed, 123 insertions, 1 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index 1fd6d0ad57fa..ce0d67ad65f9 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gupnp-igd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.28 2011/09/15 20:44:06 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.29 2011/10/21 22:15:24 eva Exp $
+
+*gupnp-igd-0.1.11 (21 Oct 2011)
+
+ 21 Oct 2011; Gilles Dartiguelongue <eva@gentoo.org> +gupnp-igd-0.1.11.ebuild,
+ +files/gupnp-igd-0.1.11-disable_static_modules.patch:
+ Version bump. Fix build with USE=-introspection, bug #383561.
*gupnp-igd-0.1.10 (15 Sep 2011)
diff --git a/net-libs/gupnp-igd/files/gupnp-igd-0.1.11-disable_static_modules.patch b/net-libs/gupnp-igd/files/gupnp-igd-0.1.11-disable_static_modules.patch
new file mode 100644
index 000000000000..48534925d21f
--- /dev/null
+++ b/net-libs/gupnp-igd/files/gupnp-igd-0.1.11-disable_static_modules.patch
@@ -0,0 +1,10 @@
+--- python/Makefile.am
++++ python/Makefile.am
+@@ -27,7 +28,7 @@
+
+ igd_la_LDFLAGS = \
+- -module -avoid-version
++ -module -avoid-version -shared
+
+ pygupnp-igd.c: $(srcdir)/pygupnp-igd.override $(srcdir)/pygupnp-igd.defs
+ $(PYCODEGEN) \
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.1.11.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.1.11.ebuild
new file mode 100644
index 000000000000..525236dc8256
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.1.11.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.1.11.ebuild,v 1.1 2011/10/21 22:15:25 eva Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit autotools eutils python
+
+DESCRIPTION="This is a library to handle UPnP IGD port mapping for GUPnP."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://www.gupnp.org/sites/all/files/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection python"
+
+RDEPEND=">=net-libs/gupnp-0.13.2
+ >=dev-libs/glib-2.16:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+ python? ( >=dev-python/pygobject-2.16 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ dev-util/gtk-doc-am"
+
+# The only existing test is broken
+RESTRICT="test"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.1.11-disable_static_modules.patch
+
+ # Disable byte-compilation of Python modules.
+ echo "#!/bin/sh" > py-compile
+
+ # Python bindings are built/installed manually.
+ sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ --disable-gtk-doc \
+ $(use_enable introspection) \
+ $(use_enable python)
+}
+
+src_compile() {
+ # introspection is built in the same directory and libtool does not handle
+ # well dependency like this
+ MAKEOPTS="${MAKEOPTS} -j1" default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_installation_image
+ fi
+
+ dodoc AUTHORS NEWS README TODO || die
+ find "${D}" -name "*.la" -delete
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize gupnp
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup gupnp
+ fi
+}