summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-07-23 03:51:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-07-23 03:51:35 +0000
commit5dc731bbe3146587eb38d65ede0e96e99f072ce6 (patch)
tree4444eab14b7eeddab3fdb9db6753d12149abcc45 /net-libs
parentSmall fixes and unbundling for 0.10 (diff)
downloadgentoo-2-5dc731bbe3146587eb38d65ede0e96e99f072ce6.tar.gz
gentoo-2-5dc731bbe3146587eb38d65ede0e96e99f072ce6.tar.bz2
gentoo-2-5dc731bbe3146587eb38d65ede0e96e99f072ce6.zip
Small fixes and unbundling for 0.11
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/ChangeLog7
-rw-r--r--net-libs/nodejs/nodejs-0.11.13-r1.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 75b94ea8d529..cd790284e7e8 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.122 2014/07/23 03:41:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.123 2014/07/23 03:51:35 patrick Exp $
+
+*nodejs-0.11.13-r1 (23 Jul 2014)
+
+ 23 Jul 2014; Patrick Lauer <patrick@gentoo.org> +nodejs-0.11.13-r1.ebuild:
+ Small fixes and unbundling for 0.11
*nodejs-0.10.29-r1 (23 Jul 2014)
diff --git a/net-libs/nodejs/nodejs-0.11.13-r1.ebuild b/net-libs/nodejs/nodejs-0.11.13-r1.ebuild
new file mode 100644
index 000000000000..8b2011c6d1d1
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.11.13-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.13-r1.ebuild,v 1.1 2014/07/23 03:51:35 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-any-r1 pax-utils toolchain-funcs
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm +snapshot"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${PYTHON_DEPS}
+ ${RDEPEND}
+ >=net-libs/http-parser-2.3
+ =dev-libs/libuv-0.11.25-r1"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ tc-export CC CXX
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+ ! use snapshot && myconf="${myconf} --without-snapshot"
+
+ # Use target arch detection logic, see v8-3.18 ebuilds
+ case ${CHOST} in
+ i?86-*)
+ myarch="ia32"
+ myconf+=" -Dv8_target_arch=ia32" ;;
+ x86_64-*)
+ if [[ $ABI = x86 ]] ; then
+ myarch="ia32"
+ else
+ myarch="x64"
+ fi ;;
+ arm*-*)
+ myarch="arm"
+ ;;
+ *) die "Unrecognized CHOST: ${CHOST}"
+ esac
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --shared-openssl \
+ --shared-libuv \
+ --shared-http-parser \
+ --shared-zlib \
+ --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ local V=1
+ export V
+ emake out/Makefile
+ emake -C out "mksnapshot.${myarch}"
+ pax-mark m "out/Release/mksnapshot.${myarch}"
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}" /usr
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}