summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-01-10 11:13:50 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-01-10 11:13:50 +0000
commit37c294c07a90291849d25afdce0093395dec2f54 (patch)
treeda36b747696418de67de819c38961f65b007dd23 /net-libs
parentsome dosemu cleanups and fixes (Manifest recommit) (diff)
downloadgentoo-2-37c294c07a90291849d25afdce0093395dec2f54.tar.gz
gentoo-2-37c294c07a90291849d25afdce0093395dec2f54.tar.bz2
gentoo-2-37c294c07a90291849d25afdce0093395dec2f54.zip
Added IUSE=doc and install HTML docs if set; updated metadata.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/socket++/ChangeLog8
-rw-r--r--net-libs/socket++/Manifest16
-rw-r--r--net-libs/socket++/metadata.xml4
-rw-r--r--net-libs/socket++/socket++-1.12.12.ebuild24
4 files changed, 32 insertions, 20 deletions
diff --git a/net-libs/socket++/ChangeLog b/net-libs/socket++/ChangeLog
index fdb0e2bd6988..b23c3ec2f472 100644
--- a/net-libs/socket++/ChangeLog
+++ b/net-libs/socket++/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/socket++
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/ChangeLog,v 1.4 2004/12/16 09:30:28 swegener Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/ChangeLog,v 1.5 2005/01/10 11:13:50 ka0ttic Exp $
+
+ 10 Jan 2005; Aaron Walker <ka0ttic@gentoo.org> metadata.xml,
+ socket++-1.12.12.ebuild:
+ Added IUSE=doc and install HTML docs if set; updated metadata.
*socket++-1.12.12 (16 Dec 2004)
diff --git a/net-libs/socket++/Manifest b/net-libs/socket++/Manifest
index 76debd2b173a..8d5aa99365d4 100644
--- a/net-libs/socket++/Manifest
+++ b/net-libs/socket++/Manifest
@@ -1,14 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 daeb4b14cfecf1ae58af2cfd28610ef0 socket++-1.12.12.ebuild 887
-MD5 f58ad1affd0921b7a81c42edfd1e74ce ChangeLog 883
-MD5 2b3e89005c19886504e6ca523a0659f9 metadata.xml 459
+MD5 9368935359a028af317179f4600a537d socket++-1.12.12.ebuild 1367
+MD5 1d4b943e49a2c9f8b65711c95282ccaf ChangeLog 1039
+MD5 bf34cf8cbb54a25fa53cd16fcbf4a2d0 metadata.xml 438
MD5 de72f99bd9ee929dfc53cbfc508c1c24 files/digest-socket++-1.12.12 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBwVW9I1lqEGTUzyQRAnJ7AJwJDy94R3uxxYkXNbc2qqYoLP+NWQCgkqMc
-S7ULOfgV6fCn6ivtmRGnLuU=
-=lK0u
------END PGP SIGNATURE-----
diff --git a/net-libs/socket++/metadata.xml b/net-libs/socket++/metadata.xml
index 59bbda3dbbab..e100dc16ef57 100644
--- a/net-libs/socket++/metadata.xml
+++ b/net-libs/socket++/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>swegener@gentoo.org</email>
- <description>Primary Maintainer</description>
+ <email>ka0ttic@gentoo.org</email>
+ <name>Aaron Walker</name>
</maintainer>
<longdescription>Socket++ library defines a family of C++ classes that can be used more effectively than directly calling the underlying low-level system functions.</longdescription>
</pkgmetadata>
diff --git a/net-libs/socket++/socket++-1.12.12.ebuild b/net-libs/socket++/socket++-1.12.12.ebuild
index c6c749db4ddd..3aba5f3e992d 100644
--- a/net-libs/socket++/socket++-1.12.12.ebuild
+++ b/net-libs/socket++/socket++-1.12.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12.ebuild,v 1.1 2004/12/16 09:30:28 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12.ebuild,v 1.2 2005/01/10 11:13:50 ka0ttic Exp $
DESCRIPTION="C++ Socket Library"
HOMEPAGE="http://www.linuxhacker.at/socketxx/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.linuxhacker.at/linux/downloads/src/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~x86"
-IUSE="debug"
+IUSE="debug doc"
DEPEND="=sys-devel/automake-1.7*
=sys-devel/autoconf-2.59*
@@ -26,9 +26,27 @@ src_unpack() {
src_compile() {
econf $(use_enable debug) || die "econf failed"
emake || die "emake failed"
+
+ if use doc ; then
+ cd ${S}/doc
+ einfo "Building HTML documentation"
+ # the 'html' target in both ${S}/Makefile and ${S}/doc/Makefile
+ # do indeed exist (and succeed when run manually), but fail when
+ # 'make html' is done here, so we call makeinfo ourselves.
+ makeinfo --html -I . -o html socket++.texi || die "makeinfo failed"
+ fi
+}
+
+src_test() {
+ cd ${S}/test
+ make check || die "make check failed"
}
src_install() {
make DESTDIR=${D} install || die "install failed"
dodoc AUTHORS ChangeLog NEWS README* THANKS || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
}