summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-11-03 21:35:40 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-11-03 21:35:40 +0000
commit10842c61e125055f38cffa47c799ceb37da8c5d8 (patch)
tree4be0d1ef824d724a5d58d0250665e57531f6d6af /net-libs
parentVersion bump. (diff)
downloadgentoo-2-10842c61e125055f38cffa47c799ceb37da8c5d8.tar.gz
gentoo-2-10842c61e125055f38cffa47c799ceb37da8c5d8.tar.bz2
gentoo-2-10842c61e125055f38cffa47c799ceb37da8c5d8.zip
Version bump, bug 343235
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgadu/ChangeLog7
-rw-r--r--net-libs/libgadu/libgadu-1.9.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/net-libs/libgadu/ChangeLog b/net-libs/libgadu/ChangeLog
index 2d895108e301..a6072d3055a4 100644
--- a/net-libs/libgadu/ChangeLog
+++ b/net-libs/libgadu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libgadu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.46 2010/07/20 02:16:01 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.47 2010/11/03 21:35:40 reavertm Exp $
+
+*libgadu-1.9.1 (03 Nov 2010)
+
+ 03 Nov 2010; Maciej Mrozowski <reavertm@gentoo.org> +libgadu-1.9.1.ebuild:
+ Version bump, bug 343235
20 Jul 2010; Maciej Mrozowski <reavertm@gentoo.org> -libgadu-1.8.2.ebuild,
libgadu-1.9.0-r1.ebuild:
diff --git a/net-libs/libgadu/libgadu-1.9.1.ebuild b/net-libs/libgadu/libgadu-1.9.1.ebuild
new file mode 100644
index 000000000000..bb44f222df72
--- /dev/null
+++ b/net-libs/libgadu/libgadu-1.9.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.9.1.ebuild,v 1.1 2010/11/03 21:35:40 reavertm Exp $
+
+EAPI="2"
+
+MY_P="${P/_/-}"
+
+inherit autotools-utils
+
+DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
+HOMEPAGE="http://toxygen.net/libgadu/"
+SRC_URI="http://toxygen.net/libgadu/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE="doc ssl static-libs threads"
+
+COMMON_DEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6m )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${COMMON_DEPEND}
+ !=net-im/kadu-0.6.0.2
+ !=net-im/kadu-0.6.0.1
+"
+
+S="${WORKDIR}/${MY_P}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=(AUTHORS ChangeLog NEWS README)
+
+src_configure() {
+ myeconfargs=(
+ $(use_with ssl openssl)
+ $(use_with threads pthread)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=(docs/html/)
+ autotools-utils_src_install
+}