summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-10-23 07:46:37 +0000
committerAlin Năstac <mrness@gentoo.org>2006-10-23 07:46:37 +0000
commitb001cb7091884f687fda477331790679d2592b97 (patch)
tree06c84ec3f81e1b10b4650215ec55dccab41cb125 /net-libs/wvstreams/wvstreams-4.2.2.ebuild
parentno point in listing kingtaco in SRC_URI (diff)
downloadgentoo-2-b001cb7091884f687fda477331790679d2592b97.tar.gz
gentoo-2-b001cb7091884f687fda477331790679d2592b97.tar.bz2
gentoo-2-b001cb7091884f687fda477331790679d2592b97.zip
Replace deprecated tcltk USE flag with tcl (#17808).
(Portage version: 2.1.1)
Diffstat (limited to 'net-libs/wvstreams/wvstreams-4.2.2.ebuild')
-rw-r--r--net-libs/wvstreams/wvstreams-4.2.2.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-libs/wvstreams/wvstreams-4.2.2.ebuild b/net-libs/wvstreams/wvstreams-4.2.2.ebuild
index d11cd64094e6..f19499fce8b3 100644
--- a/net-libs/wvstreams/wvstreams-4.2.2.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.2.2.ebuild,v 1.8 2006/08/28 05:33:52 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.2.2.ebuild,v 1.9 2006/10/23 07:46:37 mrness Exp $
inherit eutils fixheadtails
@@ -11,7 +11,7 @@ SRC_URI="http://open.nit.ca/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ppc sparc x86"
-IUSE="gtk qt3 qdbm pam slp doc tcltk debug"
+IUSE="gtk qt3 qdbm pam slp doc tcl debug"
RDEPEND=">=sys-libs/db-3
>=sys-libs/zlib-1.1.4
@@ -22,7 +22,7 @@ RDEPEND=">=sys-libs/db-3
pam? ( >=sys-libs/pam-0.75 )
slp? ( >=net-libs/openslp-1.0.9a )
doc? ( app-doc/doxygen )
- tcltk? ( >=dev-lang/tcl-8.4 dev-lang/swig )"
+ tcl? ( >=dev-lang/tcl-8.4 dev-lang/swig )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -35,12 +35,12 @@ src_unpack() {
epatch "${FILESDIR}/${P}-linux-serial.patch"
epatch "${FILESDIR}/${P}-wireless-user.patch"
- if use tcltk; then
+ if use tcl; then
epatch "${FILESDIR}/${P}-tcl_8_4.patch"
fi
epatch "${FILESDIR}/${P}-external-xplc.patch"
- local XPLC_VER=`best_version dev-libs/xplc`
+ local XPLC_VER=$(best_version dev-libs/xplc)
XPLC_VER=${XPLC_VER#*/*-} #reduce it to ${PV}-${PR}
XPLC_VER=${XPLC_VER%%[_-]*} # main version without beta/pre/patch/revision
sed -i -e "s:^xplc_version=.*:xplc_version='${XPLC_VER}':" "${S}/configure.ac" \
@@ -66,11 +66,11 @@ src_compile() {
myconf="--without-qt"
fi
econf ${myconf} \
- `use_with qdbm` \
- `use_with pam` \
- `use_with slp openslp` \
- `use_with tcltk tcl` \
- `use_enable debug` \
+ $(use_with qdbm) \
+ $(use_with pam) \
+ $(use_with slp openslp) \
+ $(use_with tcl) \
+ $(use_enable debug) \
--with-xplc \
--enable-verbose \
--with-bdb \