summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-29 12:36:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-29 12:36:39 +0000
commit154f70bee99c443143df8488bef6dd09adaecd5f (patch)
tree2c61c2f290eeac8c8b00531b099723ee6a89aa00 /net-libs/webkit-gtk
parentdev-python/pmw: Correct SLOTs, #453570 (diff)
downloadgentoo-2-154f70bee99c443143df8488bef6dd09adaecd5f.tar.gz
gentoo-2-154f70bee99c443143df8488bef6dd09adaecd5f.tar.bz2
gentoo-2-154f70bee99c443143df8488bef6dd09adaecd5f.zip
Fix build on FreeBSD and keyword ~amd64-fbsd, bug #449220
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog6
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.10.2-wifexited.patch25
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild8
3 files changed, 36 insertions, 3 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 9c1f25099f11..c24c1cfd51cf 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.192 2013/01/06 10:02:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.193 2013/01/29 12:36:39 aballier Exp $
+
+ 29 Jan 2013; Alexis Ballier <aballier@gentoo.org>
+ webkit-gtk-1.10.2-r300.ebuild, +files/webkit-gtk-1.10.2-wifexited.patch:
+ Fix build on FreeBSD and keyword ~amd64-fbsd, bug #449220
06 Jan 2013; Agostino Sarubbo <ago@gentoo.org> webkit-gtk-1.10.2-r300.ebuild:
Add ~sparc, wrt bug #449220
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-wifexited.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-wifexited.patch
new file mode 100644
index 000000000000..a1a120f2a6e4
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-wifexited.patch
@@ -0,0 +1,25 @@
+WIFEXITED definitions: POSIX documents this in stdlib.h as optional, and is
+defined there on linux, but on FreeBSD it is not, so we need to include
+sys/wait.h where POSIX mandates it to be.
+
+
+--- webkitgtk-1.10.2/Source/WebKit2/UIProcess/Plugins/gtk/PluginProcessProxyGtk.cpp.old 2013-01-28 20:38:45.000000000 -0300
++++ webkitgtk-1.10.2/Source/WebKit2/UIProcess/Plugins/gtk/PluginProcessProxyGtk.cpp 2013-01-28 20:39:10.000000000 -0300
+@@ -35,6 +35,7 @@
+ #include <glib.h>
+ #include <wtf/text/CString.h>
+ #include <wtf/text/WTFString.h>
++#include <sys/wait.h> // WIFEXITED
+
+ using namespace WebCore;
+
+--- webkitgtk-1.10.2/Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp.old 2013-01-28 20:40:26.000000000 -0300
++++ webkitgtk-1.10.2/Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp 2013-01-28 20:40:46.000000000 -0300
+@@ -38,6 +38,7 @@
+ #include <wtf/text/WTFString.h>
+ #include <wtf/gobject/GOwnPtr.h>
+ #include <wtf/gobject/GlibUtilities.h>
++#include <sys/wait.h> // WIFEXITED
+
+ #if OS(LINUX)
+ #include <sys/prctl.h>
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild
index 7e1655c64dbf..73ef4b23a5c7 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild,v 1.4 2013/01/06 10:02:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild,v 1.5 2013/01/29 12:36:39 aballier Exp $
EAPI="5"
@@ -13,7 +13,7 @@ SRC_URI="http://www.webkitgtk.org/releases/${MY_P}.tar.xz"
LICENSE="LGPL-2+ BSD"
SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
IUSE="aqua coverage debug +geoloc +gstreamer +introspection +jit spell +webgl"
# bugs 372493, 416331
REQUIRED_USE="introspection? ( geoloc gstreamer )"
@@ -155,6 +155,10 @@ src_prepare() {
# uclibc fix, bug #441674
epatch "${FILESDIR}/${PN}-1.10.1-disable-backtrace-uclibc.patch"
+ # fix for freebsd for WIFEXITED definition
+ # https://bugs.gentoo.org/show_bug.cgi?id=449220#c17
+ epatch "${FILESDIR}/${PN}-1.10.2-wifexited.patch"
+
# Respect CC, otherwise fails on prefix #395875
tc-export CC