summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-14 19:36:46 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-14 19:36:46 +0000
commit6266974fa52fb0271b5feb32749ee786c2a9a6ca (patch)
treec34ec4d558a52c859b7e67bf97685c153dfa9cc0 /net-libs/telepathy-glib
parentversion bump (diff)
downloadgentoo-2-6266974fa52fb0271b5feb32749ee786c2a9a6ca.tar.gz
gentoo-2-6266974fa52fb0271b5feb32749ee786c2a9a6ca.tar.bz2
gentoo-2-6266974fa52fb0271b5feb32749ee786c2a9a6ca.zip
Bump to 0.13.17
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog8
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.13.17.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 65a053355863..17beb228ab2c 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.67 2011/03/12 21:15:12 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.68 2011/03/14 19:36:46 nirbheek Exp $
+
+*telepathy-glib-0.13.17 (14 Mar 2011)
+
+ 14 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +telepathy-glib-0.13.17.ebuild:
+ Bump to 0.13.17
12 Mar 2011; Raúl Porcel <armin76@gentoo.org> telepathy-glib-0.12.7.ebuild:
alpha/arm/ia64/sparc stable wrt #353436
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.13.17.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.13.17.ebuild
new file mode 100644
index 000000000000..b82c4e70c06a
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.13.17.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.13.17.ebuild,v 1.1 2011/03/14 19:36:46 nirbheek Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit python virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +introspection +vala"
+
+RDEPEND=">=dev-libs/glib-2.25.16
+ >=dev-libs/dbus-glib-0.82
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ vala? (
+ dev-lang/vala:0.12[vapigen]
+ >=dev-libs/gobject-introspection-0.9.6 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_prepare() {
+ python_convert_shebangs -r 2 examples tests tools
+ default_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.12)
+ VAPIGEN=$(type -p vapigen-0.12)"
+ fi
+
+ econf --disable-static \
+ PYTHON=$(PYTHON -2 -a) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings) \
+ ${myconf}
+}
+
+src_test() {
+ # Needs dbus for tests (auto-launched)
+ Xemake -j1 check || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}