summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-16 00:15:03 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-16 00:15:03 +0000
commit270892283c5cf02327641ab7aa57d999fea4c5e2 (patch)
tree11312d84edfdc3b5c84470528929b1af128b74c3 /net-libs/telepathy-glib
parentDrop PaX patch as it doesn't seem to be needed anymore #431810. (diff)
downloadgentoo-2-270892283c5cf02327641ab7aa57d999fea4c5e2.tar.gz
gentoo-2-270892283c5cf02327641ab7aa57d999fea4c5e2.tar.bz2
gentoo-2-270892283c5cf02327641ab7aa57d999fea4c5e2.zip
Fix vala.eclass usage (bug #435158, thanks to Alexandre and Rafał Mużyło) and simplify dependencies.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog7
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.18.2.ebuild13
2 files changed, 10 insertions, 10 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 5c4623af3b75..fc8f9592502c 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.115 2012/09/15 08:53:51 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.116 2012/09/16 00:15:03 tetromino Exp $
+
+ 16 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ telepathy-glib-0.18.2.ebuild:
+ Fix vala.eclass usage (bug #435158, thanks to Alexandre and Rafał Mużyło)
+ and simplify dependencies.
*telepathy-glib-0.18.2 (15 Sep 2012)
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.18.2.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.18.2.ebuild
index 138aa40ccdf6..0c32bfcf6180 100644
--- a/net-libs/telepathy-glib/telepathy-glib-0.18.2.ebuild
+++ b/net-libs/telepathy-glib/telepathy-glib-0.18.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.18.2.ebuild,v 1.1 2012/09/15 08:53:51 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.18.2.ebuild,v 1.2 2012/09/16 00:15:03 tetromino Exp $
EAPI="4"
PYTHON_DEPEND="2:2.5"
@@ -17,6 +17,7 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="debug +introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
RDEPEND=">=dev-libs/glib-2.30.0:2
>=dev-libs/dbus-glib-0.90
@@ -24,23 +25,17 @@ RDEPEND=">=dev-libs/glib-2.30.0:2
DEPEND="${RDEPEND}
dev-libs/libxslt
virtual/pkgconfig
- vala? ( $(vala_depend)
- >=dev-libs/gobject-introspection-1.30 )"
+ vala? ( $(vala_depend) )"
src_prepare() {
python_convert_shebangs -r 2 examples tests tools
+ use vala && vala_src_prepare
default_src_prepare
}
src_configure() {
local myconf
- if use vala; then
- myconf="--enable-introspection
- VALAC=$(type -p valac-0.16)
- VAPIGEN=$(type -p vapigen-0.16)"
- fi
-
econf --disable-static \
--disable-installed-tests \
PYTHON=$(PYTHON -2 -a) \