summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-06-24 09:57:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-06-24 09:57:15 +0000
commitfade3f71e1c821feea770927f527eb8f874c5965 (patch)
treecee6711dc5fb030f5644e2dcea7c5f2db226fe0a /net-libs/ptlib
parentsci-biology/mafft: Version Bump (diff)
downloadgentoo-2-fade3f71e1c821feea770927f527eb8f874c5965.tar.gz
gentoo-2-fade3f71e1c821feea770927f527eb8f874c5965.tar.bz2
gentoo-2-fade3f71e1c821feea770927f527eb8f874c5965.zip
Fix building when linking to sdl, the libs were not propagated properly. Wrt bug#474362.
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-libs/ptlib')
-rw-r--r--net-libs/ptlib/ChangeLog7
-rw-r--r--net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch11
-rw-r--r--net-libs/ptlib/ptlib-2.12.4.ebuild7
3 files changed, 21 insertions, 4 deletions
diff --git a/net-libs/ptlib/ChangeLog b/net-libs/ptlib/ChangeLog
index 572277c5cf43..8929bcd84310 100644
--- a/net-libs/ptlib/ChangeLog
+++ b/net-libs/ptlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ptlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.48 2013/06/22 19:11:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.49 2013/06/24 09:57:14 scarabeus Exp $
+
+ 24 Jun 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/ptlib-2.12.4-sdl-linking.patch, ptlib-2.12.4.ebuild:
+ Fix building when linking to sdl, the libs were not propagated properly. Wrt
+ bug#474362.
*ptlib-2.12.4 (22 Jun 2013)
diff --git a/net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch b/net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch
new file mode 100644
index 000000000000..91e5c0811d5d
--- /dev/null
+++ b/net-libs/ptlib/files/ptlib-2.12.4-sdl-linking.patch
@@ -0,0 +1,11 @@
+diff -urN ptlib-2.12.4/configure.ac ptlib-2.12.4.new/configure.ac
+--- ptlib-2.12.4/configure.ac 2013-06-21 07:02:48.000000000 +0200
++++ ptlib-2.12.4.new/configure.ac 2013-06-24 11:51:18.356368722 +0200
+@@ -1735,6 +1735,7 @@
+ PTLIB_CFLAGS="$PTLIB_CFLAGS ${SDL_CFLAGS}"
+ LDFLAGS="$LDFLAGS `pkg-config --libs sdl`"
+ ],[HAS_SDL=])
++ ENDLDLIBS="$ENDLDLIBS ${SDL_LIBS}"
+ fi
+ fi
+ AC_SUBST(HAS_SDL)
diff --git a/net-libs/ptlib/ptlib-2.12.4.ebuild b/net-libs/ptlib/ptlib-2.12.4.ebuild
index 1fe73d42943c..bf62542fafa2 100644
--- a/net-libs/ptlib/ptlib-2.12.4.ebuild
+++ b/net-libs/ptlib/ptlib-2.12.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.4.ebuild,v 1.1 2013/06/22 19:11:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.4.ebuild,v 1.2 2013/06/24 09:57:14 scarabeus Exp $
EAPI=5
@@ -55,6 +55,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-2.10.9-svn_revision_override.patch"
epatch "${FILESDIR}/${PN}-2.10.9-pkgconfig_ldflags.patch"
epatch "${FILESDIR}/${PN}-2.12.4-respect_cxxflags.patch"
+ epatch "${FILESDIR}/${PN}-2.12.4-sdl-linking.patch"
if ! use telnet; then
epatch "${FILESDIR}/${PN}-2.10.9-disable-telnet-symbols.patch"
@@ -79,9 +80,9 @@ src_configure() {
# plugins are disabled only if ! audio and ! video
if ! use audio && ! use video; then
- myconf="${myconf} --disable-plugins"
+ myconf+=" --disable-plugins"
else
- myconf="${myconf} --enable-plugins"
+ myconf+=" --enable-plugins"
fi
# minsize: presets of features (overwritten by use flags)