summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-05-15 12:04:06 +0000
committerUlrich Müller <ulm@gentoo.org>2014-05-15 12:04:06 +0000
commit22854114349bd5cf222e4e864bf4ec0bcc9422aa (patch)
treef6b6fbdd082d3d8a8dcaa39f264c417e453a79f1 /net-libs/ptlib
parentTake maintainership of package (diff)
downloadgentoo-2-22854114349bd5cf222e4e864bf4ec0bcc9422aa.tar.gz
gentoo-2-22854114349bd5cf222e4e864bf4ec0bcc9422aa.tar.bz2
gentoo-2-22854114349bd5cf222e4e864bf4ec0bcc9422aa.zip
QA: Rename "audio" USE flag to "sound", bug 357661.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'net-libs/ptlib')
-rw-r--r--net-libs/ptlib/ChangeLog7
-rw-r--r--net-libs/ptlib/metadata.xml1
-rw-r--r--net-libs/ptlib/ptlib-2.10.10.ebuild22
-rw-r--r--net-libs/ptlib/ptlib-2.10.11.ebuild20
-rw-r--r--net-libs/ptlib/ptlib-2.10.9.ebuild22
-rw-r--r--net-libs/ptlib/ptlib-2.12.4.ebuild22
-rw-r--r--net-libs/ptlib/ptlib-2.12.9.ebuild20
-rw-r--r--net-libs/ptlib/ptlib-2.6.7-r1.ebuild22
8 files changed, 70 insertions, 66 deletions
diff --git a/net-libs/ptlib/ChangeLog b/net-libs/ptlib/ChangeLog
index 1b600becf82b..4b2608371302 100644
--- a/net-libs/ptlib/ChangeLog
+++ b/net-libs/ptlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ptlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.51 2014/04/29 07:58:15 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ChangeLog,v 1.52 2014/05/15 12:04:06 ulm Exp $
+
+ 15 May 2014; Ulrich Müller <ulm@gentoo.org> ptlib-2.6.7-r1.ebuild,
+ ptlib-2.10.9.ebuild, ptlib-2.10.10.ebuild, ptlib-2.10.11.ebuild,
+ ptlib-2.12.4.ebuild, ptlib-2.12.9.ebuild, metadata.xml:
+ QA: Rename "audio" USE flag to "sound", bug 357661.
*ptlib-2.12.9 (29 Apr 2014)
*ptlib-2.10.11 (29 Apr 2014)
diff --git a/net-libs/ptlib/metadata.xml b/net-libs/ptlib/metadata.xml
index 082e331fa64a..e90093bc27db 100644
--- a/net-libs/ptlib/metadata.xml
+++ b/net-libs/ptlib/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="asn">Enable ASN decoding/encoding support</flag>
- <flag name="audio">Enable audio support</flag>
<flag name="dtmf">Enable DTMF encoding/decoding support</flag>
<flag name="http">Enable HTTP support</flag>
<flag name="mail">Enable mail protocols (POP3/SMTP)</flag>
diff --git a/net-libs/ptlib/ptlib-2.10.10.ebuild b/net-libs/ptlib/ptlib-2.10.10.ebuild
index 02b9926322b1..eb53f6a3c44b 100644
--- a/net-libs/ptlib/ptlib-2.10.10.ebuild
+++ b/net-libs/ptlib/ptlib-2.10.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.10.ebuild,v 1.8 2013/04/16 13:27:50 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.10.ebuild,v 1.9 2014/05/15 12:04:06 ulm Exp $
EAPI="5"
@@ -15,19 +15,19 @@ LICENSE="MPL-1.0"
SLOT="0/${PV}"
KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86"
# default enabled are features from 'minsize', the most used according to ptlib
-IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+IUSE="alsa +asn debug doc +dtmf examples ffmpeg ftp +http ipv6
jabber ldap lua mail odbc oss pch pulseaudio qos remote sasl sdl serial
-shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+shmvideo snmp soap socks +sound ssl static-libs +stun telnet tts v4l +video
vxml wav xml xmlrpc"
CDEPEND="
- audio? ( alsa? ( media-libs/alsa-lib ) )
ldap? ( net-nds/openldap )
lua? ( dev-lang/lua )
odbc? ( dev-db/unixODBC )
pulseaudio? ( media-sound/pulseaudio )
sasl? ( dev-libs/cyrus-sasl:2 )
sdl? ( media-libs/libsdl )
+ sound? ( alsa? ( media-libs/alsa-lib ) )
ssl? ( dev-libs/openssl )
video? ( v4l? ( media-libs/libv4l ) )
xml? ( dev-libs/expat )
@@ -82,8 +82,8 @@ src_prepare() {
src_configure() {
local myconf=""
- # plugins are disabled only if ! audio and ! video
- if ! use audio && ! use video; then
+ # plugins are disabled only if ! sound and ! video
+ if ! use sound && ! use video; then
myconf="${myconf} --disable-plugins"
else
myconf="${myconf} --enable-plugins"
@@ -114,7 +114,6 @@ src_configure() {
--enable-pipechan \
--enable-resolver \
--enable-url \
- $(use_enable audio) \
$(use_enable alsa) \
$(use_enable asn) \
$(use_enable debug exceptions) \
@@ -146,6 +145,7 @@ src_configure() {
$(use_enable snmp) \
$(use_enable soap) \
$(use_enable socks) \
+ $(use_enable sound audio) \
$(use_enable ssl openssl) \
$(use_enable stun) \
$(use_enable telnet) \
@@ -187,7 +187,7 @@ src_install() {
dodoc History.txt ReadMe.txt ReadMe_QOS.txt || die "dodoc failed"
- if use audio || use video; then
+ if use sound || use video; then
newdoc plugins/ReadMe.txt ReadMe-Plugins.txt || die "newdoc failed"
fi
@@ -215,8 +215,8 @@ pkg_postinst() {
ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
fi
- if ! use audio || ! use video; then
- ewarn "You have disabled audio or video USE flags."
+ if ! use sound || ! use video; then
+ ewarn "You have disabled sound or video USE flags."
ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
ewarn "Having a feature enabled via use flag but disabled can lead to issues."
fi
diff --git a/net-libs/ptlib/ptlib-2.10.11.ebuild b/net-libs/ptlib/ptlib-2.10.11.ebuild
index f3ebfce86906..31e63aa67128 100644
--- a/net-libs/ptlib/ptlib-2.10.11.ebuild
+++ b/net-libs/ptlib/ptlib-2.10.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.11.ebuild,v 1.1 2014/04/29 07:58:15 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.11.ebuild,v 1.2 2014/05/15 12:04:06 ulm Exp $
EAPI="5"
@@ -15,19 +15,19 @@ LICENSE="MPL-1.0"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# default enabled are features from 'minsize', the most used according to ptlib
-IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+IUSE="alsa +asn debug doc +dtmf examples ffmpeg ftp +http ipv6
jabber ldap lua mail odbc oss pch pulseaudio qos remote sasl sdl serial
-shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+shmvideo snmp soap socks +sound ssl static-libs +stun telnet tts v4l +video
vxml wav xml xmlrpc"
CDEPEND="
- audio? ( alsa? ( media-libs/alsa-lib ) )
ldap? ( net-nds/openldap )
lua? ( dev-lang/lua )
odbc? ( dev-db/unixODBC )
pulseaudio? ( media-sound/pulseaudio )
sasl? ( dev-libs/cyrus-sasl:2 )
sdl? ( media-libs/libsdl )
+ sound? ( alsa? ( media-libs/alsa-lib ) )
ssl? ( dev-libs/openssl )
video? ( v4l? ( media-libs/libv4l ) )
xml? ( dev-libs/expat )
@@ -83,8 +83,8 @@ src_prepare() {
src_configure() {
local myconf=""
- # plugins are disabled only if ! audio and ! video
- if ! use audio && ! use video; then
+ # plugins are disabled only if ! sound and ! video
+ if ! use sound && ! use video; then
myconf="${myconf} --disable-plugins"
else
myconf="${myconf} --enable-plugins"
@@ -115,7 +115,6 @@ src_configure() {
--enable-pipechan \
--enable-resolver \
--enable-url \
- $(use_enable audio) \
$(use_enable alsa) \
$(use_enable asn) \
$(use_enable debug exceptions) \
@@ -147,6 +146,7 @@ src_configure() {
$(use_enable snmp) \
$(use_enable soap) \
$(use_enable socks) \
+ $(use_enable sound audio) \
$(use_enable ssl openssl) \
$(use_enable stun) \
$(use_enable telnet) \
@@ -188,7 +188,7 @@ src_install() {
dodoc History.txt ReadMe.txt ReadMe_QOS.txt || die "dodoc failed"
- if use audio || use video; then
+ if use sound || use video; then
newdoc plugins/ReadMe.txt ReadMe-Plugins.txt || die "newdoc failed"
fi
@@ -216,8 +216,8 @@ pkg_postinst() {
ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
fi
- if ! use audio || ! use video; then
- ewarn "You have disabled audio or video USE flags."
+ if ! use sound || ! use video; then
+ ewarn "You have disabled sound or video USE flags."
ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
ewarn "Having a feature enabled via use flag but disabled can lead to issues."
fi
diff --git a/net-libs/ptlib/ptlib-2.10.9.ebuild b/net-libs/ptlib/ptlib-2.10.9.ebuild
index 451a6a446c48..5237ff93cf01 100644
--- a/net-libs/ptlib/ptlib-2.10.9.ebuild
+++ b/net-libs/ptlib/ptlib-2.10.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.9.ebuild,v 1.1 2012/12/03 23:16:28 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.10.9.ebuild,v 1.2 2014/05/15 12:04:06 ulm Exp $
EAPI="4"
@@ -15,19 +15,19 @@ LICENSE="MPL-1.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# default enabled are features from 'minsize', the most used according to ptlib
-IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+IUSE="alsa +asn debug doc +dtmf examples ffmpeg ftp +http ipv6
jabber ldap lua mail odbc oss pch pulseaudio qos remote sasl sdl serial
-shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+shmvideo snmp soap socks +sound ssl static-libs +stun telnet tts v4l +video
vxml wav xml xmlrpc"
CDEPEND="
- audio? ( alsa? ( media-libs/alsa-lib ) )
ldap? ( net-nds/openldap )
lua? ( dev-lang/lua )
odbc? ( dev-db/unixODBC )
pulseaudio? ( media-sound/pulseaudio )
sasl? ( dev-libs/cyrus-sasl:2 )
sdl? ( media-libs/libsdl )
+ sound? ( alsa? ( media-libs/alsa-lib ) )
ssl? ( dev-libs/openssl )
video? ( v4l? ( media-libs/libv4l ) )
xml? ( dev-libs/expat )
@@ -77,8 +77,8 @@ src_prepare() {
src_configure() {
local myconf=""
- # plugins are disabled only if ! audio and ! video
- if ! use audio && ! use video; then
+ # plugins are disabled only if ! sound and ! video
+ if ! use sound && ! use video; then
myconf="${myconf} --disable-plugins"
else
myconf="${myconf} --enable-plugins"
@@ -109,7 +109,6 @@ src_configure() {
--enable-pipechan \
--enable-resolver \
--enable-url \
- $(use_enable audio) \
$(use_enable alsa) \
$(use_enable asn) \
$(use_enable debug exceptions) \
@@ -141,6 +140,7 @@ src_configure() {
$(use_enable snmp) \
$(use_enable soap) \
$(use_enable socks) \
+ $(use_enable sound audio) \
$(use_enable ssl openssl) \
$(use_enable stun) \
$(use_enable telnet) \
@@ -182,7 +182,7 @@ src_install() {
dodoc History.txt ReadMe.txt ReadMe_QOS.txt || die "dodoc failed"
- if use audio || use video; then
+ if use sound || use video; then
newdoc plugins/ReadMe.txt ReadMe-Plugins.txt || die "newdoc failed"
fi
@@ -210,8 +210,8 @@ pkg_postinst() {
ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
fi
- if ! use audio || ! use video; then
- ewarn "You have disabled audio or video USE flags."
+ if ! use sound || ! use video; then
+ ewarn "You have disabled sound or video USE flags."
ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
ewarn "Having a feature enabled via use flag but disabled can lead to issues."
fi
diff --git a/net-libs/ptlib/ptlib-2.12.4.ebuild b/net-libs/ptlib/ptlib-2.12.4.ebuild
index bf62542fafa2..5ff9443bc1d6 100644
--- a/net-libs/ptlib/ptlib-2.12.4.ebuild
+++ b/net-libs/ptlib/ptlib-2.12.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.4.ebuild,v 1.2 2013/06/24 09:57:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.4.ebuild,v 1.3 2014/05/15 12:04:06 ulm Exp $
EAPI=5
@@ -15,19 +15,19 @@ LICENSE="MPL-1.0"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# default enabled are features from 'minsize', the most used according to ptlib
-IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+IUSE="alsa +asn debug doc +dtmf examples ffmpeg ftp +http ipv6
jabber ldap lua mail odbc oss pch pulseaudio remote sasl sdl serial
-shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+shmvideo snmp soap socks +sound ssl static-libs +stun telnet tts v4l +video
vxml wav xml xmlrpc"
CDEPEND="
- audio? ( alsa? ( media-libs/alsa-lib ) )
ldap? ( net-nds/openldap )
lua? ( dev-lang/lua )
odbc? ( dev-db/unixODBC )
pulseaudio? ( media-sound/pulseaudio )
sasl? ( dev-libs/cyrus-sasl:2 )
sdl? ( media-libs/libsdl )
+ sound? ( alsa? ( media-libs/alsa-lib ) )
ssl? ( dev-libs/openssl )
video? ( v4l? ( media-libs/libv4l ) )
xml? ( dev-libs/expat )
@@ -78,8 +78,8 @@ src_prepare() {
src_configure() {
local myconf=""
- # plugins are disabled only if ! audio and ! video
- if ! use audio && ! use video; then
+ # plugins are disabled only if ! sound and ! video
+ if ! use sound && ! use video; then
myconf+=" --disable-plugins"
else
myconf+=" --enable-plugins"
@@ -110,7 +110,6 @@ src_configure() {
--enable-pipechan \
--enable-resolver \
--enable-url \
- $(use_enable audio) \
$(use_enable alsa) \
$(use_enable asn) \
$(use_enable debug exceptions) \
@@ -141,6 +140,7 @@ src_configure() {
$(use_enable snmp) \
$(use_enable soap) \
$(use_enable socks) \
+ $(use_enable sound audio) \
$(use_enable ssl openssl) \
$(use_enable stun) \
$(use_enable telnet) \
@@ -182,7 +182,7 @@ src_install() {
dodoc History.txt ReadMe.txt ReadMe_QOS.txt
- if use audio || use video; then
+ if use sound || use video; then
newdoc plugins/ReadMe.txt ReadMe-Plugins.txt
fi
@@ -210,8 +210,8 @@ pkg_postinst() {
ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
fi
- if ! use audio || ! use video; then
- ewarn "You have disabled audio or video USE flags."
+ if ! use sound || ! use video; then
+ ewarn "You have disabled sound or video USE flags."
ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
ewarn "Having a feature enabled via use flag but disabled can lead to issues."
fi
diff --git a/net-libs/ptlib/ptlib-2.12.9.ebuild b/net-libs/ptlib/ptlib-2.12.9.ebuild
index 0fd8e7a30704..e4a82941983f 100644
--- a/net-libs/ptlib/ptlib-2.12.9.ebuild
+++ b/net-libs/ptlib/ptlib-2.12.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.9.ebuild,v 1.1 2014/04/29 07:58:15 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.12.9.ebuild,v 1.2 2014/05/15 12:04:06 ulm Exp $
EAPI=5
@@ -15,19 +15,19 @@ LICENSE="MPL-1.0"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
# default enabled are features from 'minsize', the most used according to ptlib
-IUSE="alsa +asn +audio debug doc +dtmf examples ffmpeg ftp +http ipv6
+IUSE="alsa +asn debug doc +dtmf examples ffmpeg ftp +http ipv6
jabber ldap lua mail odbc oss pch pulseaudio remote sasl sdl serial
-shmvideo snmp soap socks ssl static-libs +stun telnet tts v4l +video
+shmvideo snmp soap socks +sound ssl static-libs +stun telnet tts v4l +video
vxml wav xml xmlrpc"
CDEPEND="
- audio? ( alsa? ( media-libs/alsa-lib ) )
ldap? ( net-nds/openldap )
lua? ( dev-lang/lua )
odbc? ( dev-db/unixODBC )
pulseaudio? ( media-sound/pulseaudio )
sasl? ( dev-libs/cyrus-sasl:2 )
sdl? ( media-libs/libsdl )
+ sound? ( alsa? ( media-libs/alsa-lib ) )
ssl? ( dev-libs/openssl )
video? ( v4l? ( media-libs/libv4l ) )
xml? ( dev-libs/expat )
@@ -78,8 +78,8 @@ src_prepare() {
src_configure() {
local myconf=""
- # plugins are disabled only if ! audio and ! video
- if ! use audio && ! use video; then
+ # plugins are disabled only if ! sound and ! video
+ if ! use sound && ! use video; then
myconf+=" --disable-plugins"
else
myconf+=" --enable-plugins"
@@ -110,7 +110,6 @@ src_configure() {
--enable-pipechan \
--enable-resolver \
--enable-url \
- $(use_enable audio) \
$(use_enable alsa) \
$(use_enable asn) \
$(use_enable debug exceptions) \
@@ -141,6 +140,7 @@ src_configure() {
$(use_enable snmp) \
$(use_enable soap) \
$(use_enable socks) \
+ $(use_enable sound audio) \
$(use_enable ssl openssl) \
$(use_enable stun) \
$(use_enable telnet) \
@@ -182,7 +182,7 @@ src_install() {
dodoc History.txt ReadMe.txt ReadMe_QOS.txt
- if use audio || use video; then
+ if use sound || use video; then
newdoc plugins/ReadMe.txt ReadMe-Plugins.txt
fi
@@ -210,8 +210,8 @@ pkg_postinst() {
ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
fi
- if ! use audio || ! use video; then
- ewarn "You have disabled audio or video USE flags."
+ if ! use sound || ! use video; then
+ ewarn "You have disabled sound or video USE flags."
ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
ewarn "Having a feature enabled via use flag but disabled can lead to issues."
fi
diff --git a/net-libs/ptlib/ptlib-2.6.7-r1.ebuild b/net-libs/ptlib/ptlib-2.6.7-r1.ebuild
index 0e5fcbdc79ff..61110345697f 100644
--- a/net-libs/ptlib/ptlib-2.6.7-r1.ebuild
+++ b/net-libs/ptlib/ptlib-2.6.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.6.7-r1.ebuild,v 1.15 2012/09/30 18:15:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ptlib/ptlib-2.6.7-r1.ebuild,v 1.16 2014/05/15 12:04:06 ulm Exp $
EAPI="2"
@@ -16,16 +16,16 @@ LICENSE="MPL-1.0"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
# default enabled are features from 'minsize', the most used according to ptlib
-IUSE="alsa +asn +audio debug doc dtmf examples ffmpeg ftp http ipv6
+IUSE="alsa +asn debug doc dtmf examples ffmpeg ftp http ipv6
jabber ldap mail odbc oss pch qos remote sasl sdl serial shmvideo snmp soap
-socks ssl static-libs +stun telnet tts v4l +video vxml wav xml xmlrpc"
+socks +sound ssl static-libs +stun telnet tts v4l +video vxml wav xml xmlrpc"
CDEPEND="
- audio? ( alsa? ( media-libs/alsa-lib ) )
ldap? ( net-nds/openldap )
odbc? ( dev-db/unixODBC )
sasl? ( dev-libs/cyrus-sasl:2 )
sdl? ( media-libs/libsdl )
+ sound? ( alsa? ( media-libs/alsa-lib ) )
ssl? ( dev-libs/openssl )
video? ( v4l? ( media-libs/libv4l ) )
xml? ( dev-libs/expat )
@@ -129,8 +129,8 @@ src_prepare() {
src_configure() {
local myconf=""
- # plugins are disabled only if ! audio and ! video
- if ! use audio && ! use video; then
+ # plugins are disabled only if ! sound and ! video
+ if ! use sound && ! use video; then
myconf="${myconf} --disable-plugins"
else
myconf="${myconf} --enable-plugins"
@@ -161,7 +161,6 @@ src_configure() {
--enable-pipechan \
--enable-resolver \
--enable-url \
- $(use_enable audio) \
$(use_enable alsa) \
$(use_enable asn) \
$(use_enable debug exceptions) \
@@ -191,6 +190,7 @@ src_configure() {
$(use_enable snmp) \
$(use_enable soap) \
$(use_enable socks) \
+ $(use_enable sound audio) \
$(use_enable ssl openssl) \
$(use_enable stun) \
$(use_enable telnet) \
@@ -235,7 +235,7 @@ src_install() {
# This version (2.6.7) doesn't have a ChangeLog file.
#dodoc ChangeLog-${PN}-v${PV//./_}.txt || die "dodoc failed"
- if use audio || use video; then
+ if use sound || use video; then
newdoc plugins/ReadMe.txt ReadMe-Plugins.txt || die "newdoc failed"
fi
@@ -263,8 +263,8 @@ pkg_postinst() {
ewarn "To test examples, you have to run PTLIBDIR=/usr/share/ptlib make"
fi
- if ! use audio || ! use video; then
- ewarn "You have disabled audio or video USE flags."
+ if ! use sound || ! use video; then
+ ewarn "You have disabled sound or video USE flags."
ewarn "Most audio/video have been disabled silently even if enabled via USE flags."
ewarn "Having a feature enabled via use flag but disabled can lead to issues."
fi