summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-13 16:13:17 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-13 16:13:17 +0000
commitb43cf9ef8940896f4bb9c21b3f19e2c4771cf5e2 (patch)
treef115f55c8831fc491fb9ace1ce3f16d7c391dd83 /net-libs/openslp
parentremoved old version (diff)
downloadgentoo-2-b43cf9ef8940896f4bb9c21b3f19e2c4771cf5e2.tar.gz
gentoo-2-b43cf9ef8940896f4bb9c21b3f19e2c4771cf5e2.tar.bz2
gentoo-2-b43cf9ef8940896f4bb9c21b3f19e2c4771cf5e2.zip
New package
Diffstat (limited to 'net-libs/openslp')
-rw-r--r--net-libs/openslp/files/digest-openslp-1.0.41
-rw-r--r--net-libs/openslp/openslp-1.0.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/openslp/files/digest-openslp-1.0.4 b/net-libs/openslp/files/digest-openslp-1.0.4
new file mode 100644
index 000000000000..f5d5ee0fa4b9
--- /dev/null
+++ b/net-libs/openslp/files/digest-openslp-1.0.4
@@ -0,0 +1 @@
+MD5 c947b76e251cee58207dba600318f027 openslp-1.0.4.tar.gz 593920
diff --git a/net-libs/openslp/openslp-1.0.4.ebuild b/net-libs/openslp/openslp-1.0.4.ebuild
new file mode 100644
index 000000000000..75ccc323b3ed
--- /dev/null
+++ b/net-libs/openslp/openslp-1.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/openslp-1.0.4.ebuild,v 1.1 2001/11/13 16:13:17 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An open-source implementation of Service Location Protocol"
+SRC_URI="http://prdownloads.sourceforge.net/openslp/${P}.tar.gz"
+HOMEPAGE="http://www.openslp.org"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure --prefix=/usr --sysconfdir=/etc/slp --host=${CHOST} || die
+ make || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README* THANKS
+ rm -rf ${D}/usr/doc
+ docinto html
+ cd doc
+ dodoc html/*.html
+ for i in IntroductionToSLP ProgrammersGuide UsersGuide
+ do
+ docinto html/*
+ dodoc html/$i/*.{jpg,html}
+ done
+ docinto rfc
+ dodoc rfc/*.{txt,html}
+
+}
+