summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-08 04:30:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-08 04:30:32 +0000
commit96288397df0bf84de72ef67735a0d148617d3e83 (patch)
tree0f681aa9bc820f76e9ea9cac4c03805756b387d2 /net-libs/libtorrent
parentBump (diff)
downloadgentoo-2-96288397df0bf84de72ef67735a0d148617d3e83.tar.gz
gentoo-2-96288397df0bf84de72ef67735a0d148617d3e83.tar.bz2
gentoo-2-96288397df0bf84de72ef67735a0d148617d3e83.zip
Bump for #396243
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog7
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.0.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 3f59d921ae01..fbef8be906ba 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.165 2012/03/07 21:50:37 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.166 2012/03/08 04:30:32 patrick Exp $
+
+*libtorrent-0.13.0 (08 Mar 2012)
+
+ 08 Mar 2012; Patrick Lauer <patrick@gentoo.org> +libtorrent-0.13.0.ebuild:
+ Bump for #396243
07 Mar 2012; Brent Baude <ranger@gentoo.org> libtorrent-0.12.9.ebuild:
Marking libtorrent-0.12.9 ppc64 for bug 389817
diff --git a/net-libs/libtorrent/libtorrent-0.13.0.ebuild b/net-libs/libtorrent/libtorrent-0.13.0.ebuild
new file mode 100644
index 000000000000..cd53738adedc
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.13.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.13.0.ebuild,v 1.1 2012/03/08 04:30:32 patrick Exp $
+
+EAPI=4
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="BitTorrent library written in C++ for *nix"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+# epatch "${FILESDIR}"/download_constructor.diff
+ elibtoolize
+}
+
+src_configure() {
+ # the configure check for posix_fallocate is wrong.
+ # reported upstream as Ticket 2416.
+ local myconf
+ echo "int main(){return posix_fallocate();}" > "${T}"/posix_fallocate.c
+ if $(tc-getCC) ${CFLAGS} ${LDFLAGS} "${T}"/posix_fallocate.c -o /dev/null 2>/dev/null ; then
+ myconf="--with-posix-fallocate"
+ else
+ myconf="--without-posix-fallocate"
+ fi
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}