summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-07-01 12:38:25 +0000
committerCédric Krier <cedk@gentoo.org>2007-07-01 12:38:25 +0000
commitc647b57c0be39f6d7a559003c561884026b29ce6 (patch)
tree94154d44d15e1c52ef7c126ff3ee0c7e62936c29 /net-libs/libssh2
parentAdd libcrypto flag for libssh2 (diff)
downloadgentoo-2-c647b57c0be39f6d7a559003c561884026b29ce6.tar.gz
gentoo-2-c647b57c0be39f6d7a559003c561884026b29ce6.tar.bz2
gentoo-2-c647b57c0be39f6d7a559003c561884026b29ce6.zip
Version bump
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/ChangeLog9
-rw-r--r--net-libs/libssh2/files/digest-libssh2-0.153
-rw-r--r--net-libs/libssh2/libssh2-0.15.ebuild29
3 files changed, 39 insertions, 2 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 6c5aaa716f21..d9f7082d36a4 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.1 2006/11/27 23:57:08 jokey Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.2 2007/07/01 12:38:25 cedk Exp $
+
+*libssh2-0.15 (01 Jul 2007)
+
+ 01 Jul 2007; Cédric Krier <cedk@gentoo.org> +libssh2-0.15.ebuild:
+ Version bump
*libssh2-0.14 (27 Nov 2006)
diff --git a/net-libs/libssh2/files/digest-libssh2-0.15 b/net-libs/libssh2/files/digest-libssh2-0.15
new file mode 100644
index 000000000000..2b3d71fe428f
--- /dev/null
+++ b/net-libs/libssh2/files/digest-libssh2-0.15
@@ -0,0 +1,3 @@
+MD5 6c641d6dc0d0e546249cad1d16f10a6a libssh2-0.15.tar.gz 513787
+RMD160 887a780a23893ea1709311a61e69b37041bc14be libssh2-0.15.tar.gz 513787
+SHA256 062cc96257a635a8800acbc84dc1555ac943df9ce040e2a40d6ffc39d07690cd libssh2-0.15.tar.gz 513787
diff --git a/net-libs/libssh2/libssh2-0.15.ebuild b/net-libs/libssh2/libssh2-0.15.ebuild
new file mode 100644
index 000000000000..4b1fdaf1bcfe
--- /dev/null
+++ b/net-libs/libssh2/libssh2-0.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-0.15.ebuild,v 1.1 2007/07/01 12:38:25 cedk Exp $
+
+inherit eutils
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="mirror://sourceforge/libssh2/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="libgcrypt"
+
+DEPEND="!libgcrypt? ( dev-libs/openssl )
+ libgcrypt? ( dev-libs/libgcrypt )
+ sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf $(use_enable libgcrypt) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}